yum update Problem

Discussion in 'General Discussion' started by mfgo_parusr, Sep 5, 2013.

  1. mfgo_parusr

    mfgo_parusr Kilo Poster

    Messages:
    27
    Hello,

    how can I fix this problem on my Virtuozzo-Host-Machine?

    input:
    yum update


    output:

    ...

    --> Finished Dependency Resolution
    Error: Package: virtuozzo-release-4.7.0-262.x86_64 (installed)
    Requires: nbd = 2.9.11-2
    Removing: nbd-2.9.11-2.x86_64 (installed)
    nbd = 2.9.11-2
    Updated By: nbd-2.9.20-7.el6.x86_64 (epel)
    nbd = 2.9.20-7.el6
    You could try using --skip-broken to work around the problem
    ** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
    vzmodules-2.6.32-042stab072.10.x86_64 is a duplicate with vzmodules-2.6.32-042stab032.1.x86_64
     
  2. Faris Raouf

    Faris Raouf Product Expert

    Messages:
    817
    You should try disabling the epel repo. It is not really recommended to have a third party repo on a hardware node, other than maybe temporarily for installing some specific package that is not in the base repo. It can lead to undesired problems like this.

    The "vzmodules-2.6.32-042stab072.10.x86_64 is a duplicate with vzmodules-2.6.32-042stab032.1.x86_64" is a common issue - I see it all the time. It is harmless as far as I can tell. Try "yum clean all" but I don't think it will resolve it.
     
  3. KristianM

    KristianM Product Expert

    Messages:
    469
    Hi,

    the best way to resolve this issue, is by checking which Version of the Kernel is actually booted and remove all unused ones incl. the respective vzmodules.
    You should then be able to install/upgrade to the most recent. After a reboot you can then again remove the old version of the kernel and it's respective vzmodules.

    Regards,
    Kristian
     

Share This Page