Workarounds

Discussion in 'Plesk 9.x for Windows Issue, Fixes, How-To' started by IgorG, Nov 11, 2009.

Thread Status:
Not open for further replies.
  1. IgorG

    IgorG Guru

    Messages:
    19,081
    Need to add 'allow' firewall rule for port 9998 automatically when switch to Smarterm

    Plesk 9.5.x

    Need to add 'allow' rule to firewall for TCP port 9998 automatically when switch to SmarterMail.

    SOLUTION:

    Attach has implemented this feature as requested:
    When smartermail webmail is switching on firewall rule for port 9998 is added. When SMWebmail is switching off the rule is disabled.
     

    Attached Files:

  2. IgorG

    IgorG Guru

    Messages:
    19,081
    Can not access Firewall configuration

    Plesk Panel 9.5.2
    Windows 2008

    Can not access to Firewall configuration:

    Home > Settings > IP Addresses > Firewall

    Windows Firewall and rules can be opened/viewed with no issue.

    SOLUTION:

    Use attached version of psa.ip.device.dll
     

    Attached Files:

  3. IgorG

    IgorG Guru

    Messages:
    19,081
    Security problem with permission

    Plesk Panel 9.5.2

    Customer has Plesk servers with Plesk default permissions and settings in windows\temp folder and php.ini for php5 version. He checked the IUSR permission and found that based on psacln group and its permission on temp folder, all php sessions and all windows temp folder is accessible for the users and it could cause some problems such as session hijacking and so on. He wants to know what is the best solution to protect temp folder and subfolders? And how can he prevent accessing temp folder without making problem for Plesk?

    SOLUTION:

    You can change session save_path as described at http://www.php.net/manual/en/configuration.changes.php#configuration.changes.windows:

    1. Create key HKEY_LOCAL_MACHINE\SOFTWARE\PHP\Per Directory Values\c\inetpub\vhosts\<domain>.
    2. Create string value 'session.save_path' = 'C:\Inetpub\vhosts\<domain>\private'.

    Now session files for <domain> will be stored in 'private' dir.
     
Thread Status:
Not open for further replies.

Share This Page