Weird email problem

Discussion in 'Plesk 6.0 Troubleshooting and Problems' started by Zoke, Nov 9, 2003.

  1. Zoke

    Zoke Kilo Poster

    Messages:
    47
    I'm experiencing a very odd email problem (using RH9 + Plesk 6.0.2). Each email which is sent out has 2 enters everywhere instead of one. I've changed nothing of the default mail server settings after the linux & plesk install, this problem has been there from the beginning, i.e. with automated vbulletin emails.

    This problem only occurs with emails sent through web applications such as vbulletin.
     
  2. happyadmin

    happyadmin Guest

    Dear Zoke,

    As this problem happens with vbulletin you can be sure that no problem is with your mail server. This seems to be a problem with your mail() script in vbulletin. Try to comment the lines \"echo the pdf buffer to the screen\" in your script. This might help you to solve your problem.

    Regards,
     
  3. Zoke

    Zoke Kilo Poster

    Messages:
    47
    I don't know. Here are my thoughts on it:

    It can't be my email client because I tried with many different ones, Outlook Express, Outlook 2000, Outlook XP, Outlook 2003.

    It can't be vbulletin because I did a clean vbulletin install (without any hacks) and while for example the thread notification I just received from this vB, when mine sends one out it has double enters everywhere.

    Which is leaving me with the question what's causing the problem. I doubt that it's a vbulletin problem since I'm the only one experiencing this problem but as you suggested I'll look into that tomorrow.
     
  4. Zoke

    Zoke Kilo Poster

    Messages:
    47
    I did a RH9 kickstart installation on vmware identical to my linux server without plesk. With this I found out that an empty Redhat 9 installation also gives this error, which only shows to users using Office XP (aka 2002) and Office 2003.

    I've updated various packages, MySQL, Apache, PHP but the package that fixed this is sendmail. (up2date sendmail)

    However, how safe is it to update sendmail when you're using Plesk 6.0.2?


    EDIT:
     
  5. Ales

    Ales Guru

    Messages:
    867
    Sendmail is not used on a Plesk server at all, qmail is. If you update it, you might loose symlinks that qmail sets up to function properly. No big deal to fix, but updating sendmail won't help with your problem...
     
  6. Zoke

    Zoke Kilo Poster

    Messages:
    47
  7. jimroe

    jimroe Guru

    Messages:
    2,067
    Yes - but it's tricky - on several fronts:

    This patch patches qmail-smtpd - which Plesk has already patched with a number of patches - the ones I know about are big DNS, SMTP-AUTH, and big concurrency. Furthermore, you have to patch the Qmail source for an errno patch to get it to build under the RH9 glibc. And THEN you have to apply this patch (and determine if all the patches are mutually compatible) and rebuild qmail to get the patched qmail-smtpd binary you need.

    Due to some other things that Plesk has done with Qmail (how they handle POP before SMTP relay locking comes to mind) you would NOT want to attempt to replace the entire Plesk Qmail installation - just the qmail-smtpd binary.

    So if you're comfortable patching and compiling from source, this could be done.
     
  8. Zoke

    Zoke Kilo Poster

    Messages:
    47
    Thank you for your reply,

    I've just tried adding the following to the PHP script and it fixed the problem that I was having:
    PHP:
    $content str_replace("\r\n""\n""$content");
    However, I cannot add this to vbulletin's code so there needs to be a workaround, for example this Qmail patch if it would have the same result.
    There's also another patch available:
    http://qmail.software-archive.net/qmail-smtpd-newline-1.03.patch

    But I'm not sure if I'd get the same result with this patch. It looks like the exact opposite of what I need.


    I've tried compiling the new qmail-smtpd file and overwrote the original one. I added qmail-inject to php.ini (instead of the sendmail file) but it all didn't matter anything. It sends out email but still with the double newline.
     

Share This Page