Webmail short name login

Discussion in 'Plesk Automation Suggestions and Feedback' started by ViaHosting, Feb 2, 2015.

  1. ViaHosting

    ViaHosting Kilo Poster

    Messages:
    74
    I'm not able to login in webmails with shot names, in Horde, nor in RoundCube.

    Ex: webmail.domain.tld
    username: user1


    I must use the full email address as username

    Ex: webmail.domain.tld
    username: user1@domain.tld

    It seens it not find the server.

    In Plesk Panel it works fine.
     
  2. abdi

    abdi Product Expert

    Messages:
    2,755
    Hello Alexandre,
    Are you able to login with the full email address + password instead?
     
  3. ViaHosting

    ViaHosting Kilo Poster

    Messages:
    74
    Yes, I can login with the full email address.

    But not with short names.
     
  4. abdi

    abdi Product Expert

    Messages:
    2,755
  5. ViaHosting

    ViaHosting Kilo Poster

    Messages:
    74
    Abdi,

    This doesn't fix the problem.

    The problem is not the shotname, but the authentication of Horde.

    Here is my scenario:
    - one server with ppa management + Webmail
    - another server with postfix

    If I use the full email address, it authenticates at the postfix server,
    but when i use the short name, the Horde concatenate the username and server name,
    giving the full address name correctly, but it tries to authenticate locally, not at postfix server.

    The problem is logged at the webmail server maillog:
    Feb 11 15:05:50 ppa courier-imapd: Connection, ip=[::ffff:127.0.0.1]
    Feb 11 15:05:50 ppa authpsa[357]: No such user 'mikrotik@dominio.com.br' in mail authorization database
    Feb 11 15:05:50 ppa courier-imapd: LOGIN FAILED, method=PLAIN, ip=[::ffff:127.0.0.1]
    Feb 11 15:05:55 ppa authpsa[357]: No such user 'mikrotik@dominio.com.br' in mail authorization database
    Feb 11 15:05:55 ppa courier-imapd: LOGIN FAILED, method=CRAM-MD5, ip=[::ffff:127.0.0.1]
    Feb 11 15:06:00 ppa authpsa[357]: No such user 'mikrotik@dominio.com.br' in mail authorization database
    Feb 11 15:06:00 ppa courier-imapd: LOGIN FAILED, method=CRAM-SHA1, ip=[::ffff:127.0.0.1]
    Feb 11 15:06:05 ppa authpsa[357]: No such user 'mikrotik@dominio.com.br' in mail authorization database
    Feb 11 15:06:05 ppa courier-imapd: LOGIN FAILED, method=CRAM-SHA256, ip=[::ffff:127.0.0.1]
    Feb 11 15:06:10 ppa authpsa[357]: No such user 'mikrotik@dominio.com.br' in mail authorization database
    Feb 11 15:06:10 ppa courier-imapd: LOGIN FAILED, user=mikrotik@dominio.com.br, ip=[::ffff:127.0.0.1]
    Feb 11 15:06:16 ppa courier-imapd: Disconnected, ip=[::ffff:127.0.0.1], time=25, starttls=1
     
  6. abdi

    abdi Product Expert

    Messages:
    2,755
    Hello Barbosa,

    It looks like the Berkeley Database with credentials of all mail accounts is missing. The database should be recreated. Use Plesk utility mail_auth_dump:

    Code:
    /usr/local/psa/admin/sbin/mail_auth_dump
    Code:
    file /var/lib/plesk/mail/auth/passwd.db
     
  7. ViaHosting

    ViaHosting Kilo Poster

    Messages:
    74
    Hi Abdi,

    Nope.
    This command didn't works.

    [root@ppa ~]# /usr/local/psa/admin/sbin/mail_auth_dump
    -bash: /usr/local/psa/admin/sbin/mail_auth_dump: No such file or directory


    Remember that the webmail server is not the same as the postfix.
    The email accounts are at a remote server.
     
  8. rgfincher

    rgfincher Kilo Poster

    Messages:
    18
    I've been caught like this before. I found that short names (lacking the domain name) only work when qmail is the MTA you have installed, NOT when PostFix is the default MTA installed.
     
  9. ViaHosting

    ViaHosting Kilo Poster

    Messages:
    74
    I have another Plesk server with Postfix and it works fine.

    The problem here seems to be the authentication at a remote server.
     
  10. rgfincher

    rgfincher Kilo Poster

    Messages:
    18
    OK, I guess the issue I had was a different one then.
     

Share This Page