Virtuozzo Node (PSBM) CPU General Setting TAB

Discussion in 'General Discussion' started by GerardoA, Oct 9, 2011.

  1. GerardoA

    GerardoA Kilo Poster

    Messages:
    18
    Hi Everyone

    Please excuse me if I'm not posting correctly this is my first post at the forum so please excuse if i have not posted appropriately.

    Problem Description:

    We recently upgraded to PBAS 4.1.4 & Parallels Server 5 from v4, when editing the following settings:

    PBAS > Top > Service Director > Virtuozzo Manager > Nodes > NodeName > General Settings (TAB) > EDIT

    We are trying to update the VZ Agent 2.5 > v4.6 to be inline with the updated PVA & PVA Agent (Latest versions) installed on the servers.

    After changing the drop down box to show 4.6 and entering in our server credentials and pressing the UPDATE button we are greeted with the following error:

    Value 0 specified for 'Number of CPUs to handle all the processes inside Container' is less than the minimum allowed (1 CPU(s))

    The CPU is already set to "8" from prior to upgrade of both systems.

    We have tried to change the CPU to > 1, 4 etc with no success PBAS will not save the new settings and keeps showing the same error.

    Everything was working fine prior to the upgrade as we had made an adjustment to the CPU settings just prior to upgrade and this saved successfully.

    As a side note we made a similar change to another server and everything was saved successfully and updated to the new VZAGENT 4.6.

    Any help would be greatly appreciated.

    Thank you.
     
  2. vbatraev

    vbatraev Odin Team

    Messages:
    346
    On HW node update, Containers located on it are updated also.
    Looks like a Container update failed with this error message.
    I suggest you to check and correct Containers configuration at PCC > Service Director > Virtuozzo Manager > Containers > a Container, "Configuration" tab.
     
  3. GerardoA

    GerardoA Kilo Poster

    Messages:
    18
    Ok dose this mean that all previous subscriptions that have 0 CPU = Unlimited need to be upgraded to have a physical number 1 - 8 attached to the hosting plan.

    I have found a number of subscriptions that have the unlimited CPU = 0 value attached to them and it will be a big task to upgrade all subscriptions to new hosting plans.

    This must be an oversight because this is not a logical solution as there will be a lot of PBAS users that have upgraded from a previous version that will have had CPU = 0 Unlimited usage this just breaks everything in PBAS.

    Not really a good upgrade if you ask me.

    Do we have any other suggestions for this as using VZAgent 2.5 is causing quiet a few problems on the newly upgraded PSBM5 node when trying to manage Virtuozzo CT.

    Looking forward to finding a suitable solution.

    ""Cheers
     
  4. vbatraev

    vbatraev Odin Team

    Messages:
    346
    Hi Gerardo,

    "0" doesn't equal "unlimited". There is a separate "is_unlim" flag for a resource in both subscription and hosting plan.
    It's hard to say why you get this error w/o access to your installation. I suggest either to set correct settings in hosting plan and then upgrade subscriptions to its latest version or submit a ticket to Parallels support for investigation. Once it will be clear what is wrong, it may be corrected in DB manually.

    P.S. I were not able to reproduce this issue on my installation. Upgrade went fine that I see no errors on node settings update. The resource is unlimited on my Container, as expected.
     
  5. GerardoA

    GerardoA Kilo Poster

    Messages:
    18
    Hi Victor

    Thanks for the info, i actually manually changed every hosting plan and then manually upgraded each subscription, every subscription failed to sync with the Node (Probably because VZAgent 2.5 was still selected) but it did manage to update PBAS DB with the correct CPU = 4 setting so once they where all done i could change the HWN setting to VZAgent 4.6 and CT started to sync with PBAS again.

    Prior to this we couldn't even launch, create, shutdown etc any CT from PBAS on this NODE.

    This was most clearly a PBAS DB issue due to the upgrade this is now resolved and working as it should be.

    The CPU = 0 setting was there by default in the hosting plan when you ticked the Unlimited box in hosting plan is shows as 0 in top > service director > virtuoso manager > containers > container > config > advanced settings

    we have never manually entered 0 for a setting only ticked the box marked unlimited.

    Thanks for your assistance and pointing me in the correct direction would have taken me days to work that one out ;)

    ""Cheers
     

Share This Page