Virtuozzo Containers for Windows on virtuozzo 7

Discussion in 'General Questions' started by akiyuki, Aug 1, 2016.

  1. akiyuki

    akiyuki Bit Poster

    Messages:
    7
    Hello.
    new virtuozzo 7 was released on end of last month.
    can I install Virtuozzo Containers for Windows 6.0 on virtuozzo 7 as vm?
    virtuozzo 6 was ok,but do not know on virtuozzo 7

    Thanks.
     
  2. Pavel

    Pavel A.I. Auto-Responder Odin Team

    Messages:
    403
    Hello,

    We haven't discovered any compatibility issues so far, neither anyone reported them. So, feel free to test.
    If you notice any problems while using PCW6 on VZ7 VM - please report them to support.
     
  3. Mike Pit

    Mike Pit Bit Poster

    Messages:
    3
    Hello, akiyuki
    I agree with pavel, you can test and share and post your experience with us so that we can get a better idea of any compatibility issues.
     
  4. akiyuki

    akiyuki Bit Poster

    Messages:
    7
    Hello.
    I could install Virtuozzo Containers for Windows 6.0 on virtuozzo 7
    but I stuck on licence problem.
    support says
    "
    In the VM you have configured 16 CPU. In order to make this setup licensed properly
    the license for Virtuozzo Containers for Windows installed in the VM
    need to be upgraded to support 16 CPU instead of 2.
    "
    I need to buy 16 cpu license even though hardware node is only 2 cpu.
    I can not solve this issue.
     
  5. Pavel

    Pavel A.I. Auto-Responder Odin Team

    Messages:
    403
    Hello Akiyuki,

    Thanks for reporting this - I assume I missed this fact because I used a trial license.
    License always accounts amount of sockets, not amount of cores. Unfortunately for us KVM represents each "vcpu" as a separate socket in this scenario, thus creating heavy overhead for the license.

    I'll see what can be done about and get back to you afterwards.
    Do you need a trial license so you can test the rest of the PCW-in-vz7 aspects?
     
  6. Pavel

    Pavel A.I. Auto-Responder Odin Team

    Messages:
    403
    Hello Akiyuki,

    KVM can be configured in any way - to represent vcpu as a thread (as in hyperthreading), as a socket, as a core...
    It's just prlctl configures it as a socket.
    We'll consider changing the behavior, for now you can edit libvirt config directly to make sure VM represents vcpu's as a cores, not as a sockets.

    It can be done in a following way:

    step 1 - open libvirt config for editing:
    Code:
    # virsh edit <VMname>
    
    step 2 - add topology to <cpu> directive:
    Code:
    ...
      <cpu mode='custom' match='exact'>
        <topology sockets='1' cores='16' threads='1'/>
        <model fallback='allow'>Haswell-noTSX</model>
    ...
    
     
  7. akiyuki

    akiyuki Bit Poster

    Messages:
    7
    Hello.
    Thanks Pavel,but I got a following errors
    "
    error: internal error: Unable to parse RNG /usr/share/libvirt/schemas/domain.rng: Element or text conflicts in interleave
    Failed. Try again? [y,n,i,f,?]:i
    error: Maximum CPUs greater than topology limit
    "
     
  8. Pavel

    Pavel A.I. Auto-Responder Odin Team

    Messages:
    403
    Can you post in here "cpu" and "vcpu" directives content?
     
  9. akiyuki

    akiyuki Bit Poster

    Messages:
    7
    Hello.
    I do not know how to "cpu" and "vcpu" directives content.
    Is this ok?

    <vcpu placement='static' current='16'>32</vcpu>

    [root@cloudst21 akimai_st21]# virsh dominfo 20008R2_VM3
    Id: -
    Name: 20008R2_VM3
    UUID: *********
    OS Type: hvm
    State: shut off
    CPU(s): 16
    Max memory: 39845888 KiB
    Used memory: 31457280 KiB
    Persistent: yes
    Autostart: disable
    Managed save: no
    Security model: none
    Security DOI: 0

    [root@******]# virsh nodeinfo
    CPU model: x86_64
    CPU(s): 32
    CPU frequency: 1872 MHz
    CPU socket(s): 1
    Core(s) per socket: 8
    Thread(s) per core: 2
    NUMA cell(s): 2
    Memory size: 131822208 KiB


    [root@***** ]# virsh vcpuinfo 20008R2_VM3
    VCPU: 0
    CPU: N/A
    State: N/A
    CPU time N/A
    CPU Affinity: yyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyy

    VCPU: 1
    CPU: N/A
    State: N/A
    CPU time N/A
    CPU Affinity: yyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyy

    VCPU: 2
    CPU: N/A
    State: N/A
    CPU time N/A
    CPU Affinity: yyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyy

    VCPU: 3
    CPU: N/A
    State: N/A
    CPU time N/A
    CPU Affinity: yyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyy

    VCPU: 4
    CPU: N/A
    State: N/A
    CPU time N/A
    CPU Affinity: yyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyy

    VCPU: 5
    CPU: N/A
    State: N/A
    CPU time N/A
    CPU Affinity: yyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyy

    VCPU: 6
    CPU: N/A
    State: N/A
    CPU time N/A
    CPU Affinity: yyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyy

    VCPU: 7
    CPU: N/A
    State: N/A
    CPU time N/A
    CPU Affinity: yyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyy

    VCPU: 8
    CPU: N/A
    State: N/A
    CPU time N/A
    CPU Affinity: yyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyy

    VCPU: 9
    CPU: N/A
    State: N/A
    CPU time N/A
    CPU Affinity: yyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyy

    VCPU: 10
    CPU: N/A
    State: N/A
    CPU time N/A
    CPU Affinity: yyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyy

    VCPU: 11
    CPU: N/A
    State: N/A
    CPU time N/A
    CPU Affinity: yyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyy

    VCPU: 12
    CPU: N/A
    State: N/A
    CPU time N/A
    CPU Affinity: yyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyy

    VCPU: 13
    CPU: N/A
    State: N/A
    CPU time N/A
    CPU Affinity: yyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyy

    VCPU: 14
    CPU: N/A
    State: N/A
    CPU time N/A
    CPU Affinity: yyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyy

    VCPU: 15
    CPU: N/A
    State: N/A
    CPU time N/A
    CPU Affinity: yyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyy
     
  10. Pavel

    Pavel A.I. Auto-Responder Odin Team

    Messages:
    403
    Hello,

    No, this won't really help.
    You've copied "vcpu" from "virsh edit", you can get "cpu" from the same place, if you scroll down a bit.

    Although I think I know what happened - you have hotplug enabled (maximum possible is 32 cpus, but use 16 right now):
    Code:
    <vcpu placement='static' current='16'>32</vcpu>
    
    Which means that VM might use up to 32 CPUs, but currently only uses 16 (that is how hotplug works - adds the maximum allowed and masks the unused part).
    Thus, in "topology", you should you 32 instead of 16 - that's what the error was about.
    It won't actually show 32 to you, but configuration must match the "max limit" set in "vcpu" line.
     
  11. akiyuki

    akiyuki Bit Poster

    Messages:
    7
    sorry

    <cpu mode='custom' match='exact'>
    <model fallback='allow'>SandyBridge</model>
    <topology sockets='1' cores='32' threads='1'/>
    <feature policy='require' name='pdpe1gb'/>
    <feature policy='require' name='osxsave'/>
    <feature policy='require' name='dca'/>
    <feature policy='require' name='pcid'/>
    <feature policy='require' name='pdcm'/>
    <feature policy='require' name='xtpr'/>
    <feature policy='require' name='tm2'/>
    <feature policy='require' name='est'/>
    <feature policy='require' name='smx'/>
    <feature policy='require' name='ds_cpl'/>
    <feature policy='require' name='monitor'/>
    <feature policy='require' name='dtes64'/>
    <feature policy='require' name='pbe'/>
    <feature policy='require' name='tm'/>
    <feature policy='require' name='ht'/>
    <feature policy='require' name='ss'/>
    <feature policy='require' name='acpi'/>
    <feature policy='require' name='ds'/>
    <feature policy='require' name='vme'/>
    <feature policy='disable' name='vmx'/>
    <numa>
    <cell id='0' cpus='0-15' memory='39845888' unit='KiB'/>
    </numa>
    </cpu>
     
  12. akiyuki

    akiyuki Bit Poster

    Messages:
    7
    Hello.
    after changed to 32, it seems works fine.
    Also license error was gone.
    Thanks for support.
    I will continue testing.
     
  13. Pavel

    Pavel A.I. Auto-Responder Odin Team

    Messages:
    403
    No problem, glad it helped! Good luck with testing!
     
  14. akiyuki

    akiyuki Bit Poster

    Messages:
    7
  15. Pavel

    Pavel A.I. Auto-Responder Odin Team

    Messages:
    403
    That is not exactly a problem, that is expected behavior. One must always disable ip filter and mac filter for VM when running Virtuozzo inside of it - be it linux or windows.
     

Share This Page