url problem in IE11 after update

Discussion in 'Troubleshooting' started by IATechsupport, Aug 2, 2016.

Tags:
  1. IATechsupport

    IATechsupport Kilo Poster

    Messages:
    81
    After doing the latest update of PBAS/OBAS to 4.5.6.33 we are having various issues with links.
    1) Useing IE11 to open pbas after clearing its cache and then selecting plesk domain to login to we get this in the browser,
    "You will be redirected to https://iaweb303.i-a.co.uk:8443/ent...zone,home/p_le,1/&locale=en-US&no_frames=true now. If this is not taking place, just follow the link. " and then just opens our ia-hosting.com site.

    2) If we login directly to the plesk container from pbas, and then select logout we get,
    ERROR: PleskFatalException
    Original link and target URL should be on the same domain.
    Search for related Knowledge Base articles

    3) After the pbas update the last one, which changes logo's to ODIN etc we have also lost the latest
    version of the default store, it has reverted back to the previous one.

    It seems to all be related to the update somehow.
     
  2. dkolvakh

    dkolvakh Odin Team

    Messages:
    346
    Hello.

    Please create an incident in the Odin support.
     
  3. IATechsupport

    IATechsupport Kilo Poster

    Messages:
    81
    These issues only seem to affect us and not the customer, so we don't really want to spend money on a ticket and especially as it was fine before the update.
     
  4. dkolvakh

    dkolvakh Odin Team

    Messages:
    346
    Well, I'll try to reproduce this behavior on my test lab and will return back to you with results.
     
  5. IATechsupport

    IATechsupport Kilo Poster

    Messages:
    81
    Thanks for your help.
     
  6. dkolvakh

    dkolvakh Odin Team

    Messages:
    346
    Hello.

    Regarding 1), I cannot reproduce this with Plesk 12.5.30 Update #40. Login to CP works well, indeed if I add alias plesk_domain_view_tab_gen_settings to the list of "URIs Do Not Require Referrer". Can you please give more details like Plesk version/platform etc?
    2) has been reproduced, and I suppose that this is some kind of Plesk+IE11 (with it's secure "security") bug.
    3) If you are talking about lost Store customization, such behavior means that you customized it not in the right way, f.e. change original templates instead of making copy and customize copy of template in the correct place.
     
  7. IATechsupport

    IATechsupport Kilo Poster

    Messages:
    81
    1) OBAS version 4.5.6-33 (CentOS 6) and Plesk 12.5.30 (CentOS 6). Login to Plesk from OBAS and then log out of plesk. Thats when the error happens
    2) ?
    3) I may have confused the situation by mentioning customization, This issue is not about that at all if you go here you will see the default OLD store https://cpanel.ia-hosting.com/hspc/index.php
    When before the last update it was the new version thats looks like Plesk 12 theme and with sliders etc
     
  8. IATechsupport

    IATechsupport Kilo Poster

    Messages:
    81
  9. dkolvakh

    dkolvakh Odin Team

    Messages:
    346
    As I said, I cannot reproduce issue with login to PD CP, and issue with logout from Plesk Admin CP was reproduced only once, and then works fine. To investigate issue further I need an access to your set.

    Regarding Store, I do not understand your complain. Dynamic store exists in OBAS since 4.3.3, and locations/urls aren't changed since that time. What do you mean by saying "not working correctly"?
     
  10. IATechsupport

    IATechsupport Kilo Poster

    Messages:
    81
    What do you need access to? cpanel or the server its on ?

    The problem with the store is its not showing any products none of the links work on this link https://cpanel.ia-hosting.com/shop
     
  11. dkolvakh

    dkolvakh Odin Team

    Messages:
    346
    Store do not showing any plans because there are some misconfig or miscustomization. Just take a look on it with JS debugger enabled.

    If you want to continue investigation of a Plesk CP problems and Store problems I need an access both to PCC and SSH to OBAS MN.
     
    Last edited: Aug 9, 2016
  12. IATechsupport

    IATechsupport Kilo Poster

    Messages:
    81
    I will try the JS debugger first, and if I can't work it out I will sort out access for you. Thanks
     

Share This Page