Update to Service Templates not propegating

Discussion in 'Plesk Automation Suggestions and Feedback' started by nahosting, Jun 9, 2013.

  1. nahosting

    nahosting Kilo Poster

    Messages:
    28
    Update to Service Templates not propagating

    In ppa_operations_guide.pdf in the 'Editing Service Templates' it says

    We don't seem to have such a button and changes to the service template are not being reflect on the clients accounts.
     
    Last edited: Jun 9, 2013
  2. IgorG

    IgorG Guru

    Messages:
    19,081
    Do you mean that you haven't button as on attached screenshot?
    22222.jpg
     
  3. nahosting

    nahosting Kilo Poster

    Messages:
    28
    Hi Igor,

    That's right - that button is not there - Note : This is on a reseller account.

    ppa.jpg

    Cheers,
     
  4. Andrew Andriatis

    Andrew Andriatis Odin Team

    Messages:
    437
    Hi,
    That's true that the changes in the service templates are not propagated as desired. We are fixing this in an upcoming patch. Can give you one clue, which might help till the patch is available.
    To update the existing services, make a copy of the service template, make changes for a service activation parameters and change any limit on this resource itself or any limit inside this resource. After that switch the subscription from the old to the newly defined service template.
    I realize that this is a dirty hack, but this is the only reliable way of doing this for now. As I said, we are fixing it.

    Regards,
    Andrey Andriatis
     
  5. Xamine

    Xamine Bit Poster

    Messages:
    6
    Another way if you are changing resource limits is to make the changes in the existing service template, then go to each subscriptions and click "Upgrade". The changes then propagate.
     
  6. Andrew Andriatis

    Andrew Andriatis Odin Team

    Messages:
    437
    Just FYI. This was fixed in update 11. There is one outstanding bug though. After a service template update is applied to a subscription, the mail service is turned off. Need to manually put if back from the hosting panel. The fix is coming.
     

Share This Page