Update #4 fails with "CANNOT PING" but this is not true

Discussion in 'Plesk Automation Suggestions and Feedback' started by eugenevdm, Apr 21, 2014.

  1. eugenevdm

    eugenevdm Guru

    Messages:
    622
    Trying to Update from #3 to #4 I get viewing /usr/local/ppa/log/ppaupdate.log:

    But I can PING host:
    [root@ppa ~]# ping db1.yyyyyy.net
    PING db1.yyyyyy.net (196.xxx.6.31) 56(84) bytes of data.
    64 bytes from db1.yyyyyy.net (196.xxx.6.31): icmp_seq=1 ttl=64 time=0.648 ms
    64 bytes from db1.yyyyyy.net (196.xxx.6.31): icmp_seq=2 ttl=64 time=0.277 ms


    I can also NMAP host:
    Starting Nmap 4.11 ( http://www.insecure.org/nmap/ ) at 2014-04-22 07:19 SAST
    Interesting ports on db1.yyyyyy.net (196.xxx.6.31):
    Not shown: 1676 closed ports
    PORT STATE SERVICE
    22/tcp open ssh
    111/tcp open rpcbind
    3306/tcp open mysql
    8443/tcp open https-alt
    MAC Address: 00:xx:xx:BE:0F:0D (VMWare)


    Finally in PPA the host is up, see attached screenshot.
    Screenshot from 2014-04-22 07:38:08.png
     
  2. Andrey Dobrenko

    Andrey Dobrenko Odin Team

    Messages:
    256
    No quite so. This host is temporary down because PPA agent doesn't respond. It's not about system ping:) The host itself is available, but agent ports 8352/8354 are not listened. It can be caused by many reasons. The easy way to check is to try to restart PPA agent on service node: /etc/init.d/pem restart in manner way to see what's exactly wrong.
     
  3. eugenevdm

    eugenevdm Guru

    Messages:
    622
    Perfect this worked. On two of three servers the agent was not started. So after starting it worked.

    So I guess thrown off by the pingHost message but yes I see that ping can be used generically to say "it's not available". So if I really wanted to be elaborate in my debug messages then I would have changed the error message from:

    to

    Incidentally the servers are incredibly stable and the only "change" recently was a reboot after yum upgrade to preempt heart bleed issues. So I guess after reboot the pem agent didn't start up so I'll check this next time.

    Finally I would really like to congratulate you on your technical support. I've been using Plesk since 2003 and in the last few years your technical support has gone from not so great to extremely world-class. I am super amazed at the help we get these days. Thank you!!!

    PPA is great and our environment has never been this stable.
     
    Last edited: Apr 22, 2014
  4. Andrey Dobrenko

    Andrey Dobrenko Odin Team

    Messages:
    256
    OK. We'll improve pre-checks in PPA updater to provide more clear explanation of the problem. Thanks!
     

Share This Page