Unable to Install, Problem: /usr/local/psa/bin/secret_key

Discussion in 'Plesk Automation Suggestions and Feedback' started by Cyrillv, Mar 27, 2013.

  1. Cyrillv

    Cyrillv Bit Poster

    Messages:
    4
    ok

    i really have a problem with installing ppa.
    os is centos5.9

    i did:
    Code:
    export LANG=en_us.utf8
    ./ppa_installer.sh --password CENSORED --admin_email censored@censored.ch --set_default_lang de_DE
    
    it stops to work on this line:
    Code:
    [Wed Mar 27 07:21:48 2013][INFO] Register secret key in Plesk...
    [Wed Mar 27 07:21:48 2013][ERROR] Unable to generate secret key. Result of execution utility '/usr/local/psa/bin/secret_key': Warning: Current locale is unusable. Using 'C' instead. 7e02d7ed1bfbec119a1d848f8c05067a
    
    i tried it twice on clean installs, so whats the problem here?

    if i execute /usr/local/psa/bin/secret_key it tells me:
    Code:
    Warning: Current locale is unusable. Using 'C' instead.
    Command is required
    
    
    please show me a way how i can install ppa
     
  2. Cyrillv

    Cyrillv Bit Poster

    Messages:
    4
    tried it again with a FREHSH install of centos, still the same. this really drives me crazy.
     
  3. GrigoryK

    GrigoryK Odin Team

    Messages:
    8
    There is no such system locale 'en_us.utf-8'. The correct name is 'en_US.UTF-8'.
    Please correct your 'export LANG' command before running 'ppa_installer.sh'.

    Please also make sure that default system locale stored in the '/etc/sysconfig/i18n' file is 'en_US.UTF-8' too. This is critical for correct PPA product installation.
     
  4. Cyrillv

    Cyrillv Bit Poster

    Messages:
    4
    Thanks, install was successfull with your Hints.
     

Share This Page