Unable to detect a network mask for the IP: ''

Discussion in 'Plesk Automation Suggestions and Feedback' started by HansK, Oct 27, 2011.

Thread Status:
Not open for further replies.
  1. HansK

    HansK Kilo Poster

    Messages:
    14
    Did download and ran the installer.

    Getting stuck with :

    Complete!
    [Thu 27 Oct 2011 06:38:07 AM EDT][INFO] Installing third-party packages... curl.i386 libidn.i386
    [Thu 27 Oct 2011 06:38:07 AM EDT][INFO] Required RPM packages:
    [Thu 27 Oct 2011 06:38:07 AM EDT][INFO] - http://autoinstall.plesk.com/MSP_1_0_0//thirdparty//curl-7.15.5-9.el5.i386.rpm
    [Thu 27 Oct 2011 06:38:07 AM EDT][INFO] - http://autoinstall.plesk.com/MSP_1_0_0//thirdparty//libidn-0.6.5-1.1.i386.rpm
    Retrieving http://autoinstall.plesk.com/MSP_1_0_0//thirdparty//curl-7.15.5-9.el5.i386.rpm
    Retrieving http://autoinstall.plesk.com/MSP_1_0_0//thirdparty//libidn-0.6.5-1.1.i386.rpm
    Preparing... ########################################### [100%]
    1:libidn ########################################### [ 50%]
    2:curl ########################################### [100%]

    [Thu 27 Oct 2011 06:38:10 AM EDT][INFO] Running Multi-Server Panel installation...

    [Thu 27 Oct 2011 06:38:10 AM EDT][INFO] Generating the POA configuration file...
    Usage: grep [OPTION]... PATTERN [FILE]...
    Try `grep --help' for more information.
    Usage: grep [OPTION]... PATTERN [FILE]...
    Try `grep --help' for more information.
    [Thu 27 Oct 2011 06:38:10 AM EDT][ERROR] Unable to detect a network mask for the IP: ''

    Attached you will find the zipper install log file

    rgds

    Hans Kind
     

    Attached Files:

  2. Blake@Parallels

    Blake@Parallels Mega Poster

    Messages:
    216
    What is the output of running 'hostname -i' from command line on this server?
     
  3. Andrew Andriatis

    Andrew Andriatis Odin Team

    Messages:
    437
    Do you have IPv4 configured on your box?
     
  4. HansK

    HansK Kilo Poster

    Messages:
    14
    [root@flyinghosting ~]# ifconfig
    eth0 Link encap:Ethernet HWaddr 00:16:3E:34:7F:42
    inet addr:46.23.74.96 Bcast:46.23.74.255 Mask:255.255.255.0
    inet6 addr: fe80::216:3eff:fe34:7f42/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:1385810 errors:0 dropped:0 overruns:0 frame:0
    TX packets:382207 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:2073847840 (1.9 GiB) TX bytes:23479741 (22.3 MiB)

    eth1 Link encap:Ethernet HWaddr 00:16:3E:3B:48:A2
    inet6 addr: fe80::216:3eff:fe3b:48a2/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:754 errors:0 dropped:0 overruns:0 frame:0
    TX packets:11 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:112182 (109.5 KiB) TX bytes:2178 (2.1 KiB)

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:32 errors:0 dropped:0 overruns:0 frame:0
    TX packets:32 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:3823 (3.7 KiB) TX bytes:3823 (3.7 KiB)

    [root@flyinghosting ~]# hostname -i
    hostname: Unknown host

    [root@flyinghosting ~]# hostname
    flyinghosting.localdomain

    [root@flyinghosting ~]# more /etc/hosts
    ######### Automatically generated by OnApp (2.0.1)
    127.0.0.1 localhost
    46.23.74.96 flyinghosting.net flyinghosting

    [root@flyinghosting etc]# more /etc/hostname
    flyinghosting.net
     
  5. Blake@Parallels

    Blake@Parallels Mega Poster

    Messages:
    216
    Hi Hans,

    Make sure that the server's _full_ hostname (flyinghosting.localdomain) can be resolved. Probably the easiest way would be to define this in your /etc/hosts file.
     
  6. Andrew Andriatis

    Andrew Andriatis Odin Team

    Messages:
    437
    OK. We'll have to fix the script for the case when "hostname -i" doesn't return the IP address
     
  7. HansK

    HansK Kilo Poster

    Messages:
    14
    This could very well a issue with VPS.net's way of configuring the node in the AMS data center.

    I'm currently running the installer on a node in Salt Lake City, with a correct "hostname -i" response, and the installer seems to continue where it failed before.

    I keep you posted.
     
  8. HansK

    HansK Kilo Poster

    Messages:
    14
    Installer completed successfully.

    ======================================================================
    CONGRATULATIONS!
    Multi-Server Panel was successfully installed.
    To complete system configuration, please proceed to URL: https://209.236.69.252:8443/
    ======================================================================
     
  9. Andrew Andriatis

    Andrew Andriatis Odin Team

    Messages:
    437
    For the original issue, please, see the updated installation script with the explicit "ip" parameter in it.
     
Thread Status:
Not open for further replies.

Share This Page