Solved: Let's Encrypt - Problem after recreation of Subscription

Discussion in 'Plesk Automation Suggestions and Feedback' started by P_heck, Feb 24, 2016.

  1. P_heck

    P_heck Kilo Poster

    Messages:
    60
    Hello,

    I am using the Let's Encrypt Plesk extension which works fine so far. Unfortunately, I needed to delete and recreate a subscription for one domain due to a corruption.

    Afterwards, trying to re-establish the Let's Encrypt certificate, I got the error, that too many certificates have been issued to this domain. So I waited 7 days (timeout) and tried newly - received following error msg.

    Code:
    Fehler: Let's Encrypt SSL certificate installation failed: Failed letsencrypt execution: 2016-02-24 14:08:16,939:WARNING:letsencrypt.cli:Root (sudo) is required to run most of letsencrypt functionality.
    Install certificate failure: Unable to set certificate name :
    IMPORTANT NOTES:
    - Congratulations! Your certificate and chain have been saved at
    /opt/psa/var/modules/letsencrypt/etc/live/ph-blog.de/fullchain.pem.
    Your cert will expire on 2016-05-24. To obtain a new version of the
    certificate in the future, simply run Let's Encrypt again.
    Looks like somewhere (where?) the extension stores some outdated information on the formed Let's Encrypt certificate and can't update now. Anyone has any idea, how to solve this problem?

    Cheers Peter
     
  2. P_heck

    P_heck Kilo Poster

    Messages:
    60
    Solution found: Open PSA Database ==> Look for certificate table ==> delete entry for the domain ==> re-install Let's Encrypt certificate
     

Share This Page