SoLoader spinning?

Discussion in 'Plesk Automation Suggestions and Feedback' started by GregHL, Dec 12, 2013.

  1. GregHL

    GregHL Mega Poster

    Messages:
    128
    is it normal to see an SoLoader clocking up almost 100% cpu on the CP node?

    PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
    3109 pemuser 15 0 171m 66m 41m S 98.9 0.8 19648:14 SoLoader
    1 root 15 0 10372 696 588 S 0.0 0.0 0:02.46 init
    2 root RT -5 0 0 0 S 0.0 0.0 0:00.19 migration/0
    3 root 34 19 0 0 0 S 0.0 0.0 0:01.37 ksoftirqd/0
     
  2. HMoellendorf87

    HMoellendorf87 Mega Poster

    Messages:
    245
    Hi GregHL,

    could you please check if there are tasks running? Did you checked the system requirements?
     
  3. GregHL

    GregHL Mega Poster

    Messages:
    128
    There are failed and unprocessed tasks.

    System requirements? for PPA? Parallels devs setup our cluster so I really hope the sytem requirements were met....
     
  4. HMoellendorf87

    HMoellendorf87 Mega Poster

    Messages:
    245
  5. GregHL

    GregHL Mega Poster

    Messages:
    128
  6. HMoellendorf87

    HMoellendorf87 Mega Poster

    Messages:
    245
    Hi Greg,

    can you try to solve the unfinished and failed tasks as it could be, that this is being blocked the system.
    As on our PPA management node the process is running the same, when there are such tasks in it.
     
  7. GregHL

    GregHL Mega Poster

    Messages:
    128
    I think I had better open a helpdesk ticket - basic tasks are failing - removing a user account:

    that can't be good.
     
  8. HMoellendorf87

    HMoellendorf87 Mega Poster

    Messages:
    245
    Hi GregHL,

    if Parallels setup the node, then you should do that according to the installation service.
    It seems not to work properly currently.

    Maybe that is the reason.
     
  9. Andrey Dobrenko

    Andrey Dobrenko Odin Team

    Messages:
    256
    Greg,

    Can you print a list of all processes (ps -auxfww) and identify what process consumes CPU. In normal case, there are a lot of processes SoLoaders, because this one is just loader. Here is example:

    pemuser 16138 0.1 1.2 156772 39164 ? Ssl Dec12 1:06 /usr/local/pem/bin/SoLoader --sc_id=2 --sc_instance_id=1 --sc="Kernel:/usr/local/pem/libexec/kernel-lin.so" --props-file="/usr/local/pem/etc/pleskd.props"
    pemuser 16256 0.0 0.9 65908 29236 ? Ss Dec12 0:00 /usr/local/pem/bin/SoLoader --sc_id=26 --sc_instance_id=26 --sc="BIND:/usr/local/pem/libexec/BIND.so.5.5.2.11" --props-file="/usr/local/pem/etc/pleskd.props"

    Did you try to restart PPA - "/etc/init.d/pem restart"?

    --
    Andrey Dobrenko
    Development Manager
    Parallels Plesk Automation
    Web Site: http://www.parallels.com/products/plesk-automation/
     
  10. GregHL

    GregHL Mega Poster

    Messages:
    128
    Andrey - PPA was restarted - there are a number of tasks failed - updates to subscriptions, delete users, update + setup mail services.

    The support team upgraded the cluster to MU16 - problems with tasks are still there.

    I am currently running the daily maintenance task (it failed) - when that finishes or fails, I'll restart PPA again - and then try again.
     
  11. GregHL

    GregHL Mega Poster

    Messages:
    128
    I am getting tasks fail still - I cleared out the old tasks - the current tasks failing are:

    Task ID
    36685
    Queue name
    POA_customer_233
    Task name
    Update the user’s password #100002
    Task description
    Update user’s password in the Hosting Panel.
    Queue status
    Failed
    Start not earlier than
    Dec-17-2013 10:26
    Method name
    changeUserPassword on SCREF:pleskIntegration:0
    Last execution output
    User account already exists.

    (why would it error as existing - we know the account exists - we're just changing a password it seems).
     
  12. HMoellendorf87

    HMoellendorf87 Mega Poster

    Messages:
    245
    Hi Greg,

    as PPA is a complex running system, I'd like to give you the information, that the support is free for PPA, so please contact them.
    It is hardly to discover the reason without access and knowledge what this task performs.
     
  13. GregHL

    GregHL Mega Poster

    Messages:
    128
    Yes support were involved - they had been dragging their heels on this - which why I brought the matter here. Every time they fixed one task, another hung. I would actually like to know how to investigate these myself - rather than dealing with Russian support - honestly -with almost everything needing to involve the developers, it means we have at least one day to fix things via "support" - so we prefer to know how to fix things ourselves - hosting isn't a "we'll try and fix it tomorrow" type of business - really - it's NOT.

    Example of how long things take...

    - can we fix the task issues - upgraded to 11.1 MU16 and then 11.5 ? Yes - 1 week later - still not fixed and upgraded.
    - every night I got to bed with my cellphone next to my pillow - expecting to wake up to an upgraded cluster - every morning I wake up and they asked me another question and quit for the day. Today's question... "are you using WHMCS?" - well if they reviewed my notes in my customer file, that question would be answered. Sure - there is an upgraded module - sure I can install it. Yes, I have it downloaded, but I cannot install it until 11.5 is running.

    Have I backed up every node in the cluster? No - I asked 3 times for instructions and got "we are not experts in this"

    FFS - why is there no document on pre-upgrade backup procedure?!?

    Why is there no document on backing up the PPA control node + sitebuilder systems?

    Is there a risk in upgrading the cluster that the operating system will just explode and EVERYTHING will go bang?

    Do I need to backup every piece of customer data on shared hosting nodes? Surely not...

    This 13 hour time difference between us and the support team/devs is killing my business. Every morning I look like a liar to my customers because parallels found another question to ask me instead of doing the upgrade. More than 1 week now we've been expecting this upgrade.
     
  14. HMoellendorf87

    HMoellendorf87 Mega Poster

    Messages:
    245
    Dear Greg,

    sadly to hear that the support isn't involving the developers to get this running. Maybe I can assist you as far as I can. Its me (HMoellendorf87) in the forum, but I can't login there currently. Thats the reason why I am using this account.
    I'd like to get a look on the Task Manager and such things. As I am now PPE I would like to ask you, to give credentials via PM to me, that I can verify and clarify some things and log files.

    As far as I can, I'll try to get the devs aboard to get your whole system running smoothly, but expect, that I will need a login first, so I can gather very important information to create a support request for ya.
    Maybe I can solve many things to get the system back online fully without getting near support from Parallels itself. I'll setup a 11.1 PPA shortly to get a examination system running.

    Please don't hestitate to contact me via skype (send me your nick and I'll add you asap).

    Sorry for the circumstances.
     
  15. GregHL

    GregHL Mega Poster

    Messages:
    128
    sorry - I didn't want to provide my details via pm to a user that was not known by me to be associated with Parallels - that's just not going to happen unless I know you.
     

Share This Page