Slave DNS zones do not get created

Discussion in 'Troubleshooting' started by MathieuP, Feb 16, 2014.

  1. MathieuP

    MathieuP Bit Poster


    I have just set up my PBAS install and set up 2 BIND DNS servers under CentOS 6. I have set up SSH management successfully, registered the servers in PBAS and configured named.conf and /var/named permissions and public keys correctly with the namedsync user. All of this works as PBAS connects successfully to both DNS servers via SSH and updates the named.zones file successfully. Moreover, I have tried creating empty zone files (ex.: in /var/named directory and when I delete the domain from PBAS, this file gets deleted and the named.zones file gets cleaned-up correctly.

    So the only problem I have is that domain zone files do not get created in the beginning while everything else works.

    I have searched through these forums and asked master sysadmin (google) but did not find any solution to this specific problem.

    Note: I did not install bind-chroot.

    Thanks for any help!
  2. ONMatt

    ONMatt Bit Poster

    Have you verified that the slave servers can AXFR zones from the master (PBAs)?

    For a couple days we have been fighting an issue where PowerDNS on the PBAs node is crashing so the slaves can't get updated records. For us this happened after upgrading the underlying OS from CentOS 5 i386 to CentOS 6 x64.

  3. MathieuP

    MathieuP Bit Poster

    Hi Matt,

    Thanks for your answer! However, I can already AXFR zones from PBAS on both my DNS servers successfully. Also, I have verified PBAS logs and found this:

    [2014/03/01 15:28:39] [INFO] [10132] [HSPC::MT::DM::DNS::Synchronizator::sync_zone] NS ns1.***** sync success
    [2014/03/01 15:28:44] [INFO] [10132] [HSPC::MT::DM::DNS::Synchronizator::sync_zone] NS ns2.***** sync success

    Also, on the two nameservers, I see the namedsync user logging in from /var/log/secure and as I said in my original post, it modifies the named.zones file when I add a new zone but does not create the zone file (ex.:

    Yes, I do have CentOS 6 installed on all my nodes up to now.

    I have followed this article ( and everything worked in there but still have the same problem. Everything works except zone file creation.
  4. Vadim Ivanov

    Vadim Ivanov Kilo Poster

    Please check the permissions for the directory /var/named. The user 'named' should be allowed to write. Search the /var/log/messages for named records for domain in question.

Share This Page