Service node install fails w/o root

Discussion in 'Plesk Automation Suggestions and Feedback' started by rrolfe, Sep 28, 2012.

Thread Status:
Not open for further replies.
  1. rrolfe

    rrolfe Kilo Poster

    Messages:
    22
    If you specify a username/password combo that doesn't use the "root" username the system fails to install the service node. The SCP command used to copy the poa.repo file from the management system to the service node doesn't take sudo into account.

    The task always results to permission denied.
     
  2. Andrey Dobrenko

    Andrey Dobrenko Odin Team

    Messages:
    256
    Hi rrolfe,

    At present, only root or administrator may be specified to perform system commands through ssh. We will fix it. Thanks for your feedback.

    Best Regards,
    Andrey
     
  3. rrolfe

    rrolfe Kilo Poster

    Messages:
    22
    Dobrenko,

    Well then that takes us to the other thread. It specifically says on the service node setup page that you can use another user other than root and the system will use sudo. However that obviously doesn't work. Then there's nowhere in the system to change the username used to access the service node in the system. Hence the other thread.

    Robert Rolfe
    Weberz Hosting
    http://www.weberz.com
     
  4. Andrey Dobrenko

    Andrey Dobrenko Odin Team

    Messages:
    256
    I answered on your question about changing password for service node. This problem will be fixed as i already said.
     
Thread Status:
Not open for further replies.

Share This Page