Restart Apache and Plesk commands

Discussion in 'Plesk 7.0 Troubleshooting and Problems' started by dennism220, Feb 15, 2004.

  1. dennism220

    dennism220 Kilo Poster

    Messages:
    90
    OK, I just upgraded to RHE and Plesk 7.

    Problem I'm having is the following commands no longer work.

    /usr/local/psa/admin/sbin/my_apci_rst

    Or:
    /usr/local/psa/rc.d/psa restart

    It says no such file or directory.

    What should I be using to restart apache and plesk?

    Thanks,
    Dennis
     
  2. Anton

    Anton Odin Team

    Messages:
    53
    my_apci_rst works in the background, to have it execute as it did in the previous version you need to run it with "-a -v" options:
    my_apci_rst -a -v

    The best way to restart the Plesk service is with the "service" command:
    service psa stop/stopall/start

    To just restart Apache you would run something like:
    service httpd restart

    Anton.
     
  3. siren@

    siren@ Tera Poster

    Messages:
    479
    I haven't found my_apci_rst on the system at all on Plesk 7.0. It was replaced by websrvmng under /usr/local/psa/admin/bin/

    If you type /usr/local/psa/admin/bin/websrvmng -h it lists all the commands.

    This is due to all the new creation utilities. They actually offer more abilities.
     
  4. Hydr0gen

    Hydr0gen Guest

    Ok, so how do I get plesk 7 to read my vhosts.conf ? I ran websrvmng -a but it didn't seem to do anything

    Before I'd run my_apci_rst and it would pick up the vhosts.conf file..
     
  5. cmaxwell

    cmaxwell Tera Poster

    Messages:
    264
    Hi there,

    You get the vhost.conf's loaded by running this command:

    /usr/local/psa/admin/sbin/websrvmng --reconfigure-all

    This is in the Plesk 7 manual on advanced features.

    Hope this helps.

    - Chris
     
  6. Hydr0gen

    Hydr0gen Guest

    My bad, it does work - so does the -a switch. Thanks.
    Now I gotta figure out this open_basedir issue
     
  7. Hydr0gen

    Hydr0gen Guest

    Setting the open_basedir to none seems to break things.. It seems to work okay if I set the base_dir to "/" though.
     
  8. cmaxwell

    cmaxwell Tera Poster

    Messages:
    264
    You really don't want to set the basedir to / as that has serious security implications - your website scripts can now easily access all the files on your system.

    Set it to something like /home/httpd/vhosts/<domain>/httpdocs and also turn PHP safe mode off like this in a vhost.conf file:

    <Directory /home/httpd/vhosts/<domain>/httpdocs>
    php_admin_flag safe_mode off
    php_admin_value open_basedir "/home/httpd/vhosts/<domain>/httpdocs/:/tmp"
    </Directory>

    Hope this helps!
     
  9. metoo

    metoo Kilo Poster

    Messages:
    40
    Apache restart
    look for apache bin folder

    the path may look like this:
    /usr/local/psa/apache/bin/apachectl restart

    (every system is a little different)
     

Share This Page