PVA Guest Tools not updating

Discussion in 'General Questions' started by SteveITS, Sep 3, 2015.

  1. SteveITS

    SteveITS Mega Poster

    Messages:
    211
    PVA shows our Windows Server 2012 R2 VM as "Guest Tools: Outdated." However the General Settings tab shows "Guest Tools Autoupdate" checked. We have PVA 6.0-2796 which I believe is the latest version. I believe it was updated after the VM was created. Shouldn't it be updating...?
     
  2. Pavel

    Pavel A.I. Auto-Responder Odin Team

    Messages:
    416
    Hello Steve,

    The way this option works is not really straightforward due to the complexity of the task.
    First of all, although it is not entirely relevant to your question I think I should note that autoupdate would work only for Windows virtual machines, it will not work for Linux since there is no auto-play functionality as it is implemented in Windows.
    And even though Windows have auto-play functionality it does not allow us to automate entire process. For tools to be updated automatically VM owner must log into the VM using the console session (Remote Display via PVA PP, or direct VNC connection, or a "console" RDP session). Only when logged into the console session Windows will pick up the inserted cdrom image with the guest tools installer, and update them.

    Current implementation lacks what it needs to be called "automated" of course, that is why development team is reworking this behavior entirely, aiming to make it truly automated. That is planned to achieve in scope of a bug PSBM-17703 "Automatic upgrade of Parallels Guest tools inside Virtual Machines and templates". You can track the status of this bug if you subscribe to our KB - http://kb.odin.com/subscriptions . For each update or release there is an announcement that includes list of bugs and features implemented.
     
    Last edited: Sep 28, 2015
  3. SteveITS

    SteveITS Mega Poster

    Messages:
    211
    I had to reinstall the Windows server (short version: support goofed, and removing and re-adding a Windows+SQL service node in PA has problems since the removal doesn't clean itself up fully). I used the Maintenance/Reinstall feature in PVA which is what I used the last time. The Guest Tools are not installed, and I'm guessing related to that, the network settings changes I make in PVA are not applied to the server even though PVA thinks the tasks are successful.

    How can I install Guest Tools? I've logged in now using the PVA Console and also VNC.
     
  4. Pavel

    Pavel A.I. Auto-Responder Odin Team

    Messages:
    416
    Steve, you are correct. For the network settings configured from PVA or PCS CLI to work you need functioning Tools.
    There is a button "Install Tools" in the PVA MN interface - it will mount an iso with tools to the VM. Running installer from the disk image will let you install tools in couple clicks. Note, it will require reboot to complete the installation!

    More details available in documentation:
    http://download.swsoft.com/pva/61/docs/en/pdf/Parallels_Virtual_Automation_Administrators_Guide.pdf
    pages 123-125
     
  5. SteveITS

    SteveITS Mega Poster

    Messages:
    211
    Thank you, I searched the online documentation for "Guest Tools" since that's how it is referred to on the Virtual Machine/Summary tab and Configure General Settings page, and it found two pages, but nothing about how to install it. The PDF manual you linked refers to it as "Parallels Tools." I didn't think to look for a button on the Console tab last night, evidently forgetting how I did it a couple months ago!
     
  6. Pavel

    Pavel A.I. Auto-Responder Odin Team

    Messages:
    416
    Steve, just for your information, I've submitted bug to our development team, we'll work on unifying names across our resources.
    Internal bug ID is PVA-34888
     

Share This Page