Problem adding Denic Plugin

Discussion in 'Troubleshooting' started by BitPoint, Mar 22, 2014.

  1. BitPoint

    BitPoint Kilo Poster

    Messages:
    15
    Hi,

    I'm using PBA-S 4.5.1-15. I want to configure the Denic Domain Plugin, but the PGP Textareas have a maximum of 255 chars only?! So I could not post my keys full in the input box.

    How can I solve this?

    Thank you and Greetings
    Martin
     
  2. Vadim Ivanov

    Vadim Ivanov Kilo Poster

    Messages:
    36
    Last edited: Mar 25, 2014
  3. BitPoint

    BitPoint Kilo Poster

    Messages:
    15
    Hello,

    I don't see your answer here (but in the eMail). It would be nice if you can send me the Hotfix. We cant't wait before 4.5.2 will be released.

    Thank you very much

    Greetings
    Martin
     
  4. BitPoint

    BitPoint Kilo Poster

    Messages:
    15
    I see it now. Thank you very much.
     
  5. BitPoint

    BitPoint Kilo Poster

    Messages:
    15
    Hi,

    the plugin does not work. After the installation I can't see the plugin. We use a x86_64 system. Could this be the problem?
    I've installed it with rpm -Uvh and hspc-upgrade-manager --finish.

    Greetings
    Martin
     
  6. Vadim Ivanov

    Vadim Ivanov Kilo Poster

    Messages:
    36
    Last edited: Mar 26, 2014
  7. BitPoint

    BitPoint Kilo Poster

    Messages:
    15
    Hello Vadim,

    when I add the plug in PBA-S, i got this error now after filling out all the parameters:

    --------------------- DEBUG_LOG ---------------------
    [2014/03/27 14:09:36] [DEBUG] [31988] [HSPC::Application::db_connection] SQL Connection got for 'MAIN': 0 => 3084
    [2014/03/27 14:09:36] [DEBUG] [31988] [HSPC::WebSystem::reinit_security] LOGIN:try to login to account # , result=HSPC::WebSecurity=HASH(0x225a7850)
    [2014/03/27 14:09:36] [DEBUG] [31988] [HSPC::Logger::sw_trace] TRACE [01]: +> HSPC::MT::GM->find_provider_config ()
    [2014/03/27 14:09:36] [DEBUG] [31988] [HSPC::Logger::sw_trace] TRACE [02]: . +> HSPC::MT::Core->find_account (account_id=>1)
    [2014/03/27 14:09:36] [DEBUG] [31988] [HSPC::Logger::sw_trace] TRACE [03]: . . +> HSPC::MT::Core::AbstractAccount->load (self=>HSPC::MT::Core::HSP, id=>1)
    [2014/03/27 14:09:36] [DEBUG] [31988] [HSPC::MT::Core::AbstractAccount::load] TRACE [03]: . . -> HSPC::MT::Core::AbstractAccount->load (self=>HSPC::MT::Core::HSP, id=>1) => found
    [2014/03/27 14:09:36] [DEBUG] [31988] [HSPC::MT::Core::find_account] TRACE [02]: . -> HSPC::MT::Core->find_account (account_id=>1) => found
    [2014/03/27 14:09:36] [DEBUG] [31988] [HSPC::MT::GM::find_provider_config] TRACE [01]: -> HSPC::MT::GM->find_provider_config ()
    [2014/03/27 14:09:36] [DEBUG] [31988] [HSPC::UISteps::run] [CORE:UISTEPS] handle step plugin
    [2014/03/27 14:09:37] [INFO] [31988] [HSPC::pluginWizard::DM::process_step_plugin] Try to verify config data
    [2014/03/27 14:09:37] [FATAL] [31988] [Error::throw] can`t eval cmd=$res = $self->process_step_plugin() error=Not a HASH reference at /usr/local/share/perl5/HSPC/Plugin/DM/Denic.pm line 292.
    [2014/03/27 14:09:37] [FATAL] [31988] [Error::throw] URI handler (HSPC::pluginWizard::DM->teaser_wizard) error: can`t eval cmd=$res = $self->process_step_plugin() error=Not a HASH reference at /usr/local/share/perl5/HSPC/Plugin/DM/Denic.pm line 292.
    --------------------- /DEBUG_LOG ---------------------

    I used the exported PGP keys with GnuPG2.

    Greetings
    Martin
     
  8. BitPoint

    BitPoint Kilo Poster

    Messages:
    15
    Hello,

    I've solved this last error by deleting /etc/hspc/gpg
    But now I got the error: ERROR while importing key: hex_id is empty

    And after creating the directory /etc/hspc/gpg again and executing "gpg2 --homedir=/etc/hspc/gpg --list-keys" it will create an empty pubring.gpg and trustdb.gpg.
    And i get this error after adding the plugin: ERROR while importing private key

    But with "gpg2 --homedir=/etc/hspc/gpg --list-keys" I see my public key and with "gpg2 --homedir=/etc/hspc/gpg --list-secret-keys" I see my private key.

    And when I now try to add the plugin again I got the application error again:
    --------------------- DEBUG_LOG ---------------------
    [2014/03/28 03:12:06] [DEBUG] [30638] [HSPC::Application::db_connection] SQL Connection got for 'MAIN': 0 => 4098
    [2014/03/28 03:12:06] [DEBUG] [30638] [HSPC::WebSystem::reinit_security] LOGIN:try to login to account # , result=HSPC::WebSecurity=HASH(0x226cde78)
    [2014/03/28 03:12:06] [DEBUG] [30638] [HSPC::Logger::sw_trace] TRACE [01]: +> HSPC::MT::GM->find_provider_config ()
    [2014/03/28 03:12:06] [DEBUG] [30638] [HSPC::Logger::sw_trace] TRACE [02]: . +> HSPC::MT::Core->find_account (account_id=>1)
    [2014/03/28 03:12:06] [DEBUG] [30638] [HSPC::Logger::sw_trace] TRACE [03]: . . +> HSPC::MT::Core::AbstractAccount->load (self=>HSPC::MT::Core::HSP, id=>1)
    [2014/03/28 03:12:06] [DEBUG] [30638] [HSPC::MT::Core::AbstractAccount::load] TRACE [03]: . . -> HSPC::MT::Core::AbstractAccount->load (self=>HSPC::MT::Core::HSP, id=>1) => found
    [2014/03/28 03:12:06] [DEBUG] [30638] [HSPC::MT::Core::find_account] TRACE [02]: . -> HSPC::MT::Core->find_account (account_id=>1) => found
    [2014/03/28 03:12:06] [DEBUG] [30638] [HSPC::MT::GM::find_provider_config] TRACE [01]: -> HSPC::MT::GM->find_provider_config ()
    [2014/03/28 03:12:06] [DEBUG] [30638] [HSPC::UISteps::run] [CORE:UISTEPS] handle step plugin
    [2014/03/28 03:12:07] [INFO] [30638] [HSPC::pluginWizard::DM::process_step_plugin] Try to verify config data
    [2014/03/28 03:12:07] [FATAL] [30638] [Error::throw] can`t eval cmd=$res = $self->process_step_plugin() error=Not a HASH reference at /usr/local/share/perl5/HSPC/Plugin/DM/Denic.pm line 292.
    [2014/03/28 03:12:07] [FATAL] [30638] [Error::throw] URI handler (HSPC::pluginWizard::DM->teaser_wizard) error: can`t eval cmd=$res = $self->process_step_plugin() error=Not a HASH reference at /usr/local/share/perl5/HSPC/Plugin/DM/Denic.pm line 292.
    --------------------- /DEBUG_LOG ---------------------

    What is my mistake?

    Greetings
    Martin
     
    Last edited: Mar 27, 2014
  9. Vadim Ivanov

    Vadim Ivanov Kilo Poster

    Messages:
    36
  10. BitPoint

    BitPoint Kilo Poster

    Messages:
    15
    Hello Vadim,

    the plugin can be activated now. Thank you for that. But there a several problems with the email templates.
    You are using the old format 1.1. But since August 2008 there is the new MRIv2 (2.0) format at denic.
    Is there already a newer plugin? Or even better a realtime registry plugin?
    For the handle template there must be changed the following things:

    change DENIC-Handle to Handle
    add a line "version: 2.0"
    change pcode to postalcode
    change country to countrycode

    For the domain template:

    change "version 1.1" to "version: 2.0

    And there are changes in the email responses.

    For handles and domains:
    RESULT: success

    And you are alway sending the ip of the dns server with a domain create request. That leads to a warning.
    It would be better only send the the ip number if the nameserver has the same domain as teh requested domain.

    Example:
    RESULT: success
    WARNING: 33300102912 Predelegation Check warning [WARNING: 102 Provided glue records not applicable (NS) (testdomain.de IN NS ns1.testdns.de /10.10.10.1)]
    INFO: 13000000011 Request was processed in test environment - not valid in real world [testing platform]

    Thank you.

    Greetings
    Martin
     
  11. FedorK

    FedorK Mega Poster

    Messages:
    224
  12. BitPoint

    BitPoint Kilo Poster

    Messages:
    15
    Hello Fedor,

    we are Denic member and I can't use the EPAG Plugin for .de Domains. We have to register .de domains directly at Denic.

    Nobody using PBAS who is a denic member?

    Greetings
    Martin
     
  13. FedorK

    FedorK Mega Poster

    Messages:
    224
    Martin,

    Unfortunately nobody use this plugin any more.
    I file feature request for implement new protocol but this feature request is not planned to any version.

    Thank you,
     
  14. Netzhaus

    Netzhaus Kilo Poster

    Messages:
    46
    We would like to have a working Denic plugin

    We are just starting with PBAS and would like to use the Denic plugin.
    We are Denic member.
    And realtime would be preferred over email registration.

    It would be bad, if the denic plugin is not working.
    This was one reason for the decision to try PBAS.
     
  15. Alex Goncharov

    Alex Goncharov Odin Team

    Messages:
    32
    Note that PBAS domain registration plugins come with open source.
    There is SDK, documentation and examples how to write plugins.
    http://www.parallels.com/products/pba-standard/resources/

    You do not have to wait.
    You can hire local Perl developer and develop any PBAS plugin you need or update existing outdated plugin.
    This way you can add features as soon as they become available and make any changes you need.

    Also you can hire professionals to do that:
    http://www.pbasplugins.com
     
  16. Netzhaus

    Netzhaus Kilo Poster

    Messages:
    46
    I am sorry, but Parallels is still promoting the Denic plugin as a feature for PBA-S.
    http://www.parallels.com/de/products/pba-standard/plugins/domain-registries/

    A plugin which is outdated since years and inoperable as we can read here.
    And all help the customer gets is the information, that this problem will not be solved and the customer should solve this alone?

    I am speechless at the moment.
     
  17. FedorK

    FedorK Mega Poster

    Messages:
    224
    Hello,

    We will update this plugin in next (4.5.3 update).
     

Share This Page