PPA 11.5 Preview

Discussion in 'Plesk Automation Suggestions and Feedback' started by Andrew Andriatis, Oct 13, 2013.

  1. Andrew Andriatis

    Andrew Andriatis Odin Team

    Messages:
    437
    Hi,
    Our developers say that this issue was already resolved and will be available when we'll republish the distribution next week.

    Regards,
    Andrey
     
  2. StéphanS

    StéphanS Product Expert

    Messages:
    154
    Seems you guys forgot to include the php_handler:

    Code:
    [root@ppa115 ~]# ls -la /usr/local/ppa/bin/php_handler
    ls: cannot access /usr/local/ppa/bin/php_handler: No such file or directory
    [root@ppa115 ~]# find /usr/local/ppa/ -iname "*php*"
    [root@ppa115 ~]# cat /usr/local/ppa/version
    PPA 11.5.0 PREVIEW2 131009.14
     
  3. Andrey Dobrenko

    Andrey Dobrenko Odin Team

    Messages:
    256
    There will be tool to upgrade from 11.1 to 11.5 automatically. Moreover, we are going to perform trial upgrades ourselves in scope of TAP program. If someone wants to participate, please email me.

    --
    Andrey Dobrenko
    Development Manager
    Parallels Plesk Automation
    Web Site: http://www.parallels.com/products/plesk-automation/
     
  4. Andrey Dobrenko

    Andrey Dobrenko Odin Team

    Messages:
    256
    Guys, Windows 2012 is high prior task for us and we'll issue an micro update for 11.5 to support Windows 2012. The optimistic ETA is Dec, 2013, the pessimistic - Jan-Feb, 2014.

    --
    Andrey Dobrenko
    Development Manager
    Parallels Plesk Automation
    Web Site: http://www.parallels.com/products/plesk-automation/
     
  5. Andrey Dobrenko

    Andrey Dobrenko Odin Team

    Messages:
    256
    Hi Sonics,

    Thanks for reporting! We've fixed a set of bugs including this one too and will release update for PPA 11.5 this week.

    --
    Andrey Dobrenko
    Development Manager
    Parallels Plesk Automation
    Web Site: http://www.parallels.com/products/plesk-automation/
     
  6. DobromirD

    DobromirD Bit Poster

    Messages:
    5
    Is there any information update about the new licensing model of Plesk Automation announced with the preview release and the licensing cost?
    We need to know whether the the new licensing model will replace the existing model in PPA 11.1 or will be replaced with the new mode.


    Best regards,
    Dobrev
     
  7. StéphanS

    StéphanS Product Expert

    Messages:
    154
    There will be 2 models for PPA 11.5

    The old (per node licensing), and the new (per amount of sites licensing) as described in http://download1.parallels.com/ppa/11.5/docs/preview2_guide.pdf


     
  8. RaimieL

    RaimieL Bit Poster

    Messages:
    6
    Any news on when the update will be released?
     
  9. Andrew Andriatis

    Andrew Andriatis Odin Team

    Messages:
    437
    We have re-published the preview binaries. There are no update scripts. Should be installed from scratch to get the improved version.

    Regards,
    Andrey
     
  10. StéphanS

    StéphanS Product Expert

    Messages:
    154
    Hi Andrew,

    can you tell me if /usr/local/ppa/bin/php_handler is provided in the new preview release?

    Thanks!
     
  11. Andrew Andriatis

    Andrew Andriatis Odin Team

    Messages:
    437
    there is a symlink /usr/local/ppa/bin/ppa.php_handler
     
  12. TDub

    TDub Kilo Poster

    Messages:
    43
    So what is the recommended upgrade path from 11.1 to 11.5 if we're running 11.1 on CentOS 5.x?
     
  13. Andrew Andriatis

    Andrew Andriatis Odin Team

    Messages:
    437
    With the 11.5 release we will provide the upgrade scripts, which will allow you to upgrade from 11.1 to 11.5 without the OS change.

    Regards,
    Andrey Andriatis
     
  14. UlrichD

    UlrichD Kilo Poster

    Messages:
    22
    After modifying the the install script to actually enable the yum repository, the installer runs through the steps but halts at this error (from log file):

    2013-12-05 11:26:44,317 [LOGTEE]: Loaded plugins: product-id, rhnplugin
    2013-12-05 11:26:45,341 [LOGTEE]: This system is receiving updates from RHN Classic or RHN Satellite.
    2013-12-05 11:26:45,719 [LOGTEE]:
    2013-12-05 11:26:45,719 [LOGTEE]:
    2013-12-05 11:26:48,755 [LOGTEE]: Detecting installed product components.
    2013-12-05 11:26:48,761 [LOGTEE]: Warning: following component(s) not found in product plesk: 'apache-sni'
    2013-12-05 11:26:48,762 [LOGTEE]: Gathering information about installed license key...
    2013-12-05 11:26:49,200 [LOGTEE]: Loaded plugins: product-id, rhnplugin
    2013-12-05 11:26:50,086 [LOGTEE]: This system is receiving updates from RHN Classic or RHN Satellite.
    PPB_11_5_30-dist | 951 B 00:00
    PPB_11_5_30-thirdparty | 951 B 00:00
    PSA_11_5_50-dist | 2.6 kB 00:00
    PSA_11_5_50-thirdparty | 2.6 kB 00:00
    SITEBUILDER_11_5_8-dist | 951 B 00:00
    SITEBUILDER_11_5_8-thirdparty | 951 B 00:00
    ppa-thirdparty/filelists | 7.3 kB 00:00
    repo-id-4/filelists_db | 89 kB 00:00
    rhel-x86_64-server-6/filelists | 19 MB 00:04 ] 0.0 B/s | 389 kB --:-- ETA
    2013-12-05 11:27:18,817 [LOGTEE]: Exception: Failed to solve dependencies:
    2013-12-05 11:27:18,818 [LOGTEE]: php-mbstring-5.3.3-22.el6.x86_64 requires php-common(x86-64) = 5.3.3-22.el6
    2013-12-05 11:27:18,818 [LOGTEE]: php-imap-5.3.3-22.el6.x86_64 requires php-common(x86-64) = 5.3.3-22.el6
    2013-12-05 11:27:20,482 [LOGTEE]:
    2013-12-05 11:27:20,482 [LOGTEE]: ERROR: The Yum utility failed to install the required packages.
    2013-12-05 11:27:20,483 [LOGTEE]: Attention! Your software might be inoperable.
    2013-12-05 11:27:20,484 [LOGTEE]: Please, contact product technical support.
    2013-12-05 11:27:20,494 [DEBUG]: EXEC (exit): 1
    2013-12-05 11:27:20,495 [ERROR]: Failed to execute command: ['/var/cache/ppa/dists/Plesk/ai', '--source', 'http://autoinstall.plesk.com/PPA_11.5.0/Plesk', '--select-product-id=plesk', '--select-release-latest', '--skip-branch-filter', '--target', '/var/cache/ppa/autoinstaller', '--install-component', 'common', '--install-component', 'psa-autoinstaller', '--install-component', 'sitebuilder', '--install-component', 'postfix', '--install-component', 'proftpd', '--install-component', 'web-hosting', '--install-component', 'horde', '--install-component', 'roundcube', '--install-component', 'webalizer', '--install-component', 'awstats', '--install-component', 'phpgroup', '--install-component', 'mod_fcgid', '--install-component', 'mod_perl', '--install-component', 'mod_python', '--install-component', 'apache-sni', '--install-component', 'sso']


    I have tried manually installing the php-common but rerunning the installer reproduces the error.

    Any ideas?
     
  15. UlrichD

    UlrichD Kilo Poster

    Messages:
    22
    Installation fails due to php-common dependency error

    I have modifyed the installer to enable the yum repository, but nothing else.

    When I run it, it halt on an error, here is the log file contents:
    Code:
    2013-12-05 11:26:44,317 [LOGTEE]: Loaded plugins: product-id, rhnplugin
    2013-12-05 11:26:45,341 [LOGTEE]: This system is receiving updates from RHN Classic or RHN Satellite.
    2013-12-05 11:26:45,719 [LOGTEE]: 
    2013-12-05 11:26:45,719 [LOGTEE]: 
    2013-12-05 11:26:48,755 [LOGTEE]: Detecting installed product components.
    2013-12-05 11:26:48,761 [LOGTEE]: Warning: following component(s) not found in product plesk: 'apache-sni'
    2013-12-05 11:26:48,762 [LOGTEE]: Gathering information about installed license key...
    2013-12-05 11:26:49,200 [LOGTEE]: Loaded plugins: product-id, rhnplugin
    2013-12-05 11:26:50,086 [LOGTEE]: This system is receiving updates from RHN Classic or RHN Satellite.
    PPB_11_5_30-dist                                         |  951 B     00:00     
    PPB_11_5_30-thirdparty                                   |  951 B     00:00     
    PSA_11_5_50-dist                                         | 2.6 kB     00:00     
    PSA_11_5_50-thirdparty                                   | 2.6 kB     00:00     
    SITEBUILDER_11_5_8-dist                                  |  951 B     00:00     
    SITEBUILDER_11_5_8-thirdparty                            |  951 B     00:00     
    ppa-thirdparty/filelists                                 | 7.3 kB     00:00     
    repo-id-4/filelists_db                                   |  89 kB     00:00     
    rhel-x86_64-server-6/filelists                           |  19 MB     00:04     ]  0.0 B/s | 389 kB     --:-- ETA 
    2013-12-05 11:27:18,817 [LOGTEE]: Exception: Failed to solve dependencies:
    2013-12-05 11:27:18,818 [LOGTEE]: php-mbstring-5.3.3-22.el6.x86_64 requires php-common(x86-64) = 5.3.3-22.el6
    2013-12-05 11:27:18,818 [LOGTEE]: php-imap-5.3.3-22.el6.x86_64 requires php-common(x86-64) = 5.3.3-22.el6
    2013-12-05 11:27:20,482 [LOGTEE]: 
    2013-12-05 11:27:20,482 [LOGTEE]: ERROR: The Yum utility failed to install the required packages.
    2013-12-05 11:27:20,483 [LOGTEE]: Attention! Your software might be inoperable.
    2013-12-05 11:27:20,484 [LOGTEE]: Please, contact product technical support.
    2013-12-05 11:27:20,494 [DEBUG]: EXEC (exit): 1
    2013-12-05 11:27:20,495 [ERROR]: Failed to execute command: ['/var/cache/ppa/dists/Plesk/ai', '--source', 'http://autoinstall.plesk.com/PPA_11.5.0/Plesk', '--select-product-id=plesk', '--select-release-latest', '--skip-branch-filter', '--target', '/var/cache/ppa/autoinstaller', '--install-component', 'common', '--install-component', 'psa-autoinstaller', '--install-component', 'sitebuilder', '--install-component', 'postfix', '--install-component', 'proftpd', '--install-component', 'web-hosting', '--install-component', 'horde', '--install-component', 'roundcube', '--install-component', 'webalizer', '--install-component', 'awstats', '--install-component', 'phpgroup', '--install-component', 'mod_fcgid', '--install-component', 'mod_perl', '--install-component', 'mod_python', '--install-component', 'apache-sni', '--install-component', 'sso']
    
    I have tried to manually install the php-common packages but it does not help, I do however see it installs a newer version php-common-5.3.3-26.el6.x86_64

    Any ideas to get it going again?
     
  16. UlrichD

    UlrichD Kilo Poster

    Messages:
    22
    I have already found the problem myself. PPA 11.5 requires RHEL6 to also subscribe the channel "RHEL Server Optional (v. 6 64-bit x86_64)"

    When that has been added to the system subscriptions in RHN then it continues past this point.
     

Share This Page