PPA 11.5 Preview

Discussion in 'Plesk Automation Suggestions and Feedback' started by Andrew Andriatis, Oct 13, 2013.

  1. Andrew Andriatis

    Andrew Andriatis Odin Team

    Messages:
    437
    Dear ALL!

    I am glad to announce that Parallels Plesk Automation 11.5 installation is available for your preview. Please note that this is not a stable release yet. We won't be providing its updates to bring it up to the production level. Instead after stabilization we will re-publish the entire distribution.

    The installer can be downloaded from http://autoinstall.plesk.com/PPA_11.5.0/ppa_installer . After that you can follow the PPA installation procedure described in the Quick Start Guide http://download1.parallels.com/ppa/docs/en-US/pdf/ppa_quick_start_guide.pdf . To install the management node you will need an x86_64 server with CentOS/RedHat 6. After installation please email at ppa@parallels.com to request the trial license. The release content overview is provided here: http://download1.parallels.com/ppa/11.5/docs/preview2_guide.pdf. As always, your feedback is welcome here, on our Forum, and in direct emails to ppa@parallels.com.

    Best regards,
    Andrey Andriatis
    Parallels Plesk Automation Program Manager
     
  2. sonics

    sonics Mega Poster

    Messages:
    160
    hello andrew

    many thanks for announcing the preview of the PPA 11.5 which we were waiting for.

    there is one big question for us because we host a lot of Windows web Servers.
    will it be possible in future to migrate or move a ppa 11.5 Windows web subscription from one win Service node to another?
    because in the future if one win web Service node gets old and Needs to be replaced by a new one....it Needs to be possible then to move/migrate the subscriptions from one win web serivce node to another.

    the other minor question is. what Kind of Windows Service nodes are supported by PPA 11.5?

    best regards chris
     
  3. sanarose

    sanarose Bit Poster

    Messages:
    8
    I have got great information's to this posting.
     
  4. DKTestL

    DKTestL Kilo Poster

    Messages:
    13
    Hello Andrew,

    Another important question is if PPA 11.5 supports Windows 2012 OS for the IIS Service Nodes as this is a requirement for us.
     
  5. Mosaic Data Services

    Mosaic Data Services Bit Poster

    Messages:
    5
    Hello Andrew:

    Also, will PPA 11.5 support ColdFusion 10? This is a requirement for us.
     
  6. Dartvader

    Dartvader Bit Poster

    Messages:
    2
    Trying to install according to instructions, get the error:

    Code:
    . / ppa_installer - password * - admin_email [email]*@*[/email]
    [INFO]: Checking current user privileges ...
    [INFO]: Checking critical environment requirements ...
    [INFO]: Determining OS parameters ...
    [INFO]: Detected OS: CentOS- 6 -x86_64
    [INFO]: Getting SELinux state ...
    [INFO]: SELinux: Permissive
    [INFO]: Getting system default locale ...
    [INFO]: Locale: en_US.UTF- 8
    [INFO]: Checking YUM package manager ...
    [INFO]: YUM: OK
    [INFO]: Checking whether the amount of memory available on the server is enough for installation ...
    [INFO]: Memory w / o swap: 1020424
    [INFO]: Swap: 2064376
    [INFO]: Memory Total: 3012 MB
    [INFO]: Checking that Plesk Panel is not installed ...
    [INFO]: Configuring critical environment parameters ...
    [INFO]: Configuring Parallels Plesk Automation thirdparty YUM repo ...
    [INFO]: Checking that following required packages are installed ...
    [INFO]: PACKAGES:
    [INFO]: MISSING: None
    [INFO]: Setting SELinux mode to 'Permissive' ...
    [INFO]: Disabling SELinux completely in config ...
    Traceback (most recent call last):
    **File ". / Ppa_installer", line 607 , in <module>
    ****from ppacommon import errors, utils, psexec, network, Password
    ImportError: No module named ppacommon
    What to do next and where to take this module "ppacommon"?
     
  7. Dartvader

    Dartvader Bit Poster

    Messages:
    2
    Close it.
    The problem was due to the fact that the repository ppa added to the yum.repos.d, but was not included.
     
  8. Andrew Andriatis

    Andrew Andriatis Odin Team

    Messages:
    437
    Thanks everybody for asking.

    1. Windows 2012 support is not ready yet. Will be issues as an update to 11.5. Stays as the highest priority on our list.
    2. We are working on moving webspaces between IIS nodes.

    Regards,
    Andrey
     
  9. eni523

    eni523 Bit Poster

    Messages:
    6
    0/10 would not bang

    1. like Dartvader said, the installer have a bug, it adds the repo but disabled. This can be fixed if change line 425 in ppa_installer from "enabled=0" to "enabled=1"
    2. but then after that it completley fails to install, at the point "Waiting for group_operations to start": (there where much more of this INFO-entry's i just paste a few of them)

    Code:
    [LOGTEE]: 2013-10-15 15:25:10.862  INFO Waiting for group_operations to start
    [LOGTEE]: 2013-10-15 15:25:13.869  INFO Waiting for group_operations to start
    [LOGTEE]: 2013-10-15 15:25:16.877  INFO Waiting for group_operations to start
    [LOGTEE]: 2013-10-15 15:25:19.884  INFO Waiting for group_operations to start
    [LOGTEE]: 2013-10-15 15:25:22.891  INFO Waiting for group_operations to start
    [LOGTEE]: 2013-10-15 15:25:25.899  INFO Waiting for group_operations to start
    [LOGTEE]: 2013-10-15 15:25:28.906  INFO Waiting for group_operations to start
    [LOGTEE]: 2013-10-15 15:25:31.911  INFO Waiting for group_operations to start
    [LOGTEE]: 2013-10-15 15:25:34.917  INFO Waiting for group_operations to start
    [LOGTEE]: 2013-10-15 15:25:37.924  INFO Waiting for group_operations to start
    [LOGTEE]: 2013-10-15 15:25:40.931  INFO Waiting for group_operations to start
    [LOGTEE]: 2013-10-15 15:25:43.939  INFO Waiting for group_operations to start
    [LOGTEE]: 2013-10-15 15:25:46.943 ERROR Exception [u'group_operations'] failed to start
    [LOGTEE]: 2013-10-15 15:25:46.943 ERROR <type 'exceptions.Exception'>
    [LOGTEE]: [u'group_operations'] failed to start
    [LOGTEE]: 2013-10-15 15:25:46.971 ERROR 
    [LOGTEE]:   at wait_for_scs (/var/cache/ppa/dists/PPA_11.5.0/POA/poaupdater/uPEM.py :194) in raise Exception("%s failed to start" % sclist)
    [LOGTEE]:   at installModule (/var/cache/ppa/dists/PPA_11.5.0/POA/install_routines.py :1002) in uPEM.wait_for_scs([name], monitor = SCWaiter([name], installation.progress, 0, 2))
    [LOGTEE]:   at installPlatform (/var/cache/ppa/dists/PPA_11.5.0/POA/install_routines.py :1037) in installModule(installation, platform)
    [LOGTEE]:   at rv (/var/cache/ppa/dists/PPA_11.5.0/POA/install :249) in return fun(*args, **kwds)
    [LOGTEE]:   at doInstall (/var/cache/ppa/dists/PPA_11.5.0/POA/install :585) in phase_fun(install_routines.installPlatform, progress, "Installing Platform")(installation)
    [LOGTEE]:   at main (/var/cache/ppa/dists/PPA_11.5.0/POA/install :755) in doInstall(ui, config, bu_helper)
    [LOGTEE]:   at <module> (/var/cache/ppa/dists/PPA_11.5.0/POA/install :900) in main(config, backup_helper)
    [LOGTEE]: 2013-10-15 15:25:46.975 ERROR POA installation failed. Check installation log at /var/log/poa-install.log
    [ERROR]: Failed to execute command: ['/var/cache/ppa/dists/PPA_11.5.0/POA/install', '--config', '/var/cache/ppa/dists/PPA_11.5.0/POA/poa_config', '--batch', '--reinstall']
    [ERROR]: See installation log file /tmp/ppa_installer.log for details.
    
    seems like a problem with pem:
    Code:
    # /etc/init.d/pem stop
    Stopping pleskd:                                           [  OK  ]
    # /etc/init.d/pem start
    Starting pleskd: terminate called after throwing an instance of 'std::runtime_error'
      what():  Cannot dlopen /usr/local/pem/libexec/group_operations.so.5.5.1.17: libxml++-2.6.so.2: cannot open shared object file: No such file or directory
                                                               [  OK  ]
    
    i have both of those binarys located on my machine:
    Code:
    # ll /usr/local/pem/libexec/group_operations.so.5.5.1.17 
    -rwxr-xr-x 1 root root 10680437  9. Okt 09:27 /usr/local/pem/libexec/group_operations.so.5.5.1.17
    # locate libxml++-2.6.so.2
    /usr/lib64/libxml++-2.6.so.2
    /usr/lib64/libxml++-2.6.so.2.0.7
    
    To the ppa-devs: is there a way to fix this error? we are really interested in this preview..



    but after the first try, this looks like another piece of quality software from parallels</irony>
     
  10. Andrey Dobrenko

    Andrey Dobrenko Odin Team

    Messages:
    256
    Hi, eni523,

    #ldd /usr/local/pem/libexec/group_operations.so.5.5.1.17
    linux-gate.so.1 => (0x00bb8000)
    libplatform.so => /usr/local/pem/lib/libplatform.so (0xf6c8d000)
    libpacryptoapi.so => /usr/local/platform/lib/libpacryptoapi.so (0x00c1a000)
    libACE.so.6.0.5 => /usr/lib/libACE.so.6.0.5 (0x00c3c000)
    libTAO.so.2.0.5 => /usr/lib/libTAO.so.2.0.5 (0x00e9f000)
    libTAO_AnyTypeCode.so.2.0.5 => /usr/lib/libTAO_AnyTypeCode.so.2.0.5 (0x00853000)
    libTAO_CodecFactory.so.2.0.5 => /usr/lib/libTAO_CodecFactory.so.2.0.5 (0x008e2000)
    libTAO_DynamicInterface.so.2.0.5 => /usr/lib/libTAO_DynamicInterface.so.2.0.5 (0x008f5000)
    libTAO_Messaging.so.2.0.5 => /usr/lib/libTAO_Messaging.so.2.0.5 (0x00bbe000)
    libTAO_PI.so.2.0.5 => /usr/lib/libTAO_PI.so.2.0.5 (0x00914000)
    libTAO_PI_Server.so.2.0.5 => /usr/lib/libTAO_PI_Server.so.2.0.5 (0x0094c000)
    libTAO_PortableServer.so.2.0.5 => /usr/lib/libTAO_PortableServer.so.2.0.5 (0x00961000)
    libTAO_Valuetype.so.2.0.5 => /usr/lib/libTAO_Valuetype.so.2.0.5 (0x00a28000)
    libxcode.so.1.0 => /usr/lib/libxcode.so.1.0 (0x00a3d000)
    libcrypt.so.1 => /lib/libcrypt.so.1 (0x00ac5000)
    libpthread.so.0 => /lib/libpthread.so.0 (0x00b1c000)
    libssl.so.10 => /usr/lib/libssl.so.10 (0x00b37000)
    libcrypto.so.10 => /usr/lib/libcrypto.so.10 (0x00fd1000)
    libxml++-2.6.so.2 => not found
    libglibmm-2.4.so.1 => not found
    libgobject-2.0.so.0 => not found
    libsigc-2.0.so.0 => not found
    libglib-2.0.so.0 => not found


    To fix the issue jut install 32 bit libxml++. For instance, #yum install libxml++.i686. Once, re-run the installation script again and this will work fine! That issue is already localized and will definitely have fixed by the PPA 11.5 RTM. Thank you very much to all for reporting.

    --
    Andrey Dobrenko
    Development Manager
    Parallels Plesk Automation
    Web Site: http://www.parallels.com/products/plesk-automation/
     
  11. GrigoryK

    GrigoryK Odin Team

    Messages:
    8
    ppacommon package is installed by ppa_installer automatically by default.

    The first issue that I see is that '[INFO]: PACKAGES:' string is empty but it should contain a list of packages that ppa_installer will check and install missing ones (incl. ppacommon).

    Did you altered the installer?
     
  12. eni523

    eni523 Bit Poster

    Messages:
    6
    Hi Andrey

    Thanks, after the installer did a little more but stopped at the following:

    Code:
    [LOGTEE]: 2013-10-15 17:07:33.032  INFO installing sc-SharedNodeRegistrator-5.5.1.58 (152) to host 1
    [LOGTEE]: 2013-10-15 17:07:51.860 ERROR OpenAPIError Error during OpenAPI call: Destination host 'ppa115-master.vmware' (#1), IP '172.16.23.50' : Native dependency processing failed;  		list of dependences: libwsman1.i686 >= 2.2.4-4:winexe >= 0.91-2:libgcrypt.i686 >= 1.4.4-5:libssh2.i686  .  			Please either install the packages above, 			or application templates with them. 			Error: /usr/local/pem/sbin/pem-pkg-tool:21: DeprecationWarning: The popen2 module is deprecated.  Use the subprocess module.
    [LOGTEE]:   import popen2
    [LOGTEE]: Missing or unsatisfied requirements: { libwsman1.i686 (>=2.2.4-4) }
    [LOGTEE]: Candidates were: [ libwsman1.i686 (2.2.3-8.el6, i686) ].
    [LOGTEE]: 2013-10-15 17:07:51.863 ERROR <class 'poaupdater.openapi.OpenAPIError'>
    [LOGTEE]: Error during OpenAPI call: Destination host 'ppa115-master.vmware' (#1), IP '172.16.23.50' : Native dependency processing failed;  			list of dependences: libwsman1.i686 >= 2.2.4-4:winexe >= 0.91-2:libgcrypt.i686 >= 1.4.4-5:libssh2.i686  .  			Please either install the packages above, 			or application templates with them. 		Error: /usr/local/pem/sbin/pem-pkg-tool:21: DeprecationWarning: The popen2 module is deprecated.  Use the subprocess module.
    [LOGTEE]:   import popen2
    [LOGTEE]: Missing or unsatisfied requirements: { libwsman1.i686 (>=2.2.4-4) }
    [LOGTEE]: Candidates were: [ libwsman1.i686 (2.2.3-8.el6, i686) ].
    [LOGTEE]: 2013-10-15 17:07:51.961 ERROR 
    [LOGTEE]:   at __call__ (/var/cache/ppa/dists/PPA_11.5.0/POA/poaupdater/openapi.py :164) in raise OpenAPIError(resp)
    [LOGTEE]:   at installPackageToHostAPI (/var/cache/ppa/dists/PPA_11.5.0/POA/poaupdater/uPackaging.py :152) in return api.pem.packaging.installPackageSync(host_id = host_id, package_id = pkg_id, properties = proplist)["component_id"]
    [LOGTEE]:   at installModule (/var/cache/ppa/dists/PPA_11.5.0/POA/install_routines.py :986) in properties = pkg_properties.get((ctype, name), {}))
    [LOGTEE]:   at installPlatform (/var/cache/ppa/dists/PPA_11.5.0/POA/install_routines.py :1037) in installModule(installation, platform)
    [LOGTEE]:   at rv (/var/cache/ppa/dists/PPA_11.5.0/POA/install :249) in return fun(*args, **kwds)
    [LOGTEE]:   at doInstall (/var/cache/ppa/dists/PPA_11.5.0/POA/install :585) in phase_fun(install_routines.installPlatform, progress, "Installing Platform")(installation)
    [LOGTEE]:   at main (/var/cache/ppa/dists/PPA_11.5.0/POA/install :755) in doInstall(ui, config, bu_helper)
    [LOGTEE]:   at <module> (/var/cache/ppa/dists/PPA_11.5.0/POA/install :900) in main(config, backup_helper)
    [LOGTEE]: 2013-10-15 17:07:51.964 ERROR POA installation failed. Check installation log at /var/log/poa-install.log
    [ERROR]: Failed to execute command: ['/var/cache/ppa/dists/PPA_11.5.0/POA/install', '--config', '/var/cache/ppa/dists/PPA_11.5.0/POA/poa_config', '--batch', '--reinstall']
    [ERROR]: See installation log file /tmp/ppa_installer.log for details.
    
    i manually installed the missing libs:
    Code:
    # wget http://autoinstall.plesk.com/PPA_11.5.0/POA/os/RHEL/6/RPMS/libwsman1-2.2.4-6.parallels.i686.rpm
    # rpm -i libwsman1-2.2.4-6.parallels.i686.rpm
    # yum install libgcrypt.i686 libssh2.i686 winexe
    
    and the installer was able to run trough, now the prewiew is running. thanks for your hints.
     
  13. DKTestL

    DKTestL Kilo Poster

    Messages:
    13
    Thank you for your reply Andrew!

    Do we atleast have an ETA on when this will be supported as we would like to start testing PPA 11.5 on our test servers and also test it with the option to add an IIS Service node running windows 2012.
     
  14. GrigoryK

    GrigoryK Odin Team

    Messages:
    8
    Hi, eni523,

    Could you please let us know how did you get your CentOS 6 installation? As I can see it's a kind of vmware container.
    Is it pre-defined CentOS 6 one or manual CentOS 6 installation?

    I'm asking because all your issues looks like result of somehow broken yum configuration and they should not appear under normal conditions.
     
  15. eni523

    eni523 Bit Poster

    Messages:
    6
    It's a manual installation (on a vmware host), with pretty a pretty basic setup. to the yum part: i added the epel-repo (need it for some nrpe-stuff) and use yum-priorities, but imho this is a normal condition.
     
  16. DobromirD

    DobromirD Bit Poster

    Messages:
    5
    Does any plans for CloudLinux support (LVE and/or CageFS) in next release (11.5) for Web service nodes?

    Regards,
    Dobromir Dobrev
     
  17. Andrew Andriatis

    Andrew Andriatis Odin Team

    Messages:
    437
    CloudLinux is in our backlog, but it doesn't get into the PPA 11.5 release. We have not finished planning for further updates yet.

    Regards,
    Andrey Andriatis
     
  18. DKTestL

    DKTestL Kilo Poster

    Messages:
    13
    Hello,

    Can you also inform us if the upgrade from 11.1 to 11.5 will be an automatic process or we will have to re-install the management node?

    Thank you!
     
  19. cyberhostpro

    cyberhostpro Kilo Poster

    Messages:
    74
    HI

    Why is this 2 OS's behind for windows? No 2012 support, and 2012 R2 came out last week!! can you confirm when 2012 and 2012 R2 will be supported.
     
  20. sonics

    sonics Mega Poster

    Messages:
    160
    Hello

    installed pa 11.5 and wanted to change the communication ip of the mgt node but get the following error:

    [root@ppamgt1 bin]# ./ppa.ip_address mapfile
    /usr/lib/python2.6/site-packages/poaupdater/uPEM.py:9: DeprecationWarning: the sets module is deprecated
    import sets
    /usr/lib/python2.6/site-packages/poaupdater/uBuild.py:2: DeprecationWarning: the md5 module is deprecated; use hashlib instead
    import md5
    [Thu 24 Oct 2013 07:15:23 AM CEST][INFO] checking the system configurations...
    Traceback (most recent call last):
    File "./ppa.ip_address", line 746, in <module>
    sys.exit(main(sys.argv[1]))
    File "./ppa.ip_address", line 717, in main
    return changeIP(mapFilePath)
    File "./ppa.ip_address", line 678, in changeIP
    cIP.inSystem()
    File "./ppa.ip_address", line 450, in inSystem
    replaceInFileByPattern(psqlConfPath, r"(host\s+all\s+(?:all|plesk)\s+)\d+\.\d+\.\d+\.\d+(\s+\d+\.\d+\.\d+\.\d+\s+trust)", r'\g<1>%s\g<2>' % self.ipCom.new)
    File "./ppa.ip_address", line 196, in replaceInFileByPattern
    uUtil.editFileSafe(filePath, processFile(lambda buffer: re.sub(pattern, repl, buffer)), None)
    File "/usr/lib/python2.6/site-packages/poaupdater/uUtil.py", line 365, in editFileSafe
    fstat = os.stat(filename)
    OSError: [Errno 2] No such file or directory: '/var/lib/pgsql/9.0/data/pg_hba.conf'


    best regards chris
     

Share This Page