Postfix

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by Eyecu, Feb 7, 2009.

  1. Eyecu

    Eyecu Kilo Poster

    Messages:
    13
    Good day,
    I am getting the following in my messages log coming from postfix and can't seem to find an answer anywhere,

    Feb 7 21:12:26 hs1 postfix/smtpd[19157]: DEBUG postfix smtpd supplementary group (12, <unable to get mnemonic name>)
    Feb 7 21:12:26 hs1 postfix/smtpd[19157]: DEBUG postfix smtpd supplementary group (89, <unable to get mnemonic name>)
    Feb 7 21:12:26 hs1 postfix/smtpd[19157]: DEBUG postfix smtpd real group (89, <unable to get mnemonic name>)
    Feb 7 21:12:26 hs1 postfix/smtpd[19157]: DEBUG postfix smtpd effective group (89, <unable to get mnemonic name>)
    Feb 7 21:12:26 hs1 postfix/smtpd[19157]: DEBUG postfix smtpd saved group (89, <unable to get mnemonic name>)

    Any help would greatly be appreciated.

    Thanks
     
  2. Eyecu

    Eyecu Kilo Poster

    Messages:
    13
    Now i seem to be getting another error logging with postfix the following is new and just started this evening.

    Feb 8 02:29:12 hs1 postfix/smtpd[5931]: sql_sqlite3 plugin: no result found
    Feb 8 02:29:12 hs1 postfix/smtpd[5931]: sql_sqlite3 plugin: COMMIT TRANSACTION failed: cannot start a transaction within a transaction
    Feb 8 02:29:12 hs1 postfix/smtpd[5931]: Unable to commit transaction
     
  3. ramuva

    ramuva Kilo Poster

    Messages:
    32
    I was banging my head against the wall for a while with this one :)
    The first part is about running chrooted. Not sure now if it was postfix or saslauthd
    The second is about plesk_saslauthd. Did not quite figure this one out, permission problem, just chmoded 777 passwd.db and it was gone.

    Some users (or all) were unable to send emails, because they could not auth against passwd.db.
     
  4. galaxy

    galaxy Mega Poster

    Messages:
    241
    Can you post your master.cf?
    I can't auth using either testsaslauthd or via postfix.
    I'm not sure where plesk_saslauthd comes into play and wondered about its chroot settings.
    And did you change the permissions on passwd.db or the directory it was in?


    OK, finally got this working (banging my head too...)

    you need to:

    # ln -s /var/spool/postfix/plesk /plesk

    and it works...
     
    Last edited: May 18, 2009
  5. lvalics

    lvalics Product Expert

    Messages:
    1,019
    The full solution is here for this issue.
     
  6. lvalics

    lvalics Product Expert

    Messages:
    1,019
  7. galaxy

    galaxy Mega Poster

    Messages:
    241
    Actually on the symlink is required.
    Its a bad idea to change the permissions with the chmod command as that will open up access to the password database.

    UPDATE:

    Sorry, I spoke too soon. The symlink only solves the problem half the time. I still get lots of errors with SASL and errors in the log like:

    May 19 09:23:29 neptune postfix/smtpd[7931]: connect from host-xyz.net[x.x.x.x]
    May 19 09:23:29 neptune postfix/smtpd[7931]: warning: SASL authentication failure: cannot connect to saslauthd server: No such file or directory
    May 19 09:23:29 neptune postfix/smtpd[7931]: warning: host-xyz.net[x.x.x.x]: SASL LOGIN authentication failed: generic failure
    May 19 09:23:29 neptune postfix/smtpd[7931]: lost connection after AUTH from host-xyz.net[x.x.x.x]
    May 19 09:23:29 neptune postfix/smtpd[7931]: disconnect from host-xyz.net[x.x.x.x]

    I've tried adding in the permissions changes for the /var/spool/postfix/plesk directory and the passwd.db file, however it made no change. Users still get the same error.

    So in summary, the symlink halfway solves the problem (for most customers), however the permission changes don't appear to help at all (so don't change them). I've sent a bug report to Parallels...
     
    Last edited: May 19, 2009
  8. dash

    dash Odin Team

    Messages:
    170
    Sirs,
    It’s definitely a bad idea to set r permissions for all system users to /plesk/passwd.db file. In this case any user can get access to your mail password database.
    Let’s try to understand what’s wrong in postfix/Plesk configuration instead.
    Check postfix chroot directory:
    Check queue_directory = /var/spool/postfix parameter in /etc/postfix/main.cf file

    Directory /var/spool/postfix/plesk should exist.
    It should be owned by postfix user with RWX permissions (you can get exactly user name on your system in /etc/postfix/main.cf, parameter mail_owner = postfix )

    File /var/spool/postfix/plesk/passwd.db should be owned by postfix user with r permission and group root with rwx permissions

    Check authorization service:
    Service plesk_saslauthd should be registered in /etc/postfix/master.cf file:
    plesk_saslauthd unix y y y - 1 plesk_saslauthd status=5 listen=6 dbpath=/plesk/passwd.db

    check sasl configuration file:
    Check your /etc/sasl2/smtpd.conf, /usr/lib/sasl2/smtpd.conf, /usr/lib64/sasl2/smtpd.conf, etc (depending on your OS and arch)
    This file should contain:
    And finally, check unix socket /var/spool/postfix/private/plesk_saslauthd:
    srw-rw-rw- 1 postfix postfix 0 May 13 09:16 /var/spool/postfix/private/plesk_saslauthd
     
  9. galaxy

    galaxy Mega Poster

    Messages:
    241
    I agree, its a bad idea to open up the password database.

    However I have everything setup the way you specified.

    SMTP authentication doesn't work. It will work for *some* if the symlink is installed (so there's a chroot issue too).
    I get the errors as specified in the prior post.

    I'm running on CentOS 5
     
  10. dash

    dash Odin Team

    Messages:
    170
    I've just tried to play with postfix auth and emulate auth errors.
    the only way i can receive this exact error (warning: SASL authentication failure: cannot connect to saslauthd server: No such file or directory) is that postfix can’t connect to unix socket /var/spool/postfix/private/plesk_saslauthd during authorization.

    So, check that unix socket /var/spool/postfix/private/plesk_saslauthd exists
    If it exists, it can be a chroot problem again.
    Try to set full path in /usr/lib/sasl2/smtpd.conf:
    saslauthd_path: /var/spool/postfix/private/plesk_saslauthd
    do not forget to reload postfix: /etc/init.d/postfix reload
     
  11. galaxy

    galaxy Mega Poster

    Messages:
    241
    That seems to have done it.

    Thanks !
     
  12. 2dareis2do

    2dareis2do Kilo Poster

    Messages:
    32
    postfix v's qmail

    I have tried all the above things. I am running CentOS 5 and have now decided to migrate back to qmail as out lined here:

    http://kb.odin.com/en/5801

    No more error messages. So I guess the problem with qmail when 9.0 was released has been fixed.

    Thx
     
  13. SaschaH

    SaschaH Bit Poster

    Messages:
    2
    We stumbled into the same problem since yesterday but we weren´t able to track down the issue why it happened from now to then without any warning.

    In fact Plesk overwrote the "smtpd.conf" file because in the backup file there was the full path to the unix socket and not the incremental path, so i´ve changed the path to the full path and viola the socket was created and people are now able to send mails again.
     
  14. jaydisc

    jaydisc Bit Poster

    Messages:
    5
    This solved the issue for me:

     
  15. Thomas Gonzalez

    Thomas Gonzalez Bit Poster

    Messages:
    7
    Seems to solved the issue but the path was /usr/lib64/sasl2/smtpd.conf
     
  16. Christopher McBride

    Christopher McBride Kilo Poster

    Messages:
    89
    I'm having the same problem at the moment.

    I'm running CentOS 5 x86_64 with Plesk 9.3 and everything up to date.

    Have been getting the following messages in /var/log/messages:

    Apr 16 09:18:14 mail postfix/smtpd[7300]: sql_sqlite3 plugin: no result found
    Apr 16 09:21:38 mail postfix/smtpd[7108]: sql_sqlite3 plugin: no result found
    Apr 16 09:21:51 mail postfix/smtpd[7729]: sql_sqlite3 plugin: no result found
    Apr 16 09:24:00 mail postfix/smtpd[7300]: sql_sqlite3 plugin: no result found


    As well as:
    Apr 16 10:28:05 mail postfix/smtpd[8115]: sql_sqlite3 plugin prepare SQL statement for query 'SELECT cmusaslsecretDIGEST-MD5 FROM domains d, users u WHERE u.name='XXXXX' and d.name='XXXXXXX' and d.status=0 and u.status=0 and u.dom_id=d.id;' error: no such column: MD5 (names removed)

    I've read about the second and know it is work in progress for a fix.

    Neither are causing any problems with delivering mail as above, but I'd rather them fixed.


    I've followed everything in this thred:
    queue_directory = /var/spool/postfix - Correct
    /var/spool/postfix/plesk - Exists and has correct permissions
    passwd.db - permissions correct
    Authorization service - Correct
    /usr/lib64/sasl2/smtpd.conf - Correct - with full path for saslauthd_path
    Unix socket permissions - Correct

    Even aftr setting chroot to "n" in /etc/postfix/master.cf, both errors are being produced.

    Anyone got any advice to remove this annoyance please?

    Thanks
     
  17. m0rpheu5

    m0rpheu5 Mega Poster

    Messages:
    113
    I´m having this exactly issue in my 4 servers with Plesk 9.5.4 running postfix, all permissions, path etc is right.

    what could be? Follow below my configurations and permissions.

    /usr/local/psa/var/log/maillog
    May 5 16:48:10 br01 postfix/smtpd[7156]: warning: SASL authentication failure: cannot connect to saslauthd server: No such file or directory
    May 5 16:48:10 br01 postfix/smtpd[7197]: warning: SASL authentication failure: cannot connect to saslauthd server: No such file or directory


    /var/log/messages
    May 5 16:49:51 br01 postfix/smtpd[8325]: sql_sqlite3 plugin: no result found
    May 5 16:49:51 br01 postfix/smtpd[8410]: sql_sqlite3 plugin: no result found
    May 5 16:49:51 br01 postfix/smtpd[8325]: sql_sqlite3 plugin: no result found
    May 5 16:49:51 br01 postfix/smtpd[8364]: sql_sqlite3 plugin: no result found
    May 5 16:49:51 br01 postfix/smtpd[8410]: sql_sqlite3 plugin: no result found
    May 5 16:49:51 br01 postfix/smtpd[8412]: sql_sqlite3 plugin: no result found

    queue_directory = /var/spool/postfix - Correct

    /var/spool/postfix/plesk exists and the permissions is right
    drwxrwx--- 2 postfix root 4096 May 5 13:46 plesk

    passwd.db - exist and permission is right
    -r--rw---- 1 postfix root 128000 May 5 13:46 passwd.db

    Authorization service - Correct
    /usr/lib/sasl2/smtpd.conf - Correct - folow below


    pwcheck_method: auxprop saslauthd
    auxprop_plugin: sql_sqlite3
    saslauthd_path: /var/spool/postfix/private/plesk_saslauthd
    mech_list: DIGEST-MD5 CRAM-MD5 PLAIN LOGIN
    auto_transition: yes
    sql_engine: sqlite3
    sql_hostnames: localhost
    sql_database: /plesk/passwd.db
    sql_select: SELECT `%p` FROM domains d, users u WHERE u.name='%u' and d.name='%r' and d.status=0 and u.status=0 and u.dom_id=d.id
    sql_verbose: yes
    log_level: 9

    Unix socket permissions - Correct
    srw-rw-rw- 1 postfix postfix 0 May 5 13:42 plesk_saslauthd
     
    Last edited: May 5, 2011
  18. m0rpheu5

    m0rpheu5 Mega Poster

    Messages:
    113
    if i change back the saslauthd_path to /private/plesk_saslauthd, i stop getting the error message: "warning: SASL authentication failure: cannot connect to saslauthd server: No such file or directory" but i started getting many message like this:

    May 5 16:59:41 br01 postfix/smtpd[13919]: warning: unknown[187.74.96.67]: SASL LOGIN authentication failed: authentication failure
    May 5 16:59:41 br01 postfix/smtpd[13876]: disconnect from unknown[200.29.109.98]
    May 5 16:59:41 br01 postfix/smtpd[13914]: disconnect from unknown[187.42.243.31]
    May 5 16:59:41 br01 postfix/smtpd[13876]: table hash:/var/spool/postfix/plesk/poplock(0,lock|fold_fix) has changed -- restarting
    May 5 16:59:41 br01 postfix/smtpd[13914]: table hash:/var/spool/postfix/plesk/poplock(0,lock|fold_fix) has changed -- restarting
    May 5 13:59:41 br01 postfix/smtpd[13924]: connect from unknown[178.198.101.206]
    May 5 16:59:41 br01 plesk_saslauthd[13204]: activity on 1 channel(s)
    May 5 16:59:41 br01 plesk_saslauthd[13204]: new client (fd=10) registered
    May 5 16:59:41 br01 plesk_saslauthd[13204]: main cycle iteration
    May 5 16:59:41 br01 plesk_saslauthd[13204]: activity on 1 channel(s)
    May 5 16:59:41 br01 plesk_saslauthd[13204]: some read activity on client 10
    May 5 16:59:41 br01 plesk_saslauthd[13204]: read(10, &buf, 2)=2
    May 5 16:59:41 br01 plesk_saslauthd[13204]: processing client data chunk [state=0]
    May 5 16:59:41 br01 plesk_saslauthd[13204]: read(10, &buf, 12)=12
    May 5 16:59:41 br01 plesk_saslauthd[13204]: processing client data chunk [state=1]
    May 5 16:59:41 br01 plesk_saslauthd[13204]: read(10, &buf, 2)=2
    May 5 16:59:41 br01 plesk_saslauthd[13204]: processing client data chunk [state=2]
    May 5 16:59:41 br01 plesk_saslauthd[13204]: read(10, &buf, 7)=7
    May 5 16:59:41 br01 plesk_saslauthd[13204]: processing client data chunk [state=3]
    May 5 16:59:41 br01 plesk_saslauthd[13204]: read(10, &buf, 2)=2
    May 5 16:59:41 br01 plesk_saslauthd[13204]: processing client data chunk [state=4]
    May 5 16:59:41 br01 plesk_saslauthd[13204]: read(10, &buf, 4)=4
    May 5 16:59:41 br01 plesk_saslauthd[13204]: processing client data chunk [state=5]
    May 5 16:59:41 br01 plesk_saslauthd[13204]: read(10, &buf, 2)=2
    May 5 16:59:41 br01 plesk_saslauthd[13204]: processing client data chunk [state=6]
    May 5 16:59:41 br01 plesk_saslauthd[13204]: read(10, &buf, 19)=19
    May 5 16:59:41 br01 plesk_saslauthd[13204]: processing client data chunk [state=7]


    and in the /var/log/message i continue getting the messages:
    May 5 17:00:47 br01 postfix/smtpd[14291]: sql_sqlite3 plugin: no result found
    May 5 17:00:47 br01 postfix/smtpd[14291]: sql_sqlite3 plugin: no result found
    May 5 17:00:47 br01 postfix/smtpd[14223]: sql_sqlite3 plugin: no result found
    May 5 17:00:47 br01 postfix/smtpd[14223]: sql_sqlite3 plugin: no result found
    May 5 17:00:47 br01 postfix/smtpd[14335]: sql_sqlite3 plugin: no result found
    May 5 17:00:47 br01 postfix/smtpd[14310]: sql_sqlite3 plugin: no result found
    May 5 17:00:48 br01 postfix/smtpd[14356]: sql_sqlite3 plugin: no result found


    Thanks
     
  19. Kewler

    Kewler Bit Poster

    Messages:
    5
    This doesn't work for SMB

    Setting Up Mail Services

    The Panel works in cooperation with mail server software, which provides e-mail services for mailboxes and mailing lists. After installation the mail server is configured automatically and is ready to serve, however, we recommend that you review the default settings to make sure that they satisfy your needs.

    By default, the Postfix mail server is installed on the Panel for Linux platforms, and MailEnable mail server, on the Panel for Windows platforms. You can install another mail server software, if it is supported by your Panel, and then set up the Panel for using it.

    To use another mail server software with your Panel (currently supported only on Windows hosting):
     

Share This Page