PBAS: The form you sent was not recognized by the Openprovider system

Discussion in 'Troubleshooting' started by AaronMcH, Sep 6, 2014.

  1. AaronMcH

    AaronMcH Mega Poster

    Messages:
    130
    Hi

    When a domain was transferred today the process failed with the following error: "The form you sent was not recognized by the Openprovider system", the main error is linked below:

    http://pastebin.com/CKEptTk0

    Any help would be great,
    Thanks
    Aaron
     
  2. FedorK

    FedorK Mega Poster

    Messages:
    224
    Hello Aaron,

    Looks like XML is correct. Do you contact with OpenProvider support?

    Thank you,
     
  3. AaronMcH

    AaronMcH Mega Poster

    Messages:
    130
    Hi Fedor

    Thanks for the reply, I have forwarded this to OpenProvider who are going to look into it.

    Thanks
    Aaron
     
  4. AaronMcH

    AaronMcH Mega Poster

    Messages:
    130
    Hi

    A resolution was reached with OpenProvider, the Auth Code had two angle brackets arrange in such as way that was causing the XML form to be broken when it was submitted (e.g. **<*******>**).

    They suggested that I inform Parallels of this to allow a fix to be put into the new update to the plugin that is being developed. Regarding the update, I also want to check that the OpenProvider plugin will have full support for allowing the customer to change the IPS TAG that is associated with a Nominet .uk domain? As they use IPS TAGs when transferring domains instead of Auth Codes.

    Thank you
    Aaron
     
  5. Vadim Ivanov

    Vadim Ivanov Kilo Poster

    Messages:
    36
  6. AaronMcH

    AaronMcH Mega Poster

    Messages:
    130
    Hi Vadim, thanks for the reply

    Ah ok, I'll reply to my ticket with that update.

    In this case I'm not talking about transferring in, I'm talking about if people want to transfer out, then PBAS needs functionality to allow people to change the IPS TAG of a .uk domain, as like I said Nominet doesn't use Auth Codes.

    Thank you
    Aaron
     
  7. FedorK

    FedorK Mega Poster

    Messages:
    224
    Hello Aaron,

    We have such feature request but it not sceduled yet.
    Feature ID for your reference PBAS-15059
     
  8. AaronMcH

    AaronMcH Mega Poster

    Messages:
    130
    Hi Vadim

    I received another update from OpenProvider, they said that requests that contain angle-brackets should be replaced with HTML Entities, so &lt; and &gt; respectively, not sure if the new version of the plugin does this or not.

    Thank you
    Aaron
     
    Last edited: Sep 19, 2014
  9. Vadim Ivanov

    Vadim Ivanov Kilo Poster

    Messages:
    36
    Hi Aaron,

    the issues with angle brackets etc. are handled automatically by default on xml preparation step.
     
  10. AaronMcH

    AaronMcH Mega Poster

    Messages:
    130
    Hi Vadim

    Thanks for the reply, good to hear that this will now be handled properly.

    Best regards
    Aaron
     

Share This Page