PBAS install error: "error while loading shared libraries: libpopt.so"

Discussion in 'Troubleshooting' started by LoreZyra, Jul 4, 2012.

  1. LoreZyra

    LoreZyra Kilo Poster

    Messages:
    27
    I have created a RHEL 6 box and sucessfully installed PVC4.7-64bit with the PVA-agent. Upon trying to install PBAS into my new container, I get an error about a missing library file.

    Can anyone point me in the right direction to resolve this issue?

     
  2. vbatraev

    vbatraev Odin Team

    Messages:
    346
    Please read release notes: http://download.pa.parallels.com/pbas/4.2/release/release-notes.txt
    From the notes:
    2) The following Operating Systems are supported:
    * Redhat Enterprise Linux AS5
    * CentOS 5

    NOTE: Only x86 versions are supported.
    x86_64 architecture OSes are not supported.

    You should create a Container with 32bit CentOS5 or RHEL5 (It may be done on PVC4.7-64bit).
     
  3. LoreZyra

    LoreZyra Kilo Poster

    Messages:
    27
    I found the "missing" library and created a symbolic link to it on both the host and container...

    Now, when I run the PBAS installer, I get an error that it's the wrong class... Is this installer a 32-bit app??? If so, where can I download the 64-bit version?
     
  4. LoreZyra

    LoreZyra Kilo Poster

    Messages:
    27
    Thanks. Any idea when the 64 bit OS will be supported?
     
  5. vimalkumarj

    vimalkumarj Bit Poster

    Messages:
    2
    Hi,

    while booting getting error "error while loading shared libraries: libpopt.so.0 cannot open shared object file" no such file or directory

    Now i am unable to boot, any help appreciated
     
    Last edited: Apr 30, 2013

Share This Page