PBAS - Adding Bare Metal Server

Discussion in 'Troubleshooting' started by Decisiveservers, Jun 28, 2012.

  1. Decisiveservers

    Decisiveservers Kilo Poster

    Messages:
    12
    Hi All,

    Wondering if you can help. We are looking to start creating VMs for users to use. We are looking at using the Parallels Bare Metal Server as this integrates into PBAS.

    We have installed PBMS into a server and can connect no problems with the management console, but get an error when trying to add the node into PBAS

    We have put the IP and correct password in. Even tried changing the password to "welcome1" just to test but keep getting the error
    "Can't connect to Parallels Server node" Nothing in the event logs and the CP server can connect via ssh and can ping etc.

    Anyone had the same issue or any ideas?

    Thanks

    Kind Regards,
    Rob

    --------------------------
    Decisiveservers Admin
     
  2. Decisiveservers

    Decisiveservers Kilo Poster

    Messages:
    12
    *bump* - Please help? :)
     
  3. vbatraev

    vbatraev Odin Team

    Messages:
    346
    Enable "debug" level for logs in Configuration Director > Logging and Errors > Log Settings.
    Try to connect the node again and then check /var/log/hspc/hspc.log log file for errors to identify root cause of the issue.
     
  4. Decisiveservers

    Decisiveservers Kilo Poster

    Messages:
    12
    Hi,

    Thanks, I have enabled logging and then tried to add the mode again. I still get the error which I would expect but nothing appears to get written to the log file. Would you like me to copy and past what's output the second it click the add button?

    BTW - This is PBAS 4.2

    Kind Regards,
    Rob
     
  5. Decisiveservers

    Decisiveservers Kilo Poster

    Messages:
    12
    Just to incase the answer to the question is yes, please post the logs... Here they are:
    There is an error about "Can't init transport"


    [2012/06/29 11:39:43] [DEBUG] [20271] [HSPC::Application::db_connection] SQL Connection got for 'MAIN': 0 => 4165
    [2012/06/29 11:39:43] [DEBUG] [20271] [HSPC::WebSystem::reinit_security] LOGIN:try to login to account # , result=HSPC::WebSecurity=HASH(0x1f2369c8)
    [2012/06/29 11:39:43] [DEBUG] [20271] [HSPC::Logger::sw_trace] TRACE [01]: +> HSPC::MT::GM->find_provider_config ()
    [2012/06/29 11:39:43] [DEBUG] [20271] [HSPC::Logger::sw_trace] TRACE [02]: . +> HSPC::MT::Core->find_account (account_id=>1)
    [2012/06/29 11:39:43] [DEBUG] [20271] [HSPC::Logger::sw_trace] TRACE [03]: . . +> HSPC::MT::Core::AbstractAccount->load (self=>HSPC::MT::Core::HSP, id=>1)
    [2012/06/29 11:39:43] [DEBUG] [20271] [HSPC::MT::Core::AbstractAccount::load] TRACE [03]: . . -> HSPC::MT::Core::AbstractAccount->load (self=>HSPC::MT::Core::HSP, id=>1) => found
    [2012/06/29 11:39:43] [DEBUG] [20271] [HSPC::MT::Core::find_account] TRACE [02]: . -> HSPC::MT::Core->find_account (account_id=>1) => found
    [2012/06/29 11:39:43] [DEBUG] [20271] [HSPC::MT::GM::find_provider_config] TRACE [01]: -> HSPC::MT::GM->find_provider_config ()
    [2012/06/29 11:39:43] [DEBUG] [20271] [HSPC::Logger::sw_trace] TRACE [01]: +> HSPC::OM::HNSetup->office ()
    [2012/06/29 11:39:43] [DEBUG] [20271] [HSPC::Logger::sw_trace] TRACE [02]: . +> HSPC::OM::HNSetup->hwnode_add ()
    [2012/06/29 11:39:43] [DEBUG] [20271] [HSPC::Logger::sw_trace] TRACE [03]: . . +> HSPC::OM::HNSetup->reset_new_hn (type=>ps)
    [2012/06/29 11:39:43] [DEBUG] [20271] [HSPC::OM::HNSetup::reset_new_hn] TRACE [03]: . . -> HSPC::OM::HNSetup->reset_new_hn (type=>ps)
    [2012/06/29 11:39:43] [DEBUG] [20271] [HSPC::Logger::sw_trace] TRACE [03]: . . +> HSPC::OM::HNSetup->init_new_hn (type=>ps)
    [2012/06/29 11:39:43] [DEBUG] [20271] [HSPC::Logger::sw_trace] TRACE [04]: . . . +> HSPC::OM::HNSetup->restore_from_args ()
    [2012/06/29 11:39:43] [DEBUG] [20271] [HSPC::OM::HNSetup::restore_from_args] TRACE [04]: . . . -> HSPC::OM::HNSetup->restore_from_args ()
    [2012/06/29 11:39:43] [DEBUG] [20271] [HSPC::Logger::sw_trace] TRACE [04]: . . . +> HSPC::MT::pServer->create_unattended_psbm_gate (host => 1.2.3.4)
    [2012/06/29 11:39:43] [DEBUG] [20271] [HSPC::Logger::sw_trace] TRACE [05]: . . . . +> HSPC::MT::pServer::Gate->init (host => 1.2.3.4, user => root)
    [2012/06/29 11:39:43] [INFO] [20271] [HSPC::MT::pServer::Gate::init] HSPC::MT::pServer::Gate::init: Can't init transport
    [2012/06/29 11:39:43] [DEBUG] [20271] [HSPC::MT::pServer::Gate::init] TRACE [05]: . . . . -> HSPC::MT::pServer::Gate->init (host => 1.2.3.4, user => root)
    [2012/06/29 11:39:43] [INFO] [20271] [HSPC::MT::pServer::create_unattended_psbm_gate] create_unattended_psbm_gate():: Error during init pva: Can't init transport
    [2012/06/29 11:39:43] [DEBUG] [20271] [HSPC::MT::pServer::create_unattended_psbm_gate] TRACE [04]: . . . -> HSPC::MT::pServer->create_unattended_psbm_gate (host => 1.2.3.4)
    [2012/06/29 11:39:43] [DEBUG] [20271] [HSPC::Logger::sw_trace] TRACE [04]: . . . +> HSPC::OM::HNSetup->reset_new_hn (type=>ps)
    [2012/06/29 11:39:43] [DEBUG] [20271] [HSPC::OM::HNSetup::reset_new_hn] TRACE [04]: . . . -> HSPC::OM::HNSetup->reset_new_hn (type=>ps)
    [2012/06/29 11:39:43] [DEBUG] [20271] [HSPC::OM::HNSetup::init_new_hn] TRACE [03]: . . -> HSPC::OM::HNSetup->init_new_hn (type=>ps)
    [2012/06/29 11:39:43] [DEBUG] [20271] [HSPC::Logger::sw_trace] TRACE [03]: . . +> HSPC::OM::HNSetup->connect_form ()
    [2012/06/29 11:39:43] [DEBUG] [20271] [HSPC::OM::HNSetup::connect_form] TRACE [03]: . . -> HSPC::OM::HNSetup->connect_form ()
    [2012/06/29 11:39:43] [DEBUG] [20271] [HSPC::OM::HNSetup::hwnode_add] TRACE [02]: . -> HSPC::OM::HNSetup->hwnode_add ()
    [2012/06/29 11:39:43] [DEBUG] [20271] [HSPC::OM::HNSetup::eek:ffice] TRACE [01]: -> HSPC::OM::HNSetup->office ()
    [2012/06/29 11:39:43] [DEBUG] [20271] [HSPC::Logger::sw_trace] TRACE [01]: +> HSPC::MT::Core->find_account (account_id=>1)
    [2012/06/29 11:39:43] [DEBUG] [20271] [HSPC::Logger::sw_trace] TRACE [02]: . +> HSPC::MT::Core::AbstractAccount->load (self=>HSPC::MT::Core::HSP, id=>1)
    [2012/06/29 11:39:43] [DEBUG] [20271] [HSPC::MT::Core::AbstractAccount::load] TRACE [02]: . -> HSPC::MT::Core::AbstractAccount->load (self=>HSPC::MT::Core::HSP, id=>1) => found
    [2012/06/29 11:39:43] [DEBUG] [20271] [HSPC::MT::Core::find_account] TRACE [01]: -> HSPC::MT::Core->find_account (account_id=>1) => found
     
  6. vbatraev

    vbatraev Odin Team

    Messages:
    346
  7. Decisiveservers

    Decisiveservers Kilo Poster

    Messages:
    12
    Hi,

    Nothing appears in the /var/log/hspcd/error_log

    vzlicview on the PBMS produces:

    [root@ds-pmbs01 ~]# vzlicview
    Searching for installed licenses...
    VZSRV
    status="ACTIVE"
    version=4.0
    serial="xxxxx-xxxxx-xxxxx-xxxxx-xxxx" (Replaced key!)
    expiration="07/26/2012 00:59:59"
    graceperiod=54000 (54000)
    key_number="PSBM.10002078.0000"
    cpu_total=256 (1)
    ct_total=0 (0)
    max_vzmc_users="unlimited"
    max_vzcc_users=0
    platform="Linux"
    product="PSBM"
    vzpp_allowed=0
    backup_mgmt_allowed=0
    workflow_mgmt_allowed=0
    vzagent_allowed=1
    nr_vms="unlimited"
    architecture="x86"
    architecture="x86_64"

    However running "rpm -qi pva-release" returns:
    package pva-release is not installed

    I am being stupid and missed something in the install?
    This is PBMS 5.0.0 (1159) (2.6.32-042stab049.7)

    Kind Regards,
    Rob
     
  8. vbatraev

    vbatraev Odin Team

    Messages:
    346
  9. Decisiveservers

    Decisiveservers Kilo Poster

    Messages:
    12
    I will try installing that now.

    Is this an additional option I need to select when install PBMS5 ?

    Thanks

    Kind Regards,
    Rob
     
  10. Decisiveservers

    Decisiveservers Kilo Poster

    Messages:
    12
    Hi,

    Thanks for your help, that has resolved the issue. Did I miss something during the install of PBMS?

    Thanks

    Kind Regards,
    Rob
     

Share This Page