Parallels Business Automation Installation Failed

Discussion in 'Installation and "How-To" Questions' started by wisw, Mar 22, 2010.

  1. wisw

    wisw Kilo Poster

    Messages:
    18
    OS : CentOS 5.4

    tar -xvf pba-3.3.8-39.tar
    cd pba-3.3.8-39
    ./install.sh -C

    No products match current OS installation

    My installation process is wrong or not? I should be how to correctly install it?

    My log file is as follows:

    http://oops.sg1008.myweb.hinet.net/session.log
     
  2. LawrenceP

    LawrenceP Bit Poster

    Messages:
    1
    2588 Mar 23 2010 09:55:28 [:4883] INFO: Running 'RPM dependencies of Perl packages' 'system check' script...
    2589 Mar 23 2010 09:55:28 [:4883] DEBUG: Forked a child with pid 4887
    2590 Mar 23 2010 09:55:28 [:4887] DEBUG: Executing a command. Command line follows
    2591 Mar 23 2010 09:55:28 [:4887] DEBUG: /tmp/installer_script_uDWG7F
    2592 Mar 23 2010 09:55:28 [:4883] INFO: Script executed successfully.
    2593 Mar 23 2010 09:55:28 [:4883] INFO: Running 'Server hostname' 'system check' script...
    2594 Mar 23 2010 09:55:28 [:4889] DEBUG: Executing a command. Command line follows
    2595 Mar 23 2010 09:55:28 [:4889] DEBUG: /tmp/installer_script_cTineO
    2596 Mar 23 2010 09:55:28 [:4883] DEBUG: Forked a child with pid 4889
    2597 Mar 23 2010 09:55:28 [:4883] INFO: Script executed successfully.
    2598 Mar 23 2010 09:55:28 [:4883] INFO: Running 'Operating System' 'system check' script...
    2599 Mar 23 2010 09:55:28 [:4892] DEBUG: Executing a command. Command line follows
    2600 Mar 23 2010 09:55:28 [:4892] DEBUG: /tmp/installer_script_yV8bqW
    2601 Mar 23 2010 09:55:28 [:4883] DEBUG: Forked a child with pid 4892
    2602 Mar 23 2010 09:55:28 [:4883] WARNING: Script '/tmp/installer_script_yV8bqW' returned 1 as exit status.
    2603 Mar 23 2010 09:55:28 [:4883] DEBUG: Output follows:
    2604 Mar 23 2010 09:55:28 [:4883] DEBUG: This Operating System is not supported for Parallels Business Automation - Standard clean installations,
    2605 it is only possilble to install Parallels Business Automation - Standard upgrades over previous versions of this product.
    2606 Mar 23 2010 09:56:12 [:4883] WARNING: Internal error #4103: [Autoinstaller] User cancelled installation.
    2607 Mar 23 2010 09:56:12 [:4883] INFO: Exiting with code 0

    i use my centos4.8
     
  3. VitalyF

    VitalyF Kilo Poster

    Messages:
    41
    wisw,

    In the end of log you provided I see the following error:
    ================
    Mar 22 2010 21:27:15 [:2330] DEBUG: Package hspc-release-3.3.8-39.swsoft has 2 unresolved dependencies from packages list checked earlier (see log above).
    ================

    If I check the log above this error I see the exact unresolved dependencies:
    ================
    Mar 22 2010 21:27:13 [:2330] INFO: Package mod_ssl-2.2.3-5 has following unresolved dependencies:
    httpd = 0:2.2.3-5
    ================

    and

    ================
    Mar 22 2010 21:27:13 [:2330] INFO: Package httpd-2.2.3-5 has following unresolved dependencies:
    libapr-1.so.0 >=
    libaprutil-1.so.0 >=
    ================

    Do you have packages 'apr' and 'apr-util' installed on the server?

    The problem is that httpd-2.2.3-5 is included into PBA-S 3.3.8-39 distrib, it requires 'apr' and 'apr-util' packages of version 1.0 or above while 'apr' and 'apr-util' 0.9.x are included into PBA-S distrib.

    I suggest installing 'apr' and 'apr-util' packages from CentOS repository and try again to install PBA-S after that.
     
  4. VitalyF

    VitalyF Kilo Poster

    Messages:
    41
    LawrenceP,

    PBA-S 3.3.8-39 Release Notes says:
    ================
    2) The following Operation Systems are supported:
    * Redhat Enterprise Linux AS4 (for upgrades only)
    * CentOS 4 (for upgrades only)
    * SUSE Enterprise Linux 9 (see Known Issues section, you need to
    check hostname before installation)
    * Redhat Enterprise Linux AS5
    * CentOS 5
    ================

    Clean installation is not supported on CentOS 48, only CentOS 5.x are supported.

    CentOS 4.x is good only for upgrades from previous versions of PBA-S.
     
  5. MaciekO

    MaciekO Bit Poster

    Messages:
    3
  6. vbatraev

    vbatraev Odin Team

    Messages:
    346
    Check the file '/tmp/product_installer.log' for unresolved dependencies. It may have the following entries:
    Package XXX has following unresolved dependencies:
    YYY >= VERSION

    Install missed rpm packages and run the installer.
    Pobably mod_ssl package is not installed.
     
  7. MaciekO

    MaciekO Bit Poster

    Messages:
    3
    Selinux must be disabled and everything works. Thanks
     

Share This Page