Mailman installation on PSA 2.0.

Discussion in 'PSA 2.0 'How do I' Questions' started by jacob, Oct 18, 2001.

  1. jacob

    jacob Guest

    Hi,

    I am new to Plesk so please mercy...

    I am trying to install Mailman, and I am following the instruction that I found here; URL: http://forum.plesk.com/showthread.php?s=&threadid=124&highlight=Mailman

    But I am not able to get it to work... Does anybody knows where I will be able to find more info on this.

    I am running RedHat 7.1 PSA 2.0.

    Any info that could help me will be greatly appreciated.
     
  2. tobias

    tobias Guest

    Have you figured this out? If so, I'd be grateful for your tips as I am just embarking on this myself.

    Cheers,

    Tobias
     
  3. roadrunner

    roadrunner Guest

    Sure, I can help. What problems are you having?
     
  4. tobias

    tobias Guest

    installing mailman

    Hi,

    Thanks for offering to help. I much appreciate it! :)

    I've installed Mailman. There seems to be two areas to sort out that I will need some help with:

    1) getting the web interface operational
    2) getting the email interface operational

    On 1, I've managed to follow instructions elsewhere to create a vhost.conf file in the vhosts/kabissa.org domain (where I want the mailman web interface to be accessible) and ran my_apci_rst - this doesn't seem to have any noticable effect.

    The vost.conf file contains the following lines:

    ScriptAlias /mailman/ /home/mailman/cgi-bin/
    Exec /mailman/* /home/mailman/cgi-bin/*

    Alias /lists/archives/public /home/mailman/archives/public
    Alias /lists/archives/private /home/mailman/archives/private

    Am I doing something wrong to get this vhost.conf file recognized? I'm reluctant to make any changes to httpd.conf because I have been told that it is overwritten regularly by PLESK.

    On 2, I've set up the domain lists.kabissa.org and edited /var/qmail/control/virtualdomains to include the line:

    lists.kabissa.org:mailman

    I also created the .qmail-default file in /home/mailman containing:

    |preline /usr/bin/python /home/mailman/qmail-to-mailman.py

    I created a test list and wrote to test-list@lists.kabissa.org - it was clearly executed by the wrapper as I can see my test message in the qrunner directory and a line in the mailman smtp log, but I am unable to do anything with it because I can't access the web interface to approve/reject it.

    I guess that's where I'm at right now. I don't yet know how I am going to create the various aliases so the lists work as they are supposed to. I've got 50 domains on my server and quite a few of them had mailman lists set up.

    Many thanks,

    Tobias
     
  5. superfly

    superfly Guest

    regarding vhost.conf

    the way to see if this is being recognized is to go into the httpd.include file and look for the entry specific to your virtual host. You should see an Include line as the last line of your virtual host.
     
  6. tobias

    tobias Guest

    It's not being recognized - what am I doing wrong?
     
  7. tobias

    tobias Guest

    Plesk isn't automatically adding the line

    Include /var/www/vhosts/kabissa.org/vhost.conf

    to httpd.include but I put it in and it works. I fear it will be overwritten next time Plesk restarts, so would appreciate any help from someone on making sure the line is added automatically by Plesk.

    I am unable to get the programs in /home/mailman/cgi-bin to run. The following line, taken from the Mailman website, makes Apache choke:

    Exec /mailman/* /home/mailman/cgi-bin/*

    When running it with the line 'ScriptAlias' instead of Exec - as I had it set in my old server - httpd starts up alright but I get an error message in my error_log:

    Premature end of script headers: /home/mailman/cgi-bin/listinfo

    This seems to indicate that it's trying to run these in the wrong way, ie. as cgi scripts and not compiled programs.

    Any suggestions, anyone?

    Cheers,

    Tobias
     
  8. superfly

    superfly Guest

    hmm...

    How did you end up with your vhosts in /var/www/? I thought they were put in /home/httpd/ in the PSA RPM version.

    Anyway, if you moved the vhosts, maybe there is an issue with how PSA reacts to the vhost.conf file being added. Did you make sure to run the my_apci_rst utility after creating the vhost.conf file the first time? If you don't do that it will not update Apache.

    In any case, I'm not sure I'll be much help... I use the PSA Standard installs... not the RPM. I did play with it, and test it a little, but I'm not an RPM guy.
     
  9. tobias

    tobias Guest

    Hi,

    I didn't move the vhosts - /home seems to be a link to /var/www

    I did run my_apci_rst

    Still it isn't updating the httpd.include file to include my new vhost.conf file.

    Can you just tell me what's in your vhost.conf file? What I have doesn't seem to be right but otherwise I appear to be mostly on track.

    Many thanks!

    Tobias
     
  10. Saxy

    Saxy Guest

    First of all,

    Plesk doesnt automatically add the Include line to your custom vhost.con file. You'll need to do that if you really want to.

    Second, Plesk doesnt automatically overwrite httpd.conf except on a new installation, to reconfigure the email address and host.

    Third, Plesk DOES overwrite the httpd.include whenever a change is made, so I wouldnt put any manual changes in there if possible.

    What I did for my lists was to put this line at the bottom of httpd.conf, just after the Include to httpd.include:

    Include conf/httpd.list-include

    and I made a httpd.list-include to contain all my list data.

    This is where I put all my lists.domain.com virtualhost data, using the directives: ServerName, DocumentRoot, ServerAlias, UseCanonicalName, ServerAdmin, ScriptAlias and Alias, for each domain that needs lists.

    I couldnt get a lists.* to work in all cases... this would be much better, but sometimes apache would return 404's.

    Anyway, once you restart (and you have all the locations correct) apache, you should now be able to see http://lists.yourdomain.com/mailman/listinfo and http://lists.yourdomain.com/mailman/admin working.

    This 'should' be the easy bit, as all you are doing is letting apache know of some file locations. you dont HAVE to make it a sub-domain anyway, as far as I can see.


    More to come, if requested

    Dan
     
  11. tobias

    tobias Guest

    Hi Saxy,

    Setting up a httpd.list-include file is a great idea. Much easier to deal with than a /var/www/<domain>/vhost.conf file for each domain.

    Before I start digging around with that, can you tell me what the directives are that are needed (maybe a sample of yours??) to make it work? I am unable to get the mailman cgi working at all - it gives an apache 500 error message - and since I think I did the other configuration correctly I suspect the problem lies with apache setup.

    Failing that, how best to troubleshoot user id, group id, etc?

    Cheers,

    Tobias
     
  12. Saxy

    Saxy Guest

    I'm putting my HOWTO up now..... but heres what is in my httpd.list-include:

    <VirtualHost 1.1.1.1:80>
    DocumentRoot /usr/local/mailman/www/
    ServerName lists.mydomain.com
    ServerAlias lists.mydomain.com
    UseCanonicalName Off
    ServerAdmin myemail@doma.com
    ScriptAlias /mailman/ /usr/local/mailman/cgi-bin/
    Alias /pipermail/ /usr/local/mailman/archives/public/
    </VirtualHost>

    Dan
     
  13. Saxy

    Saxy Guest

  14. roadrunner

    roadrunner Guest

    OK, hold up there guys, everyone is jumping ahead here.

    Tobias, it sounds like you have the exact same configuration that I do. You've got 2 problems to solve here, one is web access, the other is getting the list to work.

    Lets start with web access, I've seen alot of incorrect things in this thread so far. First off httpd.conf is NOT overwritten by plesk. PSA generates an httpd.include file, you will see it referenced in the bottem of httpd.conf.

    Put your changes in httpd.conf. They will be absolutely, 100% fine in there. And will never be overwritten. You really only need the ScriptAlias directive I specifified in the FAQ. THe other stuff is all for list archives.

    OK, next up, sending mail, if you havent whitelisted localhost, sending mail isnt going to work. Thats what got me when I did it the first time.

    Try these first, and let me know how it works out.
     
  15. tobias

    tobias Guest

    Hi Roadrunner,

    Here's what I've now placed in my httpd.conf file, right after the /cgi-bin/ scriptalias:

    ScriptAlias /mailman/ "/usr/local/mailman/cgi-bin/"
    Alias /lists/archives/public "/usr/local/mailman/archives/public"
    Alias /lists/archives/private "/usr/local/mailman/archives/private"

    The aliases are working. The ScriptAlias is not working. Here's what I get in my error_log when I open http://www.kabissa.org/mailman/listinfo

    Premature end of script headers: /usr/local/mailman/cgi-bin/listinfo

    Is there another log where I can review the permissions? I get the feeling either it's a permissions question or it's not running the program in the right way. Any ideas?

    Cheers,

    Tobias
     
  16. dirty@

    dirty@ Guest

    When you see "Premature end" -- look into /var/log/httpd/suexec_log or /use/local/psa/apache/logs/suexec_log -- in 99% you will find error description there.
     
  17. tobias

    tobias Guest

    Hi,

    I was able to (finally) get the web interface for mailman running thanks to Roadrunner's advice, however I'm still not close to being finished. Please bear with me.

    Can you please tell me where to put the lines in httpd.conf so that they apply to all domains on the server?

    Here's what I want added:

    # Mailman
    ScriptAlias /mailman/ /usr/local/mailman/cgi-bin/
    Alias /lists/archives/public /usr/local/mailman/archives/public
    Alias /lists/archives/private /usr/local/mailman/archives/private

    If I place it in http.conf near the cgi-bin scriptalias, it works but only for the IP address of my server. I'd like it to work for all addresses on my server.

    Best,

    Tobias
     
  18. tobias

    tobias Guest

    dirty: very interesting.. that was the info I was looking for, I think. Here's the error:

    [2001-10-25 21:50:15]: info: (target/actual) uid: (kabissa/kabissa) gid: (psacln/psacln) cmd: admin
    [2001-10-25 21:50:15]: error: command not in docroot (/usr/local/mailman/cgi-bin/admin)

    Not sure I understand it. Any ideas?

    Cheers,

    Tobias
     
  19. dirty@

    dirty@ Guest

  20. tobias

    tobias Guest

    That sounds right, but how do I fix it?

    I've since determined that my current setup works on a number of domains but not on all of them.

    I'm also not able to send messages through the list - despite having gone over the instructions over and over.. I think it's all correct. How do I troubleshoot the .qmail aliases and python's wrapper etc?

    Cheers,

    Tobias
     

Share This Page