Invalid packet when trying to start a backup

Discussion in 'Performance Questions' started by muntos, Jul 6, 2012.

  1. muntos

    muntos Bit Poster

    Messages:
    3
    Hi,

    we have a project in our company where we need to move from the C# PVA wrapper to a Java wrapper.
    I was successfully ported the connect, login, get_info requests but I have problems with backup_env
    The message received from the agent is :

    <?xml version="1.0" encoding="UTF-8"?><packet version="" priority="" id="" type="" time="">
    <origin>backupm</origin>
    <target>vzclient548-f3716904-c84d-db37-66e3-0df888c0feed</target>
    <dst>
    <director>gend</director>
    </dst>
    <data>
    <backupm>
    <error>
    <code>400</code>
    <message>Invalid packet: Invalid options were specified.</message>
    </error>
    </backupm>
    </data>
    <src>
    <director>gend</director>
    </src>
    </packet>

    The packet I send is:

    <?xml version="1.0" encoding="UTF-8" standalone="yes"?>
    <packet version="4.0.0" id="d386b840-1922-4cf8-8355-b8a2c47fabd8" xmlns:ns2="http://www.swsoft.com/webservices/vzl/4.0.0/types" xmlns:ns3="http://www.swsoft.com/webservices/vzl/4.0.0/backupm">
    <target>backupm</target>
    <data xsi:type="dataCreateBackup" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <backupm>
    <backup_env>
    <env_list>
    <ns2:eid>39b2bae6-efba-438d-9a7f-28bfad2e4a28</ns2:eid>
    </env_list>
    <backup_server/>
    <backup_options>
    <ns3:location>
    <ns3:type>1</ns3:type>
    <ns3:path>XFxudGhuYmFja3VwMS5TY2hsdW5kLmRlXEJhY2t1cHNcUFZDNFxudGhuNjA1MjI=</ns3:path>
    <ns3:login>
    <ns3:name>aG9zdGluZ3hwXHZ6YmFja3Vw</ns3:name>
    </ns3:login>
    <ns3:password>oFG2Bzef77</ns3:password>
    </ns3:location>
    <ns3:type>0</ns3:type>
    <ns3:compression>3</ns3:compression>
    </backup_options>
    </backup_env>
    </backupm>
    </data>
    </packet>

    This is a replica of the C# wrapper, where the original packet is (and is working with it):



    From my point of view they are the same (except the namespaces, but until now I wasn't used them at all, now I'm trying everything).
    Also looking on PVA documentation I can't find all the options found in the C# wrapper packet but once again , it works!

    Please help, because I don't have any ideas left at this moment.

    Regards,
    Alex
     
  2. muntos

    muntos Bit Poster

    Messages:
    3
    The C# wrapper packet :

    <?xml version="1.0" ?>
    <packet xmlns:ns2="http://www.swsoft.com/webservices/vzl/4.0.0/system" xmlns:ns4="http://www.swsoft.com/webservices/vzl/4.0.0/backupm" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:ns1="http://www.swsoft.com/webservices/vzl/4.0.0/protocol" xmlns:ns3="http://www.swsoft.com/webservices/vzl/4.0.0/types" version="4.0.0" id="d5783371-e4bc-4136-97bd-f16ad1f0deb8">
    <target>backupm</target>
    <data xsi:type="dataCreateBackup">
    <backupm>
    <backup_env>
    <env_list>
    <ns3:eid>39b2bae6-efba-438d-9a7f-28bfad2e4a28</ns3:eid>
    </env_list>
    <backup_server xsi:type="ns3:connection_infoType" />
    <backup_options xsi:type="ns4:backup_optionsType">
    <ns4:location>
    <ns4:type>1</ns4:type>
    <ns4:path>XFxudGhuYmFja3VwMS5TY2hsdW5kLmRlXEJhY2t1cHNcUFZDNFxudGhuNjA1MjI=</ns4:path>
    <ns4:login>
    <ns4:name>aG9zdGluZ3hwXHZ6YmFja3Vw</ns4:name>
    </ns4:login>
    <ns4:password>oFG2Bzef77</ns4:password>
    </ns4:location>
    <ns4:type>0</ns4:type>
    <ns4:compression>3</ns4:compression>
    </backup_options>
    </backup_env>
    </backupm>
    </data>
    </packet>
     
  3. muntos

    muntos Bit Poster

    Messages:
    3
    Nevermind, found the answer, it was in xsi:type ... :(
     

Share This Page