Installing with autoinstaller

Discussion in 'Plesk 7.1 Reloaded Installation and 'How Do I' Questions' started by spoonman, Sep 4, 2004.

  1. spoonman

    spoonman Kilo Poster

    Messages:
    21
    I tried installing plesk 7 reloaded on a Suse 9.0 system. When I tried to run the autoinstaller, i got this message

    "./psa_installer_v2.0.0_build71040818.04_os_SuSE_9.0_i686: error while loading shared libraries: libdb.so.2: cannot open shared object file: No such file or directory"

    can someone please help???
     
  2. spoonman

    spoonman Kilo Poster

    Messages:
    21
    bump...anyone?
     
  3. Michael@

    Michael@ Mega Poster

    Messages:
    113
    Hi,
    i have exact the same Problem on Suse 9.1
     
  4. spoonman

    spoonman Kilo Poster

    Messages:
    21
    I talked to support about it and concluded that the latest version of plesk is only supported by suse 9.0 and not 9.1. I never thought I would have an incompatible system because it was too up to date and frankly I think it's ridiculous. He offered me a couple sketchy ways that it might work to install it, but I'd really prefer the autoinstaller. I can't wait til they come out with a new one.
     
  5. E=mc²

    E=mc² Guest

    It ist very easy install with e.g. yast db1. It will work fine.
     
  6. spoonman

    spoonman Kilo Poster

    Messages:
    21
    can you elaborate? how exactly is this done?
     
  7. E=mc²

    E=mc² Guest

    Sorry, but I think you can't install plesk with the autoinstaller at suse 9.1. But the problem with the libdb.so.2 is because db1 ist not installed. Sorry for my bad english. I think you must install it without the autoinstaller. :(
     
  8. spoonman

    spoonman Kilo Poster

    Messages:
    21
    man...its such BS. its not like Suse 9.1 is new. We have had it for months now
     
  9. E=mc²

    E=mc² Guest

    It would be very nice when the autoinstaller works but now it doesn't work. :mad:
     
  10. matt.simpson

    matt.simpson Guru

    Messages:
    932
    I'm pretty ticked off right now that I have SuSE Enterprise 9.0 and I can't install Plesk with it.

    My original thinking was "Great, I'm getting away from crappy RedHat, and moving to a great distro that I actually like, plus, I can use Plesk with it." Well think again.

    ****, this sucks. I'm really upset about this. They should state that "SuSE Personal / Professional 9.0" not "SuSE 9.0".

    Regards,
    Matt Simpson
     
  11. E=mc²

    E=mc² Guest

    What is your problem? Tell us a little bit more.
     
  12. matt.simpson

    matt.simpson Guru

    Messages:
    932
    E=mc²... My problem is that SuSE Enterprise 9.0 isn't supported by SW-Soft. There are roughly 8 packages that are "required" by Plesk that aren't in the SuSE Enterprise 9.0 distrobution. It also won't work without installing old arse berkley db (which isn't recommended by Novell).

    The main thing that ticks me off is that they advertise Plesk works with "SuSE 9.0" when in fact, it only works with SuSE Personal and Professional 9.0, not Enterprise 9.0.

    Yes, there may be some way / hack to get Plesk to work with Enterprise 9.0, but the fact that it's not supported makes it completely useless.

    Also the fact that I hate RedHat, but I'm pretty much forced to go back to it.

    ~Matt
     
  13. E=mc²

    E=mc² Guest

    I suse Suse 9.1 it isn't supported too. But it works fine. What packages you are missing?

    Björn
     
  14. matt.simpson

    matt.simpson Guru

    Messages:
    932
    The following packages aren't included with SuSE Enterprise 9.0

    perl-MIME-Lite-3.01-53.i586.rpm
    perl-MLDBM-2.01-143.i586.rpm
    perl-MLDBM-Sync-0.30-144.i586.rpm
    perl-Msql-Mysql-modules-1.2219-327.i586.rpm
    perl-Parse-Yapp-1.05-293.i586.rpm
    perl-XML-XQL-0.68-51.i586.rpm
    perl-libxml-perl-0.07-383.i586.rpm

    There is one more, but I failed to record it.

    You also need to install a package that isn't listed called db1 (to provide libdb.so.2)

    Regards,
    Matt Simpson
     
  15. E=mc²

    E=mc² Guest

    Did you seach for this files in a ftp earch engine? Sorry, but I think you could find this packages there.

    Björn
     
  16. matt.simpson

    matt.simpson Guru

    Messages:
    932
    Hey!
    Yes, they probably _could_ be there, but my point is they are not included with either SuSE Enterprise nor with Plesk. I wouldn't install Plesk on an unsupported platform, it's silly in my opinion to do for a production server. Your basically giving SW-Soft a free ticket to say "Sorry, can't help, your platform is unsupported." if something goes seriously wrong. Even if it is their fault.

    Either way, aparently Plesk 7.5 will be out on December 1st so we'll see what that brings. Unfortunately, it'll be too late for me though as I'm putting this new server in the data centre on November 26th...

    Regards,
    Matt Simpson
     
  17. spoonman

    spoonman Kilo Poster

    Messages:
    21
    shame shame. I had a problem installing it on suse 9.1. Its pretty outrageous if you ask me. I just want to use the damn autoinstaller but it doesnt work.
     
  18. E=mc²

    E=mc² Guest

    The autoinstaller dosent work. But it is very easy to install all packets with yast.
     
  19. dstanley

    dstanley Mega Poster

    Messages:
    101
    Sorry to drag up threads. Just got a brand spanking new server with Suse 9.1

    same problems as above.

    Can you explain how you did it with yast? *newb here*
     

Share This Page