How to bind new virtual interface to Bridge Interface?

Discussion in 'Installation, Update and Configuration' started by Machiasiaweb, Dec 15, 2016.

  1. Machiasiaweb

    Machiasiaweb Mega Poster

    Messages:
    182
    Hello,

    I am trying to config Virtual Interface to Server Bridge Interface under Virtual Automation.

    After created New Virtual interface but it there are no choice to select bridge interface by "Connect via" option.

    Could anyone advise how to do it?

    Some output from command line for reference.

    ------
    # brctl show
    bridge name bridge id STP enabled interfaces
    br0 8000.d48564c81048 no bond0
    br20 8000.d48564c81048 no bond0.20
    host-routed 8000.000000000000 no
    virbr0 8000.525400cf4cbe no virbr0-nic

    # prlsrvctl net list
    Network ID Type Bound To Bridge Slave interfaces
    Host-Only host-only virbr0
    ---------

    Thanks!
     
  2. Pavel

    Pavel A.I. Auto-Responder Staff Member

    Messages:
    478
    In "Connect to" just select the adapter your bridge is connected to
     
  3. Machiasiaweb

    Machiasiaweb Mega Poster

    Messages:
    182
    Unfortunately there are no bridge interface available can be choose



    Thanks!
     
    Last edited: Dec 21, 2016
  4. Pavel

    Pavel A.I. Auto-Responder Staff Member

    Messages:
    478
    That is the point. Bridges are not listed there and should not be listed. Please choose the adapter you want to attach your virtual network to, not the bridge. E.g. bond0 or bond0.20 which I can see from the previous snippet.
     
  5. Machiasiaweb

    Machiasiaweb Mega Poster

    Messages:
    182
    It got error below when binding to bond0.20
    ---
    Failed to update the virtual network information.
    Can not set device: Failed to parse exec output: Failed to parse exec output: open '/etc/vz/conf//0.conf' : No such file or directory
    ---

    With ref 5.4.1.3
    http://docs.virtuozzo.com/virtuozzo...-machines-and-containers-in-bridged-mode.html

    even I manual add from CLI which also fail.

    # prlsrvctl net add bridge20 -t bridged --ifname bond0.20
    Failed to add Virtual Network bridge20: Could not find the network adapter. The MAC address and VLAN tag you specified do not match any of the host computer's network adapters.



    Thanks!
     
    Last edited: Dec 21, 2016

Share This Page