How do i enable Nix Load with Plesk

Discussion in 'PSA 2.0 'How do I' Questions' started by Michael@, Dec 11, 2001.

  1. Michael@

    Michael@ Mega Poster

    Messages:
    113
    Hi,,
    i hosting Vbulletin Forums and they have an option to read out the Server Load and close if the load is too high, but on plesk i get errors, what can i do ?

    This is what VBulletin says
    *NIX Load Limit
    vBulletin can read the overall load of the server on certain *nix setups (including Linux). This allows vBulletin to determine the load on the server and processor, and to turn away further users if the load becomes too high. If you do not want to use this option, set it to 0. A typical level would be 5.00 for a reasonable warning level.
     
  2. PaulC

    PaulC Guru

    Messages:
    1,479
    As long as you are running Linux, that should be all you need to get it to work.

    Cheers,
    Paul
     
  3. Michael@

    Michael@ Mega Poster

    Messages:
    113
    I run Linux :)
    but it don´t work plesk do not let me read out the server load
     
  4. PaulC

    PaulC Guru

    Messages:
    1,479
    In that case, I guess you will need to add the correct directory to the safe mode path, allowing PHP to read the info.

    I'm not sure what the path is on linux?? Something like /proc I guess.

    Cheers,
    Paul
     
  5. Michael@

    Michael@ Mega Poster

    Messages:
    113
    anybody has an idea hów to do this exactly ?

    this is the error what i get if i enable Nix load
    Warning: open_basedir restriction in effect. File is in wrong directory in /usr/local/psa/home/vhosts/pornoboard.to/httpdocs/forum/global.php on line 157

    Warning: fopen("/proc/loadavg","r") - Operation not permitted in /usr/local/psa/home/vhosts/pornoboard.to/httpdocs/forum/global.php on line 157

    Warning: Supplied argument is not a valid File-Handle resource in /usr/local/psa/home/vhosts/pornoboard.to/httpdocs/forum/global.php on line 159
     
  6. PaulC

    PaulC Guru

    Messages:
    1,479
    Create a file

    /usr/local/psa/home/vhosts/pornoboard.to/conf/vhost.conf

    In it, put this

    <Directory /usr/local/psa/home/vhosts/pornoboard.to/httpdocs>
    php_admin_value open_basedir ".:/usr/local/psa/home/vhosts/pornoboard.to/httpdocs:/proc"
    </Directory>

    Then run

    /usr/local/psa/admin/bin/my_apci_rst

    That should do it,

    Paul
     
  7. PaulC

    PaulC Guru

    Messages:
    1,479
    In the above.. the contents of vhost.conf should be 3 lines, not 4.

    The second and third line above should be placed on one.

    Cheers,
    Paul
     
  8. Michael@

    Michael@ Mega Poster

    Messages:
    113
    Hi
    i did this i made
    vi /usr/local/psa/home/vhosts/pornoboard.to/conf/vhost.conf
    than insert

    <Directory /usr/local/psa/home/vhosts/pornoboard.to/httpdocs>php_admin_value open_basedir ".:/usr/local/psa/home/vhosts/pornoboard.to/httpdocs:/proc</Directory>

    safed the file and restart apache but than the apache did not restart, no site is working, after removing the file resatart apache runs
     
  9. serve-you.net

    serve-you.net Guru

    Messages:
    1,896
    What does your error log say when you try to restart apache with that vhost.conf?

    -Dan
     
  10. Michael@

    Michael@ Mega Poster

    Messages:
    113
    than i get this error
    [Mon Dec 17 22:54:02 2001] [notice] caught SIGTERM, shutting down
    nothing more and apache do not start
     
  11. PaulC

    PaulC Guru

    Messages:
    1,479
    Whats the output of

    /usr/local/psa/apache/bin/apachectl configtest

    Cheers,
    Paul
     
  12. Michael@

    Michael@ Mega Poster

    Messages:
    113
    than i get
    [Tue Dec 18 19:28:58 2001] [warn] NameVirtualHost 64.239.61.17:443 has no VirtualHosts
    Syntax OK
     
  13. dirty@

    dirty@ Guest

    both of you missed " after :/proc :)

    and be sure that you added 3 lines

    <Directory...>
    php_admin_value open_basedir ....
    </Directory>
     
  14. PaulC

    PaulC Guru

    Messages:
    1,479
    Oooops :eek:

    Thanks Dirty - I didn't realise I had done that.

    Cheers,
    Paul
     
  15. Michael@

    Michael@ Mega Poster

    Messages:
    113
    Hi,
    sorry i tried this still the same error, i get mad with this, this is what i did no.
    create the file with
    <Directory /usr/local/psa/home/vhosts/pornoboard.to/httpdocs>
    php_admin_value open_basedir ".:/usr/local/psa/home/vhosts/pornoboard.to/httpdocs:/proc"
    </Directory>

    still the same error
     

Share This Page