Hot Migration problem

Discussion in 'General Questions' started by OdinFan, Apr 4, 2017.

  1. OdinFan

    OdinFan Bit Poster

    Messages:
    3
    Hi,

    today I tried to migrate a container between 2 virtuozzo hypervisors. Before I did this migration I moved other containers and there all worked well. But on this one container I got the following error:

    Operation with the Container "container_name" is finished with errors: Can not migrate: exec vzmsrc failed [13312] : locking (containerID) Connection to destination node (IP) is successfully established Moving the CT#(containerID) -> CT#(containerID), [], [] ... Checking bindmounts Check cluster ID Checking keep dir for private area copy Checking license restrictions Check of requires kernel modules Checking CPT image version for online migration Checking capabilities for online migration Checking technologies Checking templates for CT copy CT private /vz/private/(containerID) /usr/libexec/vzvmiter exited with code 5 can not prepare vm for CT#(containerID) : /usr/libexec/vzvmiter exited with code 5 write() : Broken pipe vzsock_send() return 5 /usr/sbin/vzctl exited with code 32 /usr/sbin/vzctl exited with code 17 can not undump CT#(containerID) : /usr/sbin/vzctl exited with code 17 This CT can't be migrated online at the moment. Try offline migration. Dumpfile /vz/private/(containerID)/dump/dumpfile.WVDFRb.saved saved Can't move CT#(containerID) -> CT#(containerID), [], [] : /usr/sbin/vzctl exited with code 17 Checking IP addresses on destination node Checking RATE parameters in config Checking ploop format 2 Open /vz/private/(containerID)/root.hdd/root.hds dev=/dev/ploop33181 mnt=/vz/root/(containerID) size=536870912000 fmt=ploop1 blksie=1048576 Stage 1 root.hdd/root.hds Tracked iterations=2 transfered=1090519040 Stage 1 done write thread completed Iterative migration is not available Suspending CT#(containerID) ... done Dumping CT#(containerID) ... done Syncing dump file... done sync page cache and flush journal /vz/root/(containerID) Copy dirty blocks root.hdd/root.hds Stage 2 root.hdd/root.hds Stage 2 done write thread completed Umounting CT#(containerID) ... Resuming CT#(containerID) ... done .


    Any idea what could be the reason for it? Both hypervisors do have the same virtuozzo version (latest) and the new kernel.

    Best regards,

    Dennis
     
  2. OdinFan

    OdinFan Bit Poster

    Messages:
    3
    oh sorry, wrong forum. Its a Ubuntu container no Windows, maybe you can move it.

    thanks a lot
     
  3. Pavel

    Pavel A.I. Auto-Responder Staff Member

    Messages:
    475
    Hello,

    Unfortunately this log alone is not enough to tell what's wrong.
    Can you please clarify what are virtuozzo versions in use? on both source and destination

    Also, if possible, please collect verbose logs for the migration. You'll need to execute migration from command line for that.
    from source server run:
    # vzmigrate %destination_ip% %ctid% --online -vvvvvv
    and post output from the screen here, or to some pastebin service and provide a link
     

Share This Page