Greylisting fails when from-String empty

Discussion in 'Plesk 9.x for Linux Suggestions and Feedback' started by Flachzange, Jul 13, 2010.

  1. Flachzange

    Flachzange Kilo Poster

    Messages:
    70
    I have the following problem with enabled greylisting and Plesk 9.5.2. Spammers massively use this issue to get their mails delivered. The problem occurs when the "from" string is empty. The greylisting filter assumes that this is a bounce message and skips it without performing the actual greylisting.

    I hope that the Parallels development team can provide a hotfix for this issue.

    Thanks and best regards,
    Christoph

     
  2. IgorG

    IgorG Guru

    Messages:
    19,081
    It is not GL related issue. If it is necessary to lock such emails - it should be done by MTA. For example, Postfix has following parameter:

    smtpd_sender_restrictions= reject_non_fqdn_sender

    which is disabled by default. It is restrict empty From: field but pass 'From: <>' fields. It is correct behaviour because according to RFC 2822 such emails are used for notification messages.
    Qmail uses more ancient RFC 822. There is defined that the From: field can be empty. And similarly for 'From: <>' fields.
     
  3. Flachzange

    Flachzange Kilo Poster

    Messages:
    70
    Hi Igor,

    thanks for your answer. I am using qmail. Is it possible to set this option also for qmail?

    Regards,
    Christoph
     
  4. IgorG

    IgorG Guru

    Messages:
    19,081
  5. Flachzange

    Flachzange Kilo Poster

    Messages:
    70
    hmm. I had issues with previous postfix installs on Plesk, so currently I won't give it a try in my productive system. But thanks anyway.
     
  6. Flachzange

    Flachzange Kilo Poster

    Messages:
    70
    This thread is quite old but I would like to provide a final answer to the described problem: Even with Postfix it is NOT possible to block this type of spam message. As Igor said, the behaviour is specified in RFC822 and mandatory for so called e-mail notifications. Even with

    smtpd_sender_restrictions= reject_non_fqdn_sender

    postfix will not reject such e-mails.
     

Share This Page