Error while installing Automation during the "Getting SELinux" step

Discussion in 'Plesk Automation Suggestions and Feedback' started by AaronMcH, Jul 5, 2013.

  1. AaronMcH

    AaronMcH Mega Poster

    Messages:
    130
    Hi, thanks for that info

    I started the system with a different kernel that did not have grsecurity, to verify I ran the command again:

    Linux <hostname> 3.10.9-xxxx-std-ipv6-64 #1 SMP Wed Aug 21 11:38:34 CEST 2013 x86_64 x86_64 x86_64 GNU/Linux

    However I still seem to run into the same issue at the same stage:

    [INFO]: Checking that following required packages are installed...
    [INFO]: PACKAGES: libselinux-utils,policycoreutils,httpd,python-simplejson,ppacommon,python-crypto,python-paramiko,pyOpenSSL,samba-client
    [INFO]: MISSING: None
    [INFO]: Setting SELinux mode to 'Permissive'...
    [ERROR]: Failed to execute command: ['/usr/sbin/setenforce', '0']

    Any ideas?
    Thanks
     
  2. 19patje72

    19patje72 Kilo Poster

    Messages:
    29
    hi Andrey,

    As the OP I have the same problem:

    [INFO]: MISSING: None
    [INFO]: Setting SELinux mode to 'Permissive'...
    [ERROR]: Failed to execute command: ['/usr/sbin/setenforce', '0']

    But at this server also, it is disabled:
    [root@ip-10-144-153-23 tmp]# sestatus
    SELinux status: disabled
    [root@ip-10-144-153-23 tmp]# cat /selinux/enforce
    0
    [root@ip-10-144-153-23 tmp]# uname -a
    Linux ip-10-144-153-23 2.6.18-308.8.2.el5.centos.plusxen #1 SMP Tue Jun 12 16:27:53 EDT 2012 x86_64 x86_64 x86_64 GNU/Linux
    [root@ip-10-144-153-23 tmp]# cat /etc/redhat-release
    CentOS release 5.8 (Final)


    BTW, this is an AWS EC2 instance, would that be a problem?

    thanks, Patrick
     
    Last edited: Oct 1, 2013
  3. AaronMcH

    AaronMcH Mega Poster

    Messages:
    130
    I just tried installing again, however this time inside a Virtuozzo container, and it installed without issue.

    So essentially my issue is fixed, however the main issue still remains.
     
  4. XuânL

    XuânL Bit Poster

    Messages:
    9
    Hmm... there should be 0 or 1 in /selinux/enforce
    Try to run following command:

    # echo 0 > /selinux/enforce
     

Share This Page