Error when try to upgrade server package or install CPAN

Discussion in 'General Discussion' started by Linh Ho, Apr 14, 2015.

  1. Linh Ho

    Linh Ho Kilo Poster

    Messages:
    28
    Hi everyone,

    When i try to upgrade my server and install cpan into this server with yum command (My server uses Centos 6.5), there are some error with perl package, i don't know how to fix it.

    Does anyone know this problem and how to fix it ?
    I want to install cpan to install some PBAs domain plugins.

    The issue is as below:

    Error: Package: hspc-release-4.5.2-21.swsoft.x86_64 (installed)
    Requires: perl(IPC::ShareLite)
    Removing: 4:perl-5.10.1-131.el6.parallels.x86_64 (installed)
    perl(IPC::ShareLite) = 0.09
    Updated By: 4:perl-5.10.1-136.el6_6.1.x86_64 (updates)
    Not found
    Error: Package: hspc-release-4.5.2-21.swsoft.x86_64 (installed)
    Requires: perl:)SWSOFT) >= 5.8.8-16
    Removing: 4:perl-5.10.1-131.el6.parallels.x86_64 (installed)
    perl:)SWSOFT)
    Updated By: 4:perl-5.10.1-136.el6_6.1.x86_64 (updates)
    Not found
    Error: Package: perl-Cache-Cache-1.06-1.noarch (installed)
    Requires: perl(IPC::ShareLite)
    Removing: 4:perl-5.10.1-131.el6.parallels.x86_64 (installed)
    perl(IPC::ShareLite) = 0.09
    Updated By: 4:perl-5.10.1-136.el6_6.1.x86_64 (updates)
    Not found
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest​
     
  2. FedorK

    FedorK Mega Poster

    Messages:
    224
    Linh Ho,

    Which plugin you need to install? All PBAS plugins should be installed without cpan.
     
  3. Linh Ho

    Linh Ho Kilo Poster

    Messages:
    28
  4. FedorK

    FedorK Mega Poster

    Messages:
    224
    Could you create rpm using cpan2rpm tool?
     

Share This Page