Corrupted container "IIS will not start due to WAS service dependency"

Discussion in 'General Questions' started by tmaack, Oct 7, 2013.

  1. tmaack

    tmaack Bit Poster

    Messages:
    5
    Hello,

    We are having issues with multiple Windows Virtuozzo nodes with the same issue. The error (when trying to start IIS):
    Code:
    The IIS Admin Service or the World Wide Web Publishing Service, or a service dependent on them failed to start.  The service, or dependent services, may had an
    error during its startup or may be disabled.
    All of the suggestions by Parallels support has failed, or turned out to only be a temporarily fix. So far, we have worked with multiple KB articles provided by none of them seem to fix anything:
    http://kb.parallels.com/en/1008 - No changes
    http://kb.parallels.com/en/114071 - Worked one time, even after it works it still returns

    So far, I have discovered that:
    - This problem occurs randomly
    - Not all containers are affected, sometimes one, sometimes more
    - Occurs on Windows 2008 R2 SP1 and non-SP1 nodes, 6.1.6700 container 4.6.490.12
    - Rebooting the node temporarily fixes the issue in almost every case

    I tried a chkdsk on the non-working container:
    Code:
    C:\Users\Administrator>vzdskctl mount C:\vz\private\1299\root.efd {46722fb2-67b2-4d9f-8130-e806100b1d86}
    SUCCESS
    
    C:\Users\Administrator>chkdsk /f \\?\Volume{46722fb2-67b2-4d9f-8130-e806100b1d86}
    The type of the file system is NTFS.
    
    CHKDSK is verifying files (stage 1 of 3)...
      93952 file records processed.
    File verification completed.
      128 large file records processed.
      0 bad file records processed.
      85076 EA records processed.
      108 reparse records processed.
    CHKDSK is verifying indexes (stage 2 of 3)...
      143442 index entries processed.
    Index verification completed.
      0 unindexed files scanned.
      0 unindexed files recovered.
    CHKDSK is verifying security descriptors (stage 3 of 3)...
      93952 file SDs/SIDs processed.
    Security descriptor verification completed.
      24746 data files processed.
    CHKDSK is verifying Usn Journal...
      1148256 USN bytes processed.
    Usn Journal verification completed.
    Windows has checked the file system and found no problems.
    
      83886079 KB total disk space.
       8066656 KB in 68785 files.
         51764 KB in 24747 indexes.
             0 KB in bad sectors.
        103023 KB in use by the system.
          4608 KB occupied by the log file.
      75664636 KB available on disk.
    
          4096 bytes in each allocation unit.
      20971519 total allocation units on disk.
      18916159 allocation units available on disk.
    
    C:\Users\Administrator>vzdskctl umount {46722fb2-67b2-4d9f-8130-e806100b1d86}
    SUCCESS
    
    C:\Users\Administrator>vzctl start 1299
    Starting container ...
    Container is mounted
    Container was started
    
    C:\Users\Administrator>vzctl enter 1299
    Microsoft Windows [Version 6.1.7600]
    Copyright (c) 2009 Microsoft Corporation.  All rights reserved.
    
    C:\WINDOWS\system32>iisreset
    iisreset
    
    Attempting stop...
    Internet services successfully stopped
    Attempting start...
    Restart attempt failed.
    The IIS Admin Service or the World Wide Web Publishing Service, or a service dependent on them failed to start.  The service, or dependent services, may had an
    error during its startup or may be disabled.
    
    C:\WINDOWS\system32>net start was
    net start was
    The Windows Process Activation Service service is starting.
    The Windows Process Activation Service service could not be started.
    
    A system error has occurred.
    
    System error 6801 has occurred.
    
    Transaction support within the specified resource manager is not started or was
    shut down due to an error.
    Has anyone else ran into this issue? Thanks!
     
  2. tmaack

    tmaack Bit Poster

    Messages:
    5
    Hello,

    We rebooted the node and this fixed the issue. However, this is not an acceptable solution to the issue as it comes back over and over. A lot of people viewed this topic, but no one responded. We have multiple nodes experiencing this issue (about 15/30 Windows nodes experience this issue). Parallels support has been unsuccessful in fixing the issue along with our support team. Any suggestions?
     
  3. tmaack

    tmaack Bit Poster

    Messages:
    5
    So, no one has ever had this issue at all? Parallels support hasn't been able to fix it either.
     
  4. tmaack

    tmaack Bit Poster

    Messages:
    5
    Basically what you are telling me is Virtuozzo is a piece of ****, and now shitty Parallels changed their name to Odin (wow, original guys) to pretend that their product doesn't suck? Good try. Glad I don't have to work with this **** anymore.
     
  5. Pavel

    Pavel A.I. Auto-Responder Odin Team

    Messages:
    416
    Hello,

    Too bad this thread didn't get attention it needed in 2013. Obviously, neither in 2015 nor in 2016 anyone would've thought it still requires attention.
    I understand it's a bit too late, however, I'd like to leave a reply since someone might come here searching for a solution.

    This is indeed a difficult and rare issue, but recently we've discovered what could've caused this behavior - that's an antivirus or 3rd-party a backup agent working in \vz\private\ directory and subdirectories. Any software that accesses root.efd disk image while CT is running would lead to huge disk fragmentation, transaction log corruption and NTFS errors over time.

    In the end it leads to inability to start WAS service (most time exact trigger is the transaction log corruption).
    Some MS updates could also improve the situation if you were using Windows Server 2008 R2 SP1 (update is not applicable to older versions).

    Also, there are articles that describe immediate fix which would be helpful once container is already damaged:
    https://kb.odin.com/en/117008
    https://kb.odin.com/en/114071

    P.S. I see you have wrong impression on a company re-branding. Re-branding was necessary due to a business re-organization ("home" and "hosting" products were split), you may want to learn about it by reading following article:
    http://blog.odin.com/serviceprovide...e-provider-business-is-now-odin#.Vp9X24195HY=

    It appears you're not impressed with the new brand name, however, Ingram Micro was quite pleased with the brand, even decided to acquire it along with the OSA product and OSA-related company branch:
    http://www.ingrammicrocloud.com/odin-announcement/
    Action proves better than any discussions that brand is worthy.

    Just in case you'll have any questions related to the WAS-related issue I'd be glad to discuss them further.
     
  6. tmaack

    tmaack Bit Poster

    Messages:
    5
    I know right? Too bad the forums were full of spam.

    This was not a rare issue. We had over 50 hardware nodes running Windows Virtuozzo, all different versions, and they all experienced this same issue. Clone it, delete it, remake it, do whatever you want. The only true fix is a node reboot. "ODIN"

    Happened on freshly built servers with brand new hardware.

    They are only temporary fixes. It comes back.

    Rebranding in hopes that people didn't realize it was Parallels, the bad software company? Nothing but problems, most problems your own staff couldn't fix.

    Not at all, Ingram Micro must not be a very smart company if they bought "Odin". The name is unoriginal. The product is junk.

    Thank you for finally responding 3 years later, I am no longer working with "Odin" products so this is no longer relevant to me. We use real virtualization like Vmware and Proxmox these days.
     
    Last edited: Oct 13, 2016

Share This Page