Control panel for customers broken with latest PBAS update

Discussion in 'Troubleshooting' started by ChristianCr, Jan 14, 2014.

  1. ChristianCr

    ChristianCr Kilo Poster

    Messages:
    51
    I've updated to the latest PBAS update (4.5-55). When I now "Login in to CP" as a customer they can no longer manage the subscriptions. They can use the rest of the PBAS Control panel, just not the link/redirect into the control panel for a subscription.

    The system is running PBAS, PPA, and two plesk panel servers (one each of linux and windows). All are patched to the latest levels.

    As far as I can tell this affects them all, whether windows or linux. Is there a know issue? Is there something I should be switching on? We don't yet have full SSL as the system is not yet in production.
     
  2. FedorK

    FedorK Mega Poster

    Messages:
    224
    Hello Christian,

    As I understand when you click button "Login in to CP" from PCC you can see PBAS Control panel but can't see the screens for Plesk and PPA. Right?

    This is not known issue and we never saw it. I not sure that somehow releted to SSL but please check browser warnings. May be be some errors like "can't show unsecury content"?

    If this not helped, could you please post ticket to Parallels support and provide access to your system, development team needs to check this situation.
     
  3. ChristianCr

    ChristianCr Kilo Poster

    Messages:
    51
    I'm not seeing any warnings from the browser.

    If I browse directly to the server on port 8443 I get a security error which I believe is down to client certificate not server certificate, and I had the same issue before which did not cause and issue.

    I'm attaching two images, one from the PBA-S cp interface, the other from logging in as the user from the PPA interface

    PBA-S interface
    pbas-cp-panel.png

    PPA interface
    ppa-cp-panel.png
     
  4. FedorK

    FedorK Mega Poster

    Messages:
    224
    I think problem in following:

    Important: To use PPA 11.5, it is required that PBAS is upgraded to version 4.5. Older
    versions of PBAS do not support PPA 11.5.
    PBAS 4.5 supports only PPA 11.5. Support of PPA 11.1 is dropped in PBAS 4.5. If you use
    PPA 11.1, then upgrade it to the version 11.5 when upgrading PBAS to the version 4.5.

    http://download.pa.parallels.com/pbas/4.5/doc/PBAS_4.5_ReleaseNotes.pdf

    Please upgrade you PPA to 11.5.
     
  5. ChristianCr

    ChristianCr Kilo Poster

    Messages:
    51
    Thank you I will look into this immediately.
     
  6. ChristianCr

    ChristianCr Kilo Poster

    Messages:
    51
    Can you just confirm this. There is now an additional $80 a month charge for PPA?

    If this true, then this was something that we were not expecting, and I have to say somewhat of a cheek that a minor upgrade has suddenly removed the use of anything but the very latest version which there is now an additional cost.

    Does this include the previously required Plesk license.

    But more importantly how do I now roll back to PBA-S 4.5-22,

    I'm not actually sure what the previous version was, but it was working with PPA and a version of 4.5. So I'm a little confused as to why it was saying that PPA 11.1 no longer works with PBAS4.5
     
    Last edited: Jan 16, 2014
  7. FedorK

    FedorK Mega Poster

    Messages:
    224
    Christian,

    You had version 4.3.4-22, this is one version which allow upgrade to 4.5-55.

    PPA 11.5 has new CP and PBAS have to support it and can't support both version 11.1 and 11.5.

    It is not possible to rollback to previos PBAS version. I ask comment PPA team your question about additional charge.
     
  8. Andrew Andriatis

    Andrew Andriatis Odin Team

    Messages:
    437
    Actually, the additional pricing for the Management Node is $35, not $80, because it doesn't require the service node license on top of it. It also includes unlimited language packs and hosting options, such as ColdFusion, Tomcat that previously had to be added to each service node license. If any of these are used in production, the new licensing comes to be less expensive.

    Regards,
    Andrey Andriatis
    Parallels Plesk Automation Program Manager
     
  9. ChristianCr

    ChristianCr Kilo Poster

    Messages:
    51
    I've had problems with this in the past, understanding what is needed to run a system

    Currently we purchase

    1xPBAS 3 reseller license
    1xPBASE 200 client license
    1xWindows Plesk license
    1xWindows Plesk Power Pack license (for MSSQL)
    2xLinux Plesk licenses (one fore the plesk node, 1 for the PPA node). The PPA node does not host or provide customer services

    What do I no longer need (I am hoping the second linux plesk)
    What new license do I need, and where can I get it. It appears not to be available in the parallels store.
     
  10. ChristianCr

    ChristianCr Kilo Poster

    Messages:
    51
    Solution

    I can report upgrading to PPA 11.5 works, though it has been a complete trauma for us.
     
    Last edited: Feb 10, 2014

Share This Page