Can't use "nostop" in psa backup anymore?

Discussion in 'PSA 2.5 Troubleshooting and Problems' started by Ronny, May 25, 2002.

  1. Ronny

    Ronny Guru

    Messages:
    550
    /usr/local/psa/home/vhosts/neogamers.com ... error!
    tar: neogamers.com/logs/access_log: file changed as we read it
    tar: Error exit delayed from previous errors
    An error was occured during execution: "tar -cz -f - -C /usr/local/psa/home/vhosts neogamers.com"

    ===============================================================================



    ****************************************************************************
    * *
    * ATTENTION: DUMP PROCEDURE HAS BEEN ABORTED, BECAUSE AN ERROR OCCURED! *
    * *
    * Using the dump file for restoration is dangerous !!! *
    * *
    ****************************************************************************


    There always seems to be errors creeping up somewhere when we use nostop... Can't it just skip that domain if somethign goes wrong? :/
     
  2. Ronny

    Ronny Guru

    Messages:
    550
    has anyone used nostop with the new BU and worked right?
     
  3. japan-ken

    japan-ken Guest

    --nonstop

    I also have the same problem.
    The problem was not produced in BU_2.5.


    Please help someone.
     
  4. cybertext

    cybertext Guest

    -- nostop with BU utility

    The backup script works fine. But if someone is changing the data (via FTP, etc) while you are trying to make the backup, the script won't handle it. I've had the same error many times. But, hat's a feature not a bug.

    So, simply run the backup utility without --nostop. This way youe PSA will shut down and not allow anyone to make changes while you do the backup.

    If you're worried about your clients being unable to get to their data for 15 or 20 minutes (while psadump is running), then run the backup script at 1:00 AM or something.

    cybertext
     
  5. Dan S.

    Dan S. Guest

    If you are using the --nostop option, I highly recommend disabling anything that provides write access. I usually kill xinetd, the psa admin interface, and courier-imap. This leaves apache and mysql running so that pages are still accessable, but nothing can be written to during the backup.
     
  6. Ronny

    Ronny Guru

    Messages:
    550
    Cybertext, our backup, tarred and gzipped is about 10GB large. It's on a 1ghz duron so it would more than likely take several hours for the backup to finish ;).
     
  7. cybertext

    cybertext Guest

    Oh, I see. Point well taken.
     
  8. Ronny

    Ronny Guru

    Messages:
    550
    I tried stopping all those services, but the dump always stops because the access_log's changed while we read them :/. I believe to stop access_log's from being written to during the dump woudln't u need to stop httpd?
     
  9. Dan S.

    Dan S. Guest

    access_log's can be written to. The nostop option is basically taking a snapshot of each file as it does the backup. If data get's overwritten after it does a snapshot, it wont be backed up. Your problem is something else, if the backup keeps dying.

    Personally I do NOT recommend using the nostop option on a full backup.
     
  10. japan-ken

    japan-ken Guest

    BU2.5n

    When is at BU2.5. -- NOSTOP was able to be specified and it was able to back up.
    Is it a problem peculiar to BU 2.5.1?
     
  11. Cranky

    Cranky Guru

    Messages:
    2,657
    Would it be possible to disable access_log's for a domain if they're causing a problem? (I'm having the same trouble on PSA 5.0.5)
     
  12. moefid

    moefid Guest

    use :
    --nostop --tar-ignore-failed-read
     
  13. Cranky

    Cranky Guru

    Messages:
    2,657
    Will --tar-ignore-failed-read prevent the restore from working under any circumstances or will it just result in a couple of corrupt files - particularly the access_log's which don't really matter?
     

Share This Page