Cache not re-generating

Discussion in 'Troubleshooting' started by JoãoB, Aug 4, 2014.

  1. JoãoB

    JoãoB Bit Poster

    Messages:
    4
    Here is what's happening right now:
    I have a version of PBA-S, and I'm currently customizing it. One of the changes I'm implementing is adding a domain search bar on all tabs. When someone searches a domain on that bar, it is redirected to the domains tab.
    But my problem is to have the routing working. I've already changed the hspc-store/includes/routing_custom.yml and the hspc-store/includes/Entity/ControllerCustom.php, but my problem is with the cached files. When I try to delete the cached files, in order for them ro be re-built, they are not doing anything.
    Is there any extra step required to re-build the cache files after I've deleted them?
     
  2. FedorK

    FedorK Mega Poster

    Messages:
    224
    Hello,

    You delete cache files, refresh store in you browser but files ProjectUrlGenerator.php and ProjectUrlMatcher.php doesn't created?

    Please check log file /var/log/hspc/store.log may be you make mistake in your routing.

    Thank you.
     
  3. JoãoB

    JoãoB Bit Poster

    Messages:
    4
    Ok, I managed to figure out what I was doing wrong. It has something to do with using tabs on routing_custom.yml
    But my problem now is by calling http://mydomain/shop/en/domains. It just says "An error occurred", and on the store.log, the error says "No Response object received".
    Is there an easy way to directly call the domain tab using a URL?
     
  4. dkolvakh

    dkolvakh Odin Team

    Messages:
    355
    Hello.

    You can use the following pre-defined url to access Domains tab directly: https://mydomain/shop/en/redirect/c_domains
    Also, there is a possibility to pass data for domain lookup, please refer to PBAS SDK for more details.
     

Share This Page