Bug: Registering a new domain as existing customer

Discussion in 'Plesk Automation Suggestions and Feedback' started by GregorL, Oct 29, 2011.

Thread Status:
Not open for further replies.
  1. GregorL

    GregorL Kilo Poster

    Messages:
    65
    Settings:
    ------------
    OpenSRS in test mode.

    Reproduce:
    ---------------
    Login as enduser.
    Account Tab
    "Add Subscription"
    Click "Buy Now" Button under Domains section.
    Enter Domain under "Register a domain name"
    Checkmark the .com for example.
    Click Checkout
    Click Next
    Click Next
    "Agree to terms and conditions"
    Check Payment.
    Click confirm order.

    The process takes 6 minutes in my tests.
     
  2. Blake@Parallels

    Blake@Parallels Mega Poster

    Messages:
    216
    Hi Gregor,

    Is the bug that it takes 6 minutes? The billing system has an events queue that kicks off every 5 minutes to run all billing related tasks (generating invoices, processing payments, provisioning orders, etc) - this probably accounts for your observed 6 minutes total time since submitting the order. Is 6 minutes too long?
     
  3. GregorL

    GregorL Kilo Poster

    Messages:
    65
    The problem is, the browser actually hangs for 6 minutes waiting for the system.
    The little ajax spinning circle is spinning during that time.
     
  4. Blake@Parallels

    Blake@Parallels Mega Poster

    Messages:
    216
    Ah, so this happened immediately after confirming the checkout? In this case, the problem would be in a different area of the system (system processing queue previously discussed would not come into play here).

    What payment method did you choose during checkout? If something other than Invoice/Check, how are your payment gateways configured?
     
  5. GregorL

    GregorL Kilo Poster

    Messages:
    65
    Yes, it happens immediately after clicking "confirm order".
    I chose Check Payment, so there should be no delay in connection with a payment gateway.
     
  6. Andrew Andriatis

    Andrew Andriatis Odin Team

    Messages:
    437
    Thanks. We reproduced the problem. Will be fixed.
     
Thread Status:
Not open for further replies.

Share This Page