Beta versions of the Plesk 6 Backup and Restore (BU) utilities Updated!

Discussion in 'Plesk 6.0 Suggestions and Feedback' started by Todd L. Crumpler, Aug 21, 2003.

  1. Todd L. Crumpler

    Todd L. Crumpler Odin Team

    Messages:
    101
    Final versions of the Plesk 6 Backup and Restore (BU) utilities released!

    Final versions of the Plesk 6 Backup and Restore (BU) utilities released!

    SWsoft has released the final build of the BU utilities for 6.0.1 version of Plesk 6.

    We wish to extend a special thank you to all the users who volunteered to help test the beta builds and reported bugs. Your assistance is invaluable and we sincerely appreciate your reports.

    To download the utilities, please follow this link:

    https://www.plesk.com/Downloads/utilities.php

    Best regards,

    Todd L. Crumpler
    SWsoft, Inc.
     
  2. CosmicD

    CosmicD Tera Poster

    Messages:
    284
    I'm getting a "not found" error... or am i just too early...:)
     
  3. Todd L. Crumpler

    Todd L. Crumpler Odin Team

    Messages:
    101
    Try it Now!

    Try it Now please!
     
  4. CosmicD

    CosmicD Tera Poster

    Messages:
    284
    OK, now it works :)
     
  5. eilko

    eilko Guru

    Messages:
    767
    can I restore a PSA5.05 dump on a PSA6.01 machine with these tools? Anyone tried yet?
     
  6. willlangford

    willlangford Tera Poster

    Messages:
    288
    Todd,
    Anyword on what 6.0.2 will fix? Or is it just a peace offering for all the opps with 6?

    ~Will
     
  7. LithiuM

    LithiuM Guest

    I could not successfully restore from backup.

    First I backup a psa6 test server (600 domains)
    Then I deleted 2 clients (300 domains)

    Then I start restore process...

    It started passing for each domain :
    Unpacking certificate xxxxx.net public key ... done
    Unpacking certificate xxxxx.net private key ... done

    And it waited for about 11-12 seconds for each line.. (24 sec. for one domain)

    after waiting about 2 hours (I thought it is still in the middle of the restore) I shut the server down.... Because it seems like I have to wait 2 hours more to complete public/private key thing (4hours total)

    That test server could fully restore same 600 domains on psa5 in 45-50 minutes.....


    -
     
  8. Cranky

    Cranky Guru

    Messages:
    2,657
    Still up for a release this week?
     
  9. willlangford

    willlangford Tera Poster

    Messages:
    288
    lets just hope..but personally i wouldnt bet on it.

    ~Will
     
  10. Cranky

    Cranky Guru

    Messages:
    2,657
    Plesk 7 will be out first if they take much longer. :(
     
  11. proweb

    proweb Guest

    where to is the backup interface in the control panel? (or am i just blind :D )

    Chris
     
  12. lawyer@

    lawyer@ Odin Team

    Messages:
    21
    Just go to the domain control page and look for 'Backup' button which is in second row at the right.
     
  13. willlangford

    willlangford Tera Poster

    Messages:
    288
    i wish there was a way to do a whole system backup too.

    ~Will
     
  14. blade21

    blade21 Guest

    5.x to 6.x

    Hi

    Is it possible to do a backup on a 5.x server and restore it on a 6.x server?

    A quick answer would be apriciated, im going to move a hole server today, and im not pleased with the thougt of doing it manually :rolleyes:
     
  15. Cranky

    Cranky Guru

    Messages:
    2,657
    Hi,

    No it's not possible. You'd need to upgrade the PSA5 server to Plesk 6, then backup and restore on another Plesk 6 box.
     
  16. blade21

    blade21 Guest

    ok then :)

    Im a newbie in this so i dont quite understand the psadump/restore commands.

    How do i backup a single domain with mail and databases? and restore it :)
     
  17. Cranky

    Cranky Guru

    Messages:
    2,657
    It's all explained in the documentation.
     
  18. proweb

    proweb Guest

    I think im in the right place, "Dumps files management for domain domain.com"

    Maybe it is just me alhough i just downloaded a dump file, restored it, went to the site and all pages apart from index.html are giving 404s, also cgi-bin files are giving 404 errors even though they do exist (the files show in ftp) , cgi files had gone, ftp login didnt work (password must have been reset)

    anyone else getting these problems?

    Thanks
    Chris
     
  19. CosmicD

    CosmicD Tera Poster

    Messages:
    284
    Hello,

    I was testing the BU utils and it seems that I have some errors.. I'd like to show it here as my mailprogram seems to send dump result emails to me. I already wondered why some sites seemed to backup nicely while others don't..

    ALso I don't have enough space in my /var/lib/psa/dumps partitions... so here goes,


    START LOGGING: Wed Aug 27 22:24:21

    [Wed Aug 27 22:24:22 2003] dumping postgres database forum ... error!
    pg_dump: [archiver (db)] connection to database "forum" failed: FATAL 1: Password authentication failed for user "postadmin"

    An error was occured during execution: "export PGUSER=postadmin; export PGPASSWORD=************* /usr/bin/pg_dump -Fp forum"

    ===============================================================================



    ****************************************************************************
    * *
    * ATTENTION: DUMP PROCEDURE HAS BEEN ABORTED, BECAUSE AN ERROR OCCURED! *
    * *
    * Using the dump file for restoration is dangerous !!! *
    * *
    ****************************************************************************

    Or could it be that postgres databases cannot be upgraded ?

    cd
     
  20. Todd L. Crumpler

    Todd L. Crumpler Odin Team

    Messages:
    101
    Reporting bugs...

    All,

    Its fine to discuss problems and fixes in this forum but for beta versions of the software its even more helpful to report issues to bugreport@plesk.com.

    This helps us to verify and fix issues much faster and is the purpose for testing beta software. Please feel free to post your issues here but do so in conjunction with a report of your issue to the bugreport email.

    Best regards,

    Todd L. Crumpler
    SWsoft, Inc.

    PS Thanks for all of your emails to bugreport and keep them cards and letters coming... Even if you don't get an answer right away we are listening and will try to verify and fix what you find.
     

Share This Page