Backups in VA 7

Discussion in 'General Questions' started by SteveITS, Apr 7, 2017.

  1. SteveITS

    SteveITS Tera Poster

    Messages:
    251
    I migrated from VA 6 to VA 7, and upgraded our backup node to Virtuozzo 7.

    1) Backups from Virtuozzo 6 hardware nodes are failling with:

    "Operation with the Container "name" is finished with errors: Unable to perform remote operation. The target host does not have the necessary PVA components installed or is running an incompatible operating system.."

    2) Am I correct in reading the documentation that VA 7 does not allow browsing of and restoring only certain files to a Virtuozzo 7 container? It only allows wiping and restoring the entire container? (http://docs.virtuozzo.com/virtuozzo...vironment-level.html#browsing-backup-contents)
     
    Last edited: Apr 7, 2017
  2. Pavel

    Pavel A.I. Auto-Responder Staff Member

    Messages:
    475
    Hello Steve,

    1) AFAIK this should have been solved in VA 7 update 1. What is your version? Of both agent and MN
    2) VZ7 uses different backups. vz6 was creating acronis-based backups which caused quite a number of problems for us, thus in vz7 we use our own backup which is more reliable, however, does not allow selective restore. So answer is "yes".
     
  3. SteveITS

    SteveITS Tera Poster

    Messages:
    251
    Hi Pavel,

    I was editing my post just as you replied. Virtuozzo 6 nodes and the VA 6.1 agent are both fully up to date. The backup node upgraded from Virtuozzo 6 (fully updated) to 7.0.3.

    re: browsing...rats, that makes the backup sort of useless for our purposes. Most of our restores have been one web site or one database. We'd have to restore it to a different/new container to get to the files. Well, I had a "backup plan" for backups before, using rdiff-backup (diff and rsync), I guess we can go back to that. We will probably end up saving disk space anyway, actually.
     
  4. Pavel

    Pavel A.I. Auto-Responder Staff Member

    Messages:
    475
    Hi Steve,

    1) What about VA MN version? It's the most important here :)

    2) Sad to hear that backups are less helpful now :(
    Note though, Virtuozzo allows you to attach backup-as-a-disk to CT/VM. This functionality is not present in VA though, but works great from command line
     
  5. SteveITS

    SteveITS Tera Poster

    Messages:
    251
    Sorry I see I didn't write about the VA MN. It was installed yesterday so should be up to date. We used the procedure to migrate the VA 6 data (http://docs.virtuozzo.com/virtuozzo_automator_7_administrators_guide/upgrading-va/index.html). I don't see a version number in the web GUI but packages include:

    va-mn 7.1.5-6.va7 x86_64 Virtuozzo Automator Management Server Up-to-date
    va-mn-controls 7.1.4-3.va7 x86_64 Virtuozzo Automator Management Node backend controls Up-to-date
    va-mn-core 7.1.17-1.va7 x86_64 Virtuozzo Automator Management Server core Up-to-date
    va-mn-release 7.1.0-1.va7 noarch Virtuozzo Automator release meta-package. Up-to-date

    Thanks for pointing out attaching a backup as a disk, I can look into that.
     
  6. Pavel

    Pavel A.I. Auto-Responder Staff Member

    Messages:
    475
    You can find version in UI in Management -> Support tab.
    However, provided versions are enough - I can see you're using VA from the factory (unstable), and it's the latest one. It should have the fix in it already.
    Please contact technical support to investigate this - VA cases are always tricky to investigate and will require direct access, forum is not fit for such things.
     

Share This Page