all whois servers say "Invalid argument"

Discussion in 'General Discussion' started by gm22, Aug 25, 2007.

  1. gm22

    gm22 Kilo Poster

    Messages:
    32
    I'm setting up a domain plugin, e.g., RuCenter for .ru domains.
    I selected to use Ripe NCC as a whois server with default settings.

    When I check for a domain, I get "whois.ripn.net: Invalid argument"

    Same things happen with all other whois servers/ TLDs.

    What an I doing wrong here?

    I'm a new HSPC user.

    Thanks.
     
  2. vbatraev

    vbatraev Odin Team

    Messages:
    346
    Ripe NCC with following settings works fine for me:
    .

    Try to execute
    #whois -h whois.ripn.net bash.org.ru
    command on management node.

    If it works could you post your settings here, so we will be able to help you.
    Another option to get help would be to contact SWsoft support.
     
  3. gm22

    gm22 Kilo Poster

    Messages:
    32
    Hi -
    SwSoft support is very good - they just fixed it for me. It was a resolution issue - whois.ripn.net would not resolve.

    I successfully registered first .ru domain.

    Now, another problem - with registration of .com/net/org domains. While I wait to hear back from support, maybe someone here could help.

    com/net/org domain checks work fine, but when I go ahead and try to register one - i.e., Domains > New Domain > Register new
    domains(s) [ Select Domain Registration Plan], then, do a search for,
    say, test123test.com - I get error "test123test.com - Error
    occurred during domain lookup."

    Is it something obvious I could fix - where should I look?

    I should add that this is using Internic whois server ( I tried other ones on the list), and OpenSRS plugin.

    Thanks.
    GM
     
  4. vbatraev

    vbatraev Odin Team

    Messages:
    346
    OpenSRS plug-in uses registrar API to check domain availability. Most probably the error appears because of incorrect plug-in configuration. Please make sure that the config is correct.

    Could you check /var/log/hspc/hspc.log for entries like:
    and post 'response_text', 'response_code' here, so we will be able to help you.
     

Share This Page