alert: unable to opendir info/0, sleeping...

Discussion in 'PSA 1.3.1 Troubleshooting and Problems' started by ridwan, Sep 5, 2001.

  1. ridwan

    ridwan Kilo Poster

    Messages:
    33
    hi forum.

    i really need some advice to get out of this mess.
    the last 24 hours all domains on my machine cannot get any mail delivered to their mailbox.

    from qmail-qstat:
    messages in queue: 5467
    messages in queue but not yet preprocessed: 2176

    from qmail-qread:
    3 Sep 2001 22:39:35 GMT #1602502 897 <root@mydomain>
    3 Sep 2001 22:39:45 GMT #1602755 905 <root@mydomain>
    .. and more that 7500 lines like this ..

    on my maillog file, there are lines:
    Sep 5 15:43:44 localhost qmail: 999719024.251442 alert: unable to opendir info/0, sleeping...
    Sep 5 15:43:54 localhost qmail: 999719034.261442 alert: unable to opendir info/0, sleeping...

    is my server hit by mailbomb?
    or, qmail queue was corrupted?

    any help would be apriciated.

    thanks in advance,
    Ridwan
     
  2. dirty@

    dirty@ Guest

    first check that qmail/queue/info/* exist and permissions = 700 qmails:qmail
     
  3. dirty@

    dirty@ Guest

    also check that your qmail doesn't began autoresponders war.. somewhere in forum was a script that set autoresponders replies to once in a day.
     
  4. ridwan

    ridwan Kilo Poster

    Messages:
    33
    thanks.
    the ownership had changed to qmailq:qmail
    dunno how..

    but qmail works again after i changed the ownership of queue/info.

    i also noticed that the autoresponder did the war with some other server :(
    i forgot to make the root and postmaster, there was about 65000 and more mails in my queue..

    after i put the script, it strated deleting the bouncing bounce.

    but now i have the other problem.

    my maillog did not log the qmail anymore.
    it stopped at sept 7, and there's no log written to it.

    i noticed the blink at /var/mail -> /var/spool/mail
    afaik, there's something wrong with my symbolic link above.
    but the mail direktori is still there..

    i have created the new one, with the right permission and ownership, but the 'ls' is still blinking.

    what is the right ownership for:
    /var/mail -> /var/spool/mail
    /var/spool
    /var/spool/mail

    i checked the 'lsattr', but there's no second level permission for that file, or should it be?

    thanks,
    Ridwan
     
  5. dirty@

    dirty@ Guest

    > my maillog did not log the qmail anymore.
    > it stopped at sept 7, and there's no log written to it.

    if you have not changed any qmail preferences, this sutuation means only that qmail doesn't started. or no mail messages has been received.

    > what is the right ownership for:
    > /var/mail -> /var/spool/mail

    please, forget about this catalog and any links. PSA 131 keeps all mailboxes for all virtual domains in /usr/local/plesk/qmail/mailnames/
     
  6. ridwan

    ridwan Kilo Poster

    Messages:
    33
    ok. then..
    how to make qmail starts?
    i did restart plesk, but there's nothing.

    still queue increasing from 2000 to 4000 mails.

    my maillog file was locked with 'i' from second level permission, but i have removed, the ownership was root:bin.
    what is the right permission and ownership for /var/log/maillog ?

    regards,
    ridwan
     
  7. philb@

    philb@ Kilo Poster

    Messages:
    49
    I created a shortcut in bashrc that does this:

    alias pl='/etc/rc.d/init.d/plesk'

    Now, I can stop and start plesk with

    pl stop <enter>
    pl start <enter>

    You can also use (but I like short commands)

    service plesk stop
    service plesk start
    or
    /etc/rc.d/init.d/plesk stop
    /etc/rc.d/init.d/plesk start

    So, I generally submit a plesk stop command and then run

    ps ax <enter>
    Look in that list for anything related to Plesk, like httpd, mysql, qmail, stunnel, etc. If any of them are running (except qmail or proftpd), you can kill them off right away by using

    kill -9 processid

    where processid is the number in the left column. This will kill processes one at a time by their process id.

    Repeat this process until you have all the Plesk processes killed.

    Wait a short time for the qmail processes to time out. It should not take more than two minutes. If after two minutes there are any qmail processes still running, kill them one at a time. Generally, I never find it necessary to kill or restart proftpd, and it's not part of the plesk stop/start script, so mostly, you can just leave it alone. It seems to run forever without problems.

    Once you have all of the Plesk processes stopped, you can start the Plesk server again with pl start.
    This may not fix your problem, but it is a sure way to get a clean restart without a reboot.
     

Share This Page