Add NODE to HSPC

Discussion in 'Troubleshooting' started by AbY28, Nov 24, 2008.

  1. AbY28

    AbY28 Bit Poster

    Messages:
    8
    Hello,

    I have install HSPC Business Automation, all work, i have add an NODE Windows, with this : http://kb.odin.com/en/3598 its ok :)
    Now, i need to add an Linux Node (CENTOS), install Virtuozzo ok. I have try to add this node to my hsp but i have an error of keys to the node transaction.
    i have follow this link : http://kb.odin.com/en/3587 but not work.
    I have check to connect to the node with my HSP with this line :

    #su - apache
    #ssh -v vzagent0@<service_ve_ip>

    I not have password ! I have check with this command line : #vzctl set 1 --userpasswd vzagent0:mypass --save
    for reset the password, password change and save, but when i connect to the node, wrong password ! i have stop/start or restart vzagent and physical reboot, not work.

    Do you have an idea im crazy now ?

    Realy thanks
     
  2. vbatraev

    vbatraev Odin Team

    Messages:
    346
    "...but when i connect to the node, wrong password..."

    Is it mean that you use hw node IP when try to add new node?
    You should use Service_CT_IP/vzagent0_password combination.
     
  3. AbY28

    AbY28 Bit Poster

    Messages:
    8
    thank you for your reply.
    To add the node Linux, I use HSPC pcc web console > Service Director> Virtuozzo Manager> Nodes> New Node.
    IP and Password of vzagent. And i have this error : An error occurred while copying the key was forwarded to the Hardware Node.

    An idea ?

    Thanks
     
  4. vbatraev

    vbatraev Odin Team

    Messages:
    346
    Is there any errors when you connect to service container through SSH from PBAS node?

    #su - apache
    #ssh -v vzagent0@<service_ve_ip>
     
  5. AbY28

    AbY28 Bit Poster

    Messages:
    8
    I have try this and reset .ssh key to the file after reset password, restart-start/stop vzagent..., but not work, wrong password....

    other idea ? Im lost !

    Thanks

     
  6. vbatraev

    vbatraev Odin Team

    Messages:
    346
    Try the following:
    1. make sure there is no container with the same IP as on the service CT.
    2. make sure that correct password for the service CT was set. Try to connect to the service CT as vzagent0 user through ssh from the hardware node. Also you may enter to the service CT using "vzctl enter 1" command and reset password from there.

    If you are 100% sure that correct password is set, you connect to the right server and you are still getting the error, then try to add public key manually.
     
  7. AbY28

    AbY28 Bit Poster

    Messages:
    8
    ok, i have check with an other server, i have install SUSE 10.
    Virtuozzo install with the auto installer : http://download.parallels.com/virtuozzo/virtuozzo4.0/linux/vzinstall-linux.bin

    install ok all work !

    Now, check connectivity to the node with HSPC. I add the node, and ...... error !! key transaction .....
    ok i connect to the new virtuozzo, check the status of vzagent, is stoped !
    so, i use this command line : /usr/sbin/vzagent_compat_ctl start
    vzagent start now !

    Be back to the HSPC, i click to add, suspence..... error :An error occurred while copying the key was forwarded to the Hardware Node.

    humm

    ok, connect to the virtuozzo with HSPC server : command line :

    #su - apache
    #ssh -v vzagent0@<service_ve_ip>

    bad password, acces denied !

    humm, ok im connecte to the virtuozzo, use this command to update password :

    #vzctl set 1 --userpasswd vzagent0:mypassword --save

    be back to the HSPC, i click to add, suspence..... error :An error occurred while copying the key was forwarded to the Hardware Node.

    humm

    ok, peaps vzagent need restart !
    Connecte to the virtuozzo, use this command line :

    /usr/sbin/vzagent_compat_ctl stop
    /usr/sbin/vzagent_compat_ctl start

    be back to the HSPC, i click to add, suspence..... error : An error occurred while copying the key was forwarded to the Hardware Node.

    humm

    ok,
    i check SSH key, all good, peaps error ?
    i delete the key on HSPC .ssh

    reconnect to the server with this command line :

    #su - apache
    #ssh -v vzagent0@<service_ve_ip>

    bas password, acces denied !

    Ok, peaps SSH key wrong !
    I connect to the HSPC, delete SSH key, and past the key directly !

    Re re re re connecte to the HSPC web, add node, ip and pass, suspence....... error : An error occurred while copying the key was forwarded to the Hardware Node.

    ok, i have check all possibility, all KB, i use 2 os plateforms (SUSE and CENTOS), do you have an idea ? Im realy crazy with this software, HSPC work with NODE windows but Linux **** ! why ?

    Realy thanks for ur reply
     
  8. AbY28

    AbY28 Bit Poster

    Messages:
    8
    News : I have found this on ur faq ...

    # vzctl set 1 --ipdel all --ipadd public_IP_address
    --userpasswd vzagent0:**********
    * Restart the Parallels Agent software on the Hardware Node:
    # vzagent_ctl restart

    I check and report result here.
     
  9. AbY28

    AbY28 Bit Poster

    Messages:
    8
    Not work, im crazy !!
     
  10. tdcmystere

    tdcmystere Bit Poster

    Messages:
    4
    Find a solution :)

    on Virtuozzo

    vzctl set 1 --ipdel all --ipadd public_IP_address --save
    --userpasswd vzagent0:**********

    vzctl enter 1
    passwd vzagent0

    (2x your password new)

    ok

    on PBA

    su apache
    bash-3.2$ ssh -v vzagent0@your ip here -i /usr/local/pem/etc/ssh-keys/vem.key.sec

    after it you vill se this :)


    bash-3.2$ ssh -v vzagent0@xx.xx.xx.xx -i /usr/local/pem/etc/ssh-keys/vem.key.sec
    OpenSSH_4.3p2, OpenSSL 0.9.8b 04 May 2006
    Warning: Identity file /usr/local/pem/etc/ssh-keys/vem.key.sec not accessible: No such file or directory.
    debug1: Reading configuration data /var/www/.ssh/config
    debug1: Reading configuration data /etc/ssh/ssh_config
    debug1: Applying options for *
    debug1: Connecting to xx.xx.xx.xx [xx.xx.xx.xx] port 22.
    debug1: Connection established.
    debug1: identity file /var/www/.ssh/identity type 0
    debug1: identity file /var/www/.ssh/id_rsa type -1
    debug1: identity file /var/www/.ssh/id_dsa type 2
    debug1: loaded 3 keys
    debug1: Remote protocol version 1.99, remote software version OpenSSH_3.6.1p2
    debug1: match: OpenSSH_3.6.1p2 pat OpenSSH_3.*
    debug1: Enabling compatibility mode for protocol 2.0
    debug1: Local version string SSH-2.0-OpenSSH_4.3
    debug1: SSH2_MSG_KEXINIT sent
    debug1: SSH2_MSG_KEXINIT received
    debug1: kex: server->client aes128-cbc hmac-md5 none
    debug1: kex: client->server aes128-cbc hmac-md5 none
    debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
    debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
    debug1: Host 'xx.xx.xx.xx' is known and matches the RSA host key.
    debug1: Found key in /var/www/.ssh/known_hosts:2
    debug1: ssh_rsa_verify: signature correct
    debug1: SSH2_MSG_NEWKEYS sent
    debug1: expecting SSH2_MSG_NEWKEYS
    debug1: SSH2_MSG_NEWKEYS received
    debug1: SSH2_MSG_SERVICE_REQUEST sent
    debug1: SSH2_MSG_SERVICE_ACCEPT received
    debug1: Authentications that can continue: publickey,password,keyboard-interactive
    debug1: Next authentication method: publickey
    debug1: Trying private key: /var/www/.ssh/id_rsa
    debug1: Offering public key: /var/www/.ssh/id_dsa
    debug1: Authentications that can continue: publickey,password,keyboard-interactive
    debug1: Next authentication method: keyboard-interactive
    debug1: Authentications that can continue: publickey,password,keyboard-interactive
    debug1: Next authentication method: password
    vzagent0@xx.xx.xx.xx's password:
    debug1: Authentications that can continue: publickey,password,keyboard-interactive
    Permission denied, please try again.
    vzagent0@xx.xx.xx.xx's password:
    debug1: Authentication succeeded (password).
    debug1: channel 0: new [client-session]
    debug1: Entering interactive session.
    debug1: Sending environment.
    debug1: Sending env LANG = en_US.UTF-8
    <packet xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" id="0" priority="0" version="4.0.0">
    <origin>vzclient3-818bd4a3-6b82-a04a-8ac1-5f6b8e527a18</origin>
    <target>agent</target>
    <data>
    <ok/>
    <eid>818bd4a3-6b82-a04a-8ac1-5f6b8e527a18</eid>
    </data>
    </packet>
    debug1: client_input_channel_req: channel 0 rtype exit-status reply 0
    debug1: channel 0: free: client-session, nchannels 1
    Connection to xx.xx.xx.xx closed.
    debug1: Transferred: stdin 0, stdout 0, stderr 37 bytes in 30.0 seconds
    debug1: Bytes per second: stdin 0.0, stdout 0.0, stderr 1.2
    debug1: Exit status 0
     

Share This Page